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LASER EDITOR

<>
1- WELCOME

About this Help System

This Help System is designed for users who will be using Laser Editor to create graphics layouts for laser

engraving operations.

Using the Help System:

You might access the whole contents by choosing Help > Help from the Laser Editor's menu bar, or
pressing F1 in the main screen of the application.

Furthermore, you can take advantage of the context-sensitive Help, that is, you can display a Help topic

based on what you are doing:

e Pressing F1 (or the ? button in a window's title bar) opens dialog or window level Help;

e clicking a properties title in the Properties window (such as, for example, Geometry) when working
on a document or a graphic object, then pressing F1, opens a table with a description of those

properties.

Contents of the Help:

The Help is organized into the following main topics:

Chapter

Getting started with Laser Editor
Preliminary operations
Creating graphic layouts

Performing the engraving operation

Laser Engine User Interface

Contents

Presents an overview of the product in terms of scope, architecture,
and User Interface.

Describes how to register Laser Editor as well as how to set the
default parameters for the application.

Describes how to create a graphic layout by adding objects to a
plane or ring document, and how to operate on objects.

Provides instructions on how to test your graphic layout and how to
complete the laser engraving operation.

Describes how to use the Laser Engine user interface.
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2- GETTING STARTED WITH LASER EDITOR

This chapter is organized into the following sections:

Topic What you will learn

Scope and overview of Laser Editor's features, and

About Laser Editor architecture of the new laser marking units.

Quick reference guide in terms of work environment, toolbars,

Laser Editor's User Interface quick reference and menus of Laser Editor.
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About Laser Editor

Laser Editor is the ultimate laser marking software suite that allows users to easily mark, etch, or engrave
product identification information such as 2D matrix codes, linear barcodes, postal codes, stacked bar codes,
text including any industry standard font formats, alpha-numeric serial numbers, date codes, part numbers,
graphics and logos in any production environment.

Laser Editor represents an evolution of the development undertaken with the previous program Smartist.

Laser Editor is a complete laser marking system that can be used for:
e graphic layouts editing

e laser devices fine-tuning and control, including an integrated I/O module for axis management that
allows integration into a production line or other marking equipment

o fully customization by creating automated procedures
e easy integration into assembly lines with or without PC

What's new in Laser Editor

Laser Editor has a new smart and intuitive graphic interface which has been localized into several
languages. A context-sensitive help system guides you through the procedures for creating and marking your
layouts.

Furthermore, new powerful and flexible features have been added.

New graphic editing features have been added, including but not limited to:
e improved vectors editing capabilities
e advanced vectorial processing features for automated editing of nodes
e new import filters
e advanced filling patterns are supported
e acomplete "Array" feature specially designed for Integrated Circuits (IC) marking
e interactive marking time evaluation function
e marking order optimization feature
e mark preview capability (implemented at scripting editor level too)
e undo/redo capabilities

(For further information, see Creating graphic layouts).

New advanced features have been added:
e 4 axis motor control for rotary indexers, Z axis, Rotor axis, X-Y tables, and so forth
e Built-in /O module for external equipment control
e "On the fly" marking capabilities with a configuration wizard
e Remote control of the marking process over Ethernet

e User control and password management
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A fully programmable application:

e Project Editor, a new powerful programs editor, has been added. You can create your own
programs and automation tools:

0 update the layout contents at runtime

load and mark documents

collect data from external sources or database systems
build a custom user interface

use advanced debugging functions

O O O O o©o

and much more

Project Editor is supplied with source files samples, reference material, and a context-sensitive Help system.

ActiveX interface (licensed feature)

ActiveX interface has been added to Laser Engine. This provides users that are familiar with Smartist
ActiveX programming a similar way to easily write custom graphic interface on top of Laser Engine without
dealing with the details of low level laser controlling.

Note:
A Plugins are not available when using ActiveX. For more details, please refer to the Project Editor
online documentation, chapter "Language reference".

Related topics:
e Laser Editor's User Interface quick reference
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Laser Editor's User Interface quick reference

This section provides an overview of the Laser Editor User Interface to be used as a quick reference, and in
particular:

e Work environment- How the Laser Editor's environment is organized

e Using toolbars tools- A quick overview of the available toolbars buttons

Work environment
The picture below shows the main window of Laser Editor when you access it:

10



GETTING STARTED WITH LASER EDITOR

Work environment components:

Tip:
For a more detailed description of how to display, hide, or dock the components of the work
environment of Laser Editor, please refer to Setting your work environment.

Area |Description
@ Menu bar with all the Laser Editor commands.

Toolbars with the tools that allow you to:

e draw and manage the engraving layout (see Using toolbars tools)

e interact with the laser device (see Laser toolbar.)

@ e manage user rights on the system functions (see Laser Engine chapter, section Managing
users and access rights

You can display a toolbar by selecting the corresponding button in the vertical Select toolbar.
Furthermore, you can hide/display toolbars by right-clicking a blank area in the upper part of the
window.

subset of horizontal toolbar buttons.

@ Select toolbar - The vertical toolbar allows switching between toolbars. Each buttons activates a
You can hide/display this toolbar by right-clicking a blank area in the toolbars area.

Undo/redo command list - It lists all the actions that you have performed during layout editing, It
allows keeping track of all actions, and undoing or redoing any of these actions. To undo/redo an
action, select it, then do one of the following:

./
@ e click the S Wt buttons on the toolbar

e choose Edit > Undo (or Redo) from the menu bar

The Undo/redo window can float over the work area, or you can dock it at the left-side of the window,
just below the toolbars, by double-clicking its title bar. Furthermore, you can hide/display this window
by right-clicking a blank area in the toolbars area.

Objects engraving order - It shows the order in which the objects that were added to the document
will be engraved. To change the marking order, drag the objects to the desired position. To optimize
»

@ the marking order, you can use the = Marking order function that is made available after clicking

the 'J%J Adjust Objects button on the vertical toolbar.

This window can float over the work area, or you can dock it at the left-side of the window, just below
the toolbars, by double-clicking its title bar. Furthermore, you can hide/display this window by right-
clicking a blank area in the toolbars area.

Work area - The graphic work area where the engraving layout or the sequence will be represented.
When you select File > New plane (or ring) document, the document is displayed in this area. You
might work on more documents at the same time; in this case, at the top of the work area, the

. . Documentd* _
@ documents tabs will be displayed . ooc =" b l to allow you to switch between

documents. To close an individual document, click the EJ button at the top-right of the area.

.! Attention: The maximum width of the work area is defined by the focus length set in Laser
Configuration. (See Setting the work area.)

11
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Properties browser - It tells you information (that is, settings) about any selected object in the work

area. Documents are treated as objects in Laser Editor; so, if no object is selected, the document's

properties are displayed. The Property browser can float over the work area, or you can dock it at the
® right-side of the window, just below the toolbars, by double-clicking its title bar. Furthermore, you can

hide/display this window by right-clicking a blank area in the toolbars area.

The property browser supports context-sensitive Help: Clicking a properties title (e.g., Geometry) and

then pressing F1, opens a table with a description of those properties.

e Status bar -It shows name and status of the connected laser device. Furthermore, when the mouse
pointer rests on a toolbar button, a brief descriptions of the button is displayed in this area.

Using toolbars tools
In this section:
e Vertical vs. horizontal toolbar

e Standard toolbar

)
e ./ Insert Objects toolbar

o 'O Objects Operation toolbar

. '%’:‘ Adjust Objects toolbar

. “k Zoom toolbar

&

e 77 Lasertoolbar

Vertical vs. horizontal toolbar
Laser Editor has a vertical toolbar (the select toolbar) and a horizontal toolbar.

The horizontal toolbar contains a standard set of buttons (the main toolbar) plus a variable set of buttons;
this set changes depending on the button that you click on the vertical toolbar.

In the example below, the Zoom toolbar has been displayed after pressing the Zoom button on the vertical
toolbar:

™ Fila Edt Wew Actions Laser  Window Help

Fi R N N . WA g W) oY (TN NONG N+
i O 2 TS T 4D 5

* .gul-.da,rrmmmndsm F X Dacument]
JW}

I

___________________________________

The following tables briefly describes the function of each toolbar buttons. Follow the link in the table to
display the Help topic with more function details.

12
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x

Note:

Buttons are available or unavailable depending on the operation you are performing.

Toolbars can also be hidden/displayed by right-clicking on a blank area in the toolbars area and
then deselecting/selecting the items from the shortcut menu.

Standard toolbar
This toolbar is always displayed:

Button

O & | © D B

|5

)

Description

Plane Document- It allows opening a new document in the work area,
either Plane, Ring or Sequence. Click the button to open a new Plane Document opens; click
the down arrow. to display the dropdown list that allows you to select the desired document:

A Bl Sk D

|

: F'ylg‘ne Document Chii+h B
J + Ring Document t
y |
L Sequence i

(Same as menu command File > New):

[ File | Edit View Actions Laser Window Help
] Mew %:_1 Plane Document ChrH |
-_— i Project editor I? Ring Decument -
I_ =3 Open Chrl+0 | SeqUence
. : I ’

Project editor - It launches the Project Editor application which allows creating programs in
order to automate marking operations. (Same as menu command File > Project editor).

Open - It opens the window that allows choosing an existing layout. (Same as menu
command File > Open).

Save - It opens the window that allows saving a layout. (Same as menu command File >
Save).

Mark Preview - It allows checking the final result of the marking process of your layouts
directly in Laser Editor. This button is made available after creating or opening a document in
the work area. (Same as File > Mark Preview).

Cut - It allows cutting the selected object. (Same as menu command Edit > Cut).

Copy - It allows copying the selected object. (Same as menu command Edit > Copy).

Paste - It allows pasting the object. (Same as menu command Edit > Paste).

Undo - It allows undoing the selected command. (Same as menu command Edit > Undo).

Redo - It allows redoing the previously undone command. (Same as menu command Edit >
Redo).

¥, 0D:00 Marking time - It allows calculating the time for engraving the active document.

13
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Insert Objects toolbar

)
This toolbar is displayed after pressing the = Insert Objects button on the vertical toolbar. It allows adding
objects to the current document. See About graphic objects for more information.

Button

X
-—

%

&
(I

|

O

4

Description

Remove object(s) - It allows removing the selected object. (Same as menu command Actions
> Remove object(s).

Text string - It allows inserting a text string into the current document. (Same as menu
command Actions > Insert > Text string).

Code - It allows inserting a code into the current document. (Same as menu command Actions
> Insert > Code).

Imported - It displays the window that allows you to insert an imported graphic object into the
current document. You might import vectorial or raster images, AutoCad/AutoDesk .DXF and
.DWG files, .HPGL or . PLT files, as well as existing layouts (.XLP files). (Same as menu
command Actions > Insert > Imported).

Array - It allows inserting an array into the current document. (Same as menu command
Actions > Insert > Array).

Circle - It allows inserting an ellipse into the current document. (Same as menu command
Actions > Insert > Circle).

Rectangle - It allows inserting a rectangle into the current document. (Same as menu
command Actions > Insert > Rectangle).

Poly - It allows inserting a polygon into the current document. (Same as menu command
Actions > Insert > Poly).

Lines - It allows inserting a line into the current document. (Same as menu command Actions >
Insert > Lines).

Dot - It allows inserting a dot into the current document. (Same as menu command Actions >
Insert > Dot).

14
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Objects Operation toolbar

This toolbar is displayed after pressing the & Objects Operation button on the vertical toolbar. It allows
operating on objects, such as, for example, grouping/ungrouping objects, editing vectors, and so forth.
See Grouping, merging, or joining objects for more information.

Button |Description

Group selection - It allows grouping the selected objects in a single object. Single objects keep
) their properties, but the transformation and movement operations involve all grouped objects.
' (Same as menu command Actions > Group selection).

- Merge selection - It allows assembling two or more objects in a single object. Single objects keep
_,r" their properties, with the exception of laser and filling properties. (Same as menu command Actions
> Merge selection).

Ungroup selection - It allows disassembling grouped or merged objects so they can be moved or
changed individually. (Same as menu command Actions > Ungroup selection):

1

BECe
(-

Union - It allows assembling vectorial objects so that their constituting polygons are merged into a
single object. This operation can only be reversed using the Undo command. (Same as menu
command Actions > Union).

Intersection - It allows assembling overlapping objects into a new single vectorial object. Only the
area that is common to the objects will be considered for the engraving. This operation can only be
reversed using the Undo command. (Same as menu command Actions > Intersection).

... Difference - It allows assembling overlapping objects into a new single vectorial object. Only the
L | |outline of the first selected object, minus the common area, will be marked. This operation can only
be reversed using the Undo command. (Same as menu command Actions > Difference).

_ |Exclusion - It allows assembling overlapping objects into a new single vectorial object. The
g} outlines of the two objects will be marked, minus the common area.This operation can only be
reversed using the Undo command. (Same as menu command Actions > Exclusion).

Make vectorial - It allows converting the selected string or code into a vectorial object for you to be
A able to edit nodes. Note that, when a string is made vectorial, it looses its properties and becomes
="~ |a simple vectorial object. (Same as menu command Actions > Make vectorial). See Editing objects
vectors for more information.

. Advanced processing - This button allows accessing the advanced vectorial processing options
Jﬂ that provide an automated way to edit vectors. (Same as menu command Actions > Advanced
processing). See Using Advanced Processing options for further information.

Edit nodes - It allows editing the nodes of a vectorial object. When you press this button,

W the ¥ ® = & b o <o Edit Nodes toolbar is displayed that allows you to edit the object's
shape. (Same as menu command Actions > Edit nodes).
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Adjust Objects toolbar

This toolbar is displayed after pressing the 'J%'J Adjust Objects button on the vertical toolbar. It allows
aligning, spacing, flipping, or resizing objects, as well as fine-tuning the marking order. See Aligning, flipping,
or spacing objects for more information.

Button

Q4
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Description

Align left - It allows aligning the selected objects to the left. (Same as menu command Actions >
Align > Align left).

Align top - It allows aligning the selected objects to the top. (Same as menu command Actions >
Align > Align top).

Align right - It allows aligning the selected objects to the right. (Same as menu command Actions >
Align > Align right).

Align bottom - It allows aligning the selected objects to the bottom. (Same as menu command
Actions > Align > Align bottom).

Align center X - It allows aligning the selected objects along the X axis. (Same as menu command
Actions > Align > Align center X).

Align center Y - It allows aligning the selected objects along the Y axis. (Same as menu command
Actions > Align > Align center Y).

Flip horizontally - It allows flipping the selected object(s) horizontally. (Same as menu command
Actions > Flip > Flip horizontally).

Flip vertically - It allows flipping the selected object(s) vertically. (Same as menu command Actions
> Flip > Flip vertically).

Space horizontally - It allows spacing the selected objects evenly across. (Same as menu
command Actions > Spacing > Space horizontally).

Space vertically - It allows spacing the selected objects evenly down. (Same as menu command
Actions > Spacing > Space vertically).

Make same size - It allows making the same size for the selected objects. (Same as menu
command Actions > Size > Make same size).

Make same width - It allows making the same width for the selected objects. (Same as menu
command Actions > Size > Make same width).

Make same height - It allows making the same height for the selected objects. (Same as menu
command Actions > Size > Make same height).

Restore transformations - It allows restoring the selected object(s) to its original size or orientation.
(Same as menu command Actions > Size > Restore transformation).

Marking order - It allows optimizing the order in which the objects will be engraved. (Same as menu
command Actions > Marking order). See Optimizing the objects marking order for more information.
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Zoom toolbar

This toolbar is displayed after pressing the Q Zoom button on the vertical toolbar. It allows displaying the
whole graphic area on the screen or a greatly enlarged detail of a particular part. See Zooming for more
information.

Button |Description

@ In - It allows gradually zooming the whole graphic area. (Same as menu command View > In).

a Out - It allows gradually reducing the zoom. (Same as menu command View > Out).

Selection - It allows zooming in the selected object(s) so that it fits the entire graphic area. To
@ return to the original graphic area, click on Zoom page. (Same as menu command View >
Selection).

@ Page - It allows restoring the original graphic area. (Same as menu command View > Page).

Window - It allows zooming a specific area in the drawing. (Same as menu command View >
Window).

Laser toolbar

This toolbar is always displayed. It allows interacting with the laser device. For further information,
see Performing the engraving operation for more information.

Button |Description

Connect to device - This button is only available if you have a Supervisor installation of Laser
“* Editor (see Installation types and connection modes).
’ It displays the window that allows you to connect to a laser device, either locally or remotely. (Same
as menu command Laser > Connect to device).

\*% Open from device - It allows opening a laser document that you have previously saved to the laser
# device. (Same as File > Open from device).

b Save to device - It allows saving a layout to a specific device with a specific name, into a folder
managed by Laser Engine. (Same as File > Save to device).

Switch to Manual (or Auto) Mode - It allows switching between operating modes. Selecting Manual

@ Mode allows you to set laser parameters or send documents to marking. By default, Auto Mode is

*. |set and layouts are sent to marking via a Project Editor's program. (Same as menu command Laser
> Select Manual (or Auto) Mode).

Work Mode - This button is only enabled if you are in Manual Mode. It allows marking the selected
e layout using the external Start and Stop commands directly from editor. If you are not connected to
a device, it activates the simulator. (Same as menu command Laser > Send marking).

Send marking - This button is only enabled if you are in Manual Mode. It allows sending the layout
‘B to the device for marking. If you are not connected to a device, it activates the simulator. (Same as
menu command Laser > Send marking).

> Send marking on selection - This button is only enabled if you are in Manual Mode. It allows
/i) (sending the selected object to the device for marking. If you are not connected to a device, it
7 lactivates the simulator. (Same as menu command Laser > Send marking on selection).

@ |Stop marking - It allows interrupting the laser marking operation. (Same as menu command Laser
& > Stop marking).

17
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Limits on selection - It allows tracking the engraving limits of the currently selected object(s). The
area involved in engraving is shown and not the profile of the object to be engraved. (Same as menu
command Laser > Limits on selection).

Limits all - It allows tracking the engraving limits in the work plain. Margins are displayed using a
red laser pointer. (Same as menu command Laser > Limits all).

Limits previous/next sector - These buttons allow tracking the engraving limits of the sectors that
compose the object(s). This function is suitable when engraving on ring documents. (Same as menu
commands Laser > Limits previous sector and Limits next sector).

Simulator - It is used to simulate the engraving results when in Manual Mode. A new graphic
window is displayed where engraving is simulated. The simulation maintains all the speed, filling,
wobble or other parameters set for the document. (Same as menu command Laser > Simulator).

Show Laser Engine - It allows opening Laser Engine window directly from Laser Editor, either
locally or remotely. See Laser Engine User Interface.

Laser Configuration - It allows opening the Laser Configuration window directly from Laser Editor
S0 as to set the laser and axis parameters. (Same as menu command Laser > Laser Configuration).

Edit device global variables - It allows managing global variables, so as to share contents
(counters and strings) between more documents. (Save as menu command Laser > Edit device
global variables). See Using global variables.

Manage Device Users - It allows you to set and mange the users' rights on the system you to connect to a
laser device, either locally or remotely. See Managing users and access rights.

System Test - It allows accessing the dialog where you can test the Laser system and check your
system's connections. In particular you can test all Inputs and Outputs, as well as the
external Start and Stop signals.
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3- PRELIMINARY OPERATIONS

Before you begin working with Laser Editor, you have to complete the following procedures:

e Reqistering your product

Installation types and connection modes

Setting the default behaviour of Laser Editor

Importing Smatrtist Projects

Opening the data folders




LASER EDITOR

Registering your product

While Laser Editor does not need to be licensed, Laser Engine, that is the runtime component of the marking
system, can be installed as a trial version for 30 days, after which it will no longer engrave. However, Laser
Editor will still functioning as a graphic editor.

To register Laser Engine before it expires, complete the following procedures:
e Obtaining the license file
e Sending the activation key to the remote device

Obtaining the license file

To register Laser Editor:
1. From the Laser Editor menu bar, choose Help > Get device ID.
2. Inthe Device ID window, select button Copy Device ID to clipboard :

~. Device ID Ed
IF Address: localbaost
Device ID: GAZE-OOY R R-PEZA4-S07OG-978G1 -ICSDN

:’ | Copy Device ID ko clipboard

To license this software please e-mail the code above together with laser
serial number and order invaice number or delivery note ar O

email: license-dla-lasermarkingi@datalogic. cam

3. Copy the identification code and paste it into an e-mail that you will send to the address that appears
at the bottom of the dialog.

4. You will receive a reply with an attached file called License.dat.

Sending the activation key to the remote device

Attention:
!l.l To perform this operation, you must be connected to the device. For further information,

see Connecting to the laser device.

This procedure allows sending the activation key to the remote device to which you are connected:

To send the license:
1. From the Laser Editor menu bar, choose Help > Send license.

2. In the Choose license file window that is displayed, select the License.dat file that you have
received from the manufacturer (see Obtaining the license file).

3. Click on Open. This will automatically send the license to the remote device.
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Installation types and connection modes

When installing Laser Editor, you can choose between different installation types, depending on your needs.

The installation type determines if you are installing either Laser Editor or Laser Engine, or both components,
as well as whether you can interact to Laser Engine remotely.

The following table summarizes the available solutions:

Laser Engine is
suitable for remote
control through the
network

Laser Editor can connect
Installation type and description to any Laser Engine
available on the network

Interactive

Installs both Laser Editor and Laser Engine.

e Use this option if you are installing the
software on the PC that will control the laser

locally (SLAVE device). NO VES

e This option will install components for editing
layouts and controlling the laser source
locally.

e This option allows the laser source to be
controlled by MASTER device via Ethernet.

Supervisor

e Use this option if you are installing the
software on the PC that will control the laser
source remotely (MASTER device).

e This will install components for editing YES NO
layouts and control the laser source via
Ethernet.

e This option allows the laser source to be
controlled by MASTER device via remote
ActiveX control.
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Setting the default behaviour of Laser Editor

You can use the Configuration dialog box of Laser Editor to set the default configuration parameters for
your application.

See the following for further information:
e Setting language, measurement unit and graphical effects (General page)
e Setting documents parameters (Geometry page)
e Setting the laser parameters (Laser page)

Setting language, measurement unit and graphical effects (General
page)

This window allows you to specify the user interface language, the linear measurement unit and the
graphical effect for your application.

To set the General parameters:

1. From the Laser Editor menu bar, choose File > Configuration. The Default parameters
configuration window is displayed.

2. Inthe left pane of the window, leave General selected.
3. Set the default parameters using the following table as a reference.

Group box |Parameter Description

It lists the available languages for the user interface. Select the
language you want to use.

Language Note that by default, the language is set to Autodetect, meaning that
it depends upon the language of your operating system.
Linear Sets the linear measurement unit. Available  options
Units are mm or inches.
Decimals Sets the number of decimals to be used. Admitted values are 0 to 5.

It specifies the maximum disk space for log files.

The log file is compiled at the Laser Engine level and lists all actions
that have occurred allowing you to correct any problem that might
occur.

For further information on how to use and manage the log file, please
see Understanding the log file.

Logging Max log space (KB)

Graphical . . It allows increasing the font dimensions. This is particularly useful
Text dimension . e
effects when using Asiatic fonts.
It allows managing the evaluator for the marking time in order to
speed up the layouts editing. Two settings are available:
o0 every change - the evaluator is calculated whenever the
contents of a document are changed. This settings slows
Tools Evaluator updates

down the editing operations.

o on click - the evaluator is calculated at the user's request.
This is the recommended setting, especially in case of layouts
with many graphics.
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4. Click OK to implement your settings.

5. To restore the default parameters, click on Restore window settings and then restart the
application.

6. To clear the lists of laser sources and lenses got from several engines, click on Reset to factory
settings and then restart the application.

Setting documents parameters (Geometry page)
This window allows setting dimension, orientation, and grid settings for documents.

Note:

@ All measurement units in this page depend on the units that were selected in the General page.
See Setting lanquage, measurement unit and graphical effects (General page).

To set the documents parameters:

1. From the Laser Editor menu bar, choose File > Configuration. The Default parameters
configuration window is displayed.

2. In the left pane of the window, select Geometry. The parameters in this window allow setting the
default parameters for the documents that you will create.

3. Make the desired changes using the following table:

Group box

Plane

Ring

Grid settings

Origin
orientation

Note:

and

Parameter
Width
Height
Margin X
Margin Y
Diameter
Thickness
Margin Y
Enable grid
Snap to grid
Grid step

Origin

position
Origin X
Origin Y
Invert X

Invert Y

Description

Sets the width of the work area for a plane document.

Sets the height of the work area for a plane document.

Sets the width of the margins in the work area for a plane document.
Sets the height of the margins in the work area for a plane document.
Sets the size of the external or internal diameter for a ring document.
Sets the height of the ring or cylinder for a ring document.

Sets the width of the margins in the work area for a ring document.

If selected, displays the grid in the work area (Default: selected).

If selected, enables the objects snap to the grid. (Default: deselected).
It allows setting the grid spacing.

The default origin for the Cartesian coordinates (x y) that are used as the
reference point. Their origin is set by default to 0.0 (Center).

The dropdown list allows you to select an origin other than Center, such
as Left Top or Right Bottom.

Furthermore, you can set a Custom origin: in this case, enter new values
for the X,Y coordinates.

Sets the X coordinate (horizontal) of the new origin, in relation to the
default position, that is the Center of the document.

Sets the Y coordinate (vertical) of the new origin, in relation to the default
position, that is the Center of the document.

If selected, inverts the X axis so as to change the field orientation. (Default:
deselected)

If selected, inverts the Y axis, so as to change the field orientation.
(Default: deselected)

@ You will then be able to change the settings at a document level by editing the Properties window for
the active document. See Setting lanquage, measurement unit and graphical effects (General page).

4. Click OK to implement your settings.
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Setting the laser parameters (Laser page)

This window allows you to specify the laser device to which you are connecting, as well as the lens and
marking technique.

Important note:
l!.! The parameters that you set in this window will be the default parameters for Laser Editor. However,
=== lyou can still set different parameters at a document level (see About documents).

To set the laser parameters:

1. From the Laser Editor menu bar, choose File > Configuration. The Default parameters
configuration window is displayed.

2. Inthe left pane of the window, select Laser.

3. Set the appropriate parameters using the following table as a reference:

Group box |Parameter |Description

If you have a Stand-alone installation, it lists the laser source to which you are

currently connected.

If you have a Supervisor installation, it lists the available laser sources to which you
Target Laser can remotely connect.

Note: If this field is empty, it means that you are not connected to any laser source.

If you are operating on a network, you must launch the Laser Engine at least once,

in order to see the relevant laser source listed in the list.

It contains a list of available optical lens that you can install on the scanner head

Lens and it allows selecting the default lens to be used.

4. Click OK to implement your settings.
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Importing Materials Database

This function is used to import into Laser Editor database materials that you have created using Smartist.
You can import;
e Materials Database (.ini, .DB files)

To import a materials database from Smartist:

1. From the Laser Editor menu bar, choose File > Import Materials Database to display the Choose a
materials database to open window.

2. From the Type of file dropdown list, select the proper type of file. There are two available options:
0 .ini files
o .DBfiles

3. Browse to locate the desired file and click Open.

4. After completing the import operation, a number of information messages will be displayed providing
information on imported file(s).

25
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Open Smartist Projects

Is possible to open into Laser Editor any project or document that you have created using Smartist. You can
open:

e Smartist projects (.prj files)

e Smartist documents (.LDX, .LDC files)

To open a Smartist project or document:

1. From the Laser Editor menu bar, choose File > Open to display the Choose a document to
open window.

2. From the Type of file dropdown list, select the proper type of file. There are two available options:

0 Smartist projects (.prj files) - It allows importing a Smartist project, which can be
composed by one or more graphic layouts.

0 Smartist documents (.LDX, .LDC files) - It allows importing a specific document that you
have created using Smatrtist.

3. Browse to locate the desired file and click Open.

4. After completing the import operation, a number of information messages will be displayed providing
information on imported file(s), Smartist version, and so forth. Any opened document will be
displayed in a tab within the Laser Editor window, for you to manage or edit as any other Laser
Editor document.

Tip:

Note that, if any script or formatter file was included in the project, a message tells you in
@ which folder on your PC it has been saved during the import operation. You can use Project

Editor to open or edit it. Project Editor is a tool that allows creating custom programs, which

includes his own Help system. To access it, choose File > Project Editor from the Laser Editor

menu bar.
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Automatic conversion Smartist Projects

Is possible to convert automatically a list of Smartist Projects from input directory and subdirectories.

Usage: LaserEditor.exe --convert-files <from directory> <to directory> <file pattern> [--convert-
subdirs] [--convert-log <log file name>]

o --conver-files — It allows to specify the Input and Output directories.
» <from directory> — Input directory
= <to directory> — Output directory
= <file pattern> — You can specify a file name pattern
0 --convert-subdirs — It allows to specify to convert files from subdirectories.
0 -—convert-log — It allows to specify the log file name created in the Output directory. The
default file name is ‘convert.log’.
= <log file name> — Log file name

Example:
LaserEditor.exe --convert-files c:\temp\prj_from c:\temp\prj_to *.prj
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Opening the data folders

The Open data folder function allows retrieving informations that you might need for support purposes, as
well as to check the data or the device's configuration.

To view the folders contents:

1. From the Help menu, select Open data folder.
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2. Inthe window that is displayed, select the desired folder. Use the following table as a reference:

Folder Contents
|Config |Configuration files, laser configuration, and license.
|Corrections |Fi|es for lenses correction.
|Database |Databases of passwords, materials, and global variables.
|Fonts |List of the fonts that can be used in Laser Engine.
Lods Log files that were generated from Laser Engine and Laser Engine Service
9 Controller
'Docs/Layouts 'Documents that are loaded while executing scripts
List of the temporary documents that are sent to the marking in Manual mode,
Docs/Temp : )
directly from the Laser Editor.
Proiects Folders containing the projects that are saved to the device. The "default" folder
) must always include the default project.
|Plugins |Plugins that are registered when launching Laser Engine.
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4- CREATING GRAPHIC LAYOUTS

This chapter is divided into the following sections:

Topic

Setting your work
environment

Graphics editing overview

About documents

About sequences

About graphic objects

Using global variables

Understanding objects
colour in the work area

Common___ operations __on
objects

What you will learn
How to set your work environment in terms of panes and toolbars.

An overview of how graphic layouts are managed in Laser Editor.

How to create and manage documents as objects containers, for plane or ring
laser engraving, and how to set their properties.

How to create and manage sequences that allow defining a sequence of
actions to be executed at the Laser Engine level.

What objects properties are intended for. How to add and manage graphic
objects that compose the layout (simple vectorial objects, strings, codes,
arrays, imported raster or vectorial images).

How to set and manage global variables, so as to share contents (counters
and strings) between more documents.
The meaning of the objects colours in the work area.

How to perform common operations on objects, such as aligning, adjusting,
resizing, spacing or flipping objects, by using the mouse, toolbars, or by
setting the object properties.
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Setting your work environment

By default all child windows are displayed in the Laser Editor window, that is, the Properties, the Undo/Redo
commands list, and the Objects engraving order windows.

Furthermore, several toolbar buttons are displayed, to allow you a quick access to the main functions of
Laser Editor.

However, you can customize your work environment by displaying or hiding both windows and toolbars.

Hiding/Displaying windows or toolbars

To hide/display an element:

1. Right-click in a blank area next to the toolbars to display a shortcut menu that lists all the elements
that compose the work environment (panes and toolbars).
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El Froperties T
EI Objects engraving order

2. Deselect/select the corresponding checkbox to hide/display an element, respectively.

Docking/Undocking panes

By default, the three panes Undo/redo commands list, Objects engraving order, and Properties, are
displayed at the left and the right side of the Laser Editor's window, respectively. You can move or resize
them. For example, you might want the Properties window to float over the work area.

To dock/undock a pane:

e To undock a pane, click on its title bar, for example on Properties, and then drag it to the desired
position.

e Toresize a pane, undock it, and then use the mouse to change its dimensions.

e To dock a pane in its original position, double-click the title bar.
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Graphics editing overview
In order to create and manage layouts for laser engraving, you will do the following:

e Create a document, that is the "container" for the graphic objects that compose the layout.
(See About documents)

e Add and edit the graphic objects to be engraved (see About graphic objects)

The Property browser, which is available for documents and objects, allows you to edit the properties so as
to suit your engraving needs. You can customize the parameters that define how the objects will be
engraved: this includes sizes, origins, filling, laser parameters, and so forth.

Furthermore, you can operate on objects by using toolbars, mouse, and menu bar.

While editing, you can use the F1 key to access the context Help that relates to what you are doing, as well
as to display information on each properties group, as illustrated in the following example where a String
object has been added to a plane document:
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About documents

In Laser Editor, a document can be referred to as a container for graphic objects that compose the layout to
be engraved. The document's area corresponds to the engraving laser work area.

Laser Editor provides two types of documents that you can use depending on your engraving needs:
e Plane documents, are used for vectorial or raster engraving on flat surfaces.

¢ Ring documents, are used for vectorial or raster engraving on cylindrical surfaces.

When you install Laser Editor, it is necessary to be connected to the Laser Engine, that is, to a laser source
in order to be able to create new documents. If you are operating in a standalone station, the Laser Engine is
launched automatically; while, if you are operating on a network, you need to manually connect to the Laser
Engine at least once. Otherwise, you will only be able to edit existing documents.

When creating e new document, default parameters are used to set the laser source, the dimensions of the
graphic work area, and so forth; these are the parameters that have been set for the application (See Setting
the default behaviour of Laser Editor). However, you can use the documents Property browser to change
these settings, as it is described in the sections that follow.

When adding an object to a document, the laser parameters that have been set for the document are used.
You can still setting different laser parameters for each object; in this case, the object will appear blue.
(See Understanding objects colour in the work area).

The following sections describe how to work with documents in Laser Editor:

e Common documents properties

e Creating a document for plane engraving

e Creating a document for ring engraving

e Opening existing layouts

e Saving layouts

You can also use the Sequence feature to create programs that allows automating documents' marking
operations (see About sequences).

Common documents properties
Tip:
The properties that are described in this section apply to both plane and ring documents. Properties
that are specific to either plane or ring documents, are described in the relevant section.

The following tables describe the Target and Laser properties, which are common to plane and ring
documents.

These properties are available when a document is being created and no objects are selected.
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Target properties for documents

Attention:
This set of properties is only visible if:
=, e you are operating on a network and you are not yet connected to a laser source; or

e you are connected to more laser sources.

When creating a new document, the default parameters that have been set in the Default configuration
parameters window for Laser Editor are used. For further information, see Setting the laser parameters

(Laser page).

The following properties are available when you first install Laser Editor and are not yet connected to a Laser
Engine. Once you are connected to a Laser Engine, these properties are not longer available. They become
available if you connect to a Laser Engine which is connected to another laser source or a lens; in this case,
you can select from the lists the desired source or lens.

Group Property |Description

It lists the available laser sources (stand-alone installation), or the laser source(s)

Laser source to which you might remotely connect (supervisor installation).

It contains a list of available optical lens that you can install on the scanner head
of the laser device.

The dimensions of the Work Area depends on this parameter (see Setting the
work area).

Objective lens
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Laser properties for documents

The following properties will be used as the default laser parameters when adding new objects to the
document. However, you can still set different parameters for a specific object. (See Custom Laser
parameters for Objects).

Group Property Description

It allows setting the number of runs of the laser light on the object to
engrave. You might set up to 3 passages, each with different laser

Passages parameters (see Passage properties group). This option may be particularly
useful to make several engraving runs to clean the work piece after a more
incisive engraving process. (See Using more engraving runs)

This indicates the laser output power. The value is expressed as a

Power percentage of the maximum power of the laser source.
Light emitted by the laser is pulsed. Use this parameter to adjust the
frequency of the emitted light.

Frequency All other parameters being equal, a lower frequency causes a higher per

pulse. Not all combinations of power and frequency are allowed. Depending
on the laser source type, low frequencies require correspondingly low
powers.

This indicates the engraving speed. The value is expressed in millimeters
Passage per second. (Note: A slower speed implies engraving a deeper engraving.

(#) Scan Speed Set a very slow speed (50-100 mm/sec.) for special processes, such as
burnishing or deep engraving.
Dot Dela Sets the engraving time for each dot, that is, the time required for laser
y emission on the dot.
Shot Time Sets the duration of the laser shot pulse i.e. the time the Q-switch is open
(or, better, transparent).
Sets the number of times objects are marked. Increasing the number of
Repetitions passes will increase depth of engraving, consequently affecting the cycle

time.

If it is set to True, this property allows engraving thicker lines through a spiral movement
instead of a linear movement. (See Using the Wobble function to engrave with thicker lines)

Wobble Radius Represents the radius of the spiral curve
Speed Represents the frequency of spiral repetition
7 Axis If it is set to True, it allows setting the Height, that is, the distance between

the mechanical zero and the logic zero for the Z Axis (the focus position).

You can set the parameters for the objects in the document, based on a specific material (e.g. plastic) and its
reactions to the marking operation. For further information on how to save and recover a materials database,
see Saving a Materials database for a later re-use.
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Creating a document for plane engraving

A plane document is used for vectorial or raster graphic engraving on flat surfaces.

The document's area corresponds to the engraving laser work area. It is where you create the layout by
drawing and editing graphics objects, or importing raster or vectorial image files, such as a logo (see About
graphic objects).

When you create a new document, the default parameters that have been set in the Default configuration
parameters window for Laser Editor are used. (See Setting the default behaviour of Laser Editor). You can
use the Property browser to set other parameters.

For further information, see:
e Creating the document

e Saving a Materials database for a later re-use

e Setting the work area

e Common documents properties

e Geometry properties - Document plane

Creating the document

To create the document:

1. Do one of the following:

(0]

From the Laser Editor menu bar, choose File > New > Layer.

B -
o From the Laser Editor standard toolbar, click the S8 T putton.
2. The document appears in the Laser Editor's window, where the engraving layout is represented.
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Note that the Properties window contains the default parameters, that is the
been set for Laser Editor.

parameters the have
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3. To create the engraving layout, complete the following operations:

0 Set the properties for the document that best fit your engraving requirements. Refer to
sections Common___documents _ properties, Geometry _properties - Document _plane,
and Saving a Materials database for a later re-use for further information.

In particular, when setting the document's work area, refer to Setting the work area.

0 Add the graphic objects for engraving, either by drawing or importing them (see About
graphic objects)

4. When you are finished, you might save the document in the following ways:

0 Choose File > Save or click the LJ button to save the document on your PC, as a graphic
layout (.x1p file).

0 Choose File > Save as to save a copy of the document.

0 Choose File > Save to Device or press the ,b button to save the layout remotely, directly
to the laser device for marking. You can select the device and enter a name for the
document.

The document(s) will be actually sent to the laser engraver through an automated procedure
written with Project Editor.

(For further information, see Saving a layout to a device).

Note:

The Project Editor is a programs editor that is used to automate marking
@ procedures or to update the layout contents at runtime. It has its own context-

sensitive Help and it is integrated into Laser Editor. To access it, choose File >

Project Editor.

5. To close a document, click the £ button at the top right of the work area.

Note: You can work on more documents simultaneously. Each document will be displayed in a tab in the
Laser Editor's window.
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Saving a Materials database for a later re-use

The Materials property, allows saving specific laser settings and filling parameters in a database that you
can then import in a new layout. After setting your parameters according to a specific material and its
reactions to the marking procedure, and once your layout is ready, you can store it for a later re-use.

The same operation can be done for each individual object in the document.

To save a materials database:

1. Click Materials properties:

Repetitions 1
Wobble [
1 Axis ]
4 Materials

Save |:|

2. Click the Save button to display the following dialog:

_. Save material

3. Enter a meaningful Material hame (e.g., plastic) and click OK to save the database. Note that the
dropdown list contains the materials databases that you have created previously.

4. Use the Delete button to delete existing databases.

To re-open a previously saved database:
1. From the Laser Editor menu, select File > Import Materials Database.

2. In the windows that is displayed, navigate to Data_Lighter > Database and then select the desired
file: .in1 file, if the layout was created in Smartist, . db if it was created in Laser Editor.
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Setting the work area

The size of the work area is a fundamental setting. The maximum size that can be used is based on several
elements, including the focus height installed on the engraving laser and the quality of the lens. As a general
rule, increasing the focal length will result in the work area increasing, but the model and the quality of the
lens can also affect the size of the work area.

The lens can have different focal lengths: this determines the size of the marking area. The table below lists
some typical examples:

Focal length Working Area
100 mm 50 x 50 mm
160 mm 110 x 110 mm
254 mm 180 x 180 mm

The focal lengths also determine other properties of the laser marking system, such as the working distance
and the laser spot.

When you set the work area parameters, keep in mind that its width cannot exceed the focus length set for
the laser. The figure below shows an example:

The focal length for the objective lens are set both at laser device's level and at the level of the document:

To set the focal length at the laser device level:
1. Right-click the Laser Engine icon on the Windows taskbar and select Laser Configuration. (For
more information on how the Laser Engine works, see Laser Engine User Interface).
2. Select the Correction page.

3. Under Lens, choose from the Focal Length [mm] dropdown list the focal length used by the laser
device.

To set the focal length at the document level:
1. In the Properties window of the active document, under Target, choose from the Lens dropdown
list the optical lens to be used.
2. When setting the work area for the document, remember not to exceed the dimensions that the
installed optical lens determine.
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Geometry properties - Document plane

When creating a new document, the default parameters that have been set in the Default configuration
parameters window for Laser Editor are used. For further information, see Setting documents parameters
(Geometry page).

You can use the document's Property browser to set parameters other than the default ones.

Note:

@ All measurement units that are used in this page depend upon the units that you have selected
at the application level. See Setting language, measurement unit and graphical effects (General
page).

Group Property |Description

It corresponds to the surface to engrave. The size of the work area is a fundamental

parameter. The maximum size that can be used is based on several parameters, including

the focus height installed on the engraving laser and the model of lens. (SeeSetting the
Work Area work area).

Width Sets the width of the work area.
Height Sets the height of the work area.
Marai X Sets the distance between left and right margins of the work area.
argins
J Y Sets the distance between top and bottom margins of the work area.
If it is set to True (default), the grid is displayed and the relevant properties are available.
The grid is a series of traced lines which intersect. They can be used to precisely align and
position objects in the drawing window. (See Using the document's grid).
Grid Step Sets the dimension of the cells on the grid.
Sna to If it is set to True, enables the snap to the objects in the grid, that is, when
ridp you move objects on the grid, they will be aligned to the closest grid line.
9 (Default: False).
The default origin for the Cartesian coordinates (x y) that are used as the reference point.
Their origin is set by default to 0.0 (Center). The position of the objects refers to this point.
The dropdown list allows you to select an origin other than Center, such as Left
Top or Right Bottom.
Furthermore, you can set a Custom origin: in this case, you should enter new values for
the X,Y coordinates.
o X Position Sets the X coordinate (horizontal) of the new origin, in relation to the default
Origin position, that is the Center of the document.
. Sets the Y coordinate (vertical) of the new origin, in relation to the default
Y Position

position, that is the Center of the document.
Invert X |If it is set to True, inverts the X axis so as to change the field orientation.

Axis (Default: False)
Invert Y |If it is set to True, inverts the Y axis, so as to change the field orientation.
Axis (Default: False)
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Creating a document for ring engraving

Note:
In order to mark a ring document, you must install and configure on your device a rings
J separator.
— Furthermore, the Rotor axis must be enabled (Enable axis property) in your Laser Configuration
settings. (See Setting the X, Y, Z, and Rotor Axes parameters).

Ring documents are used when you need to engrave a cylindrical surface. The document's work area
represents the whole linear development of the surface to be engraved (360°).

The document's area corresponds to the engraving laser work area. It is where you create the layout by
drawing and editing graphics objects, or importing raster or vectorial image files, such as a logo (see About

graphic objects).

When you create a new document, the default parameters that have been set in the Default configuration
parameters window for Laser Editor are used. (See Setting the default behaviour of Laser Editor). You can
use the document's Property browser to set other parameters.

For further information, see:

e Creating the document

e Common documents properties

e Geometry properties - Ring document

Creating the document

To create the document:
1. Do one of the following:

o0 From the Laser Editor menu bar, choose File > New > Ring Document.

|'|i_-'|:II ot
o From the Laser Editor standard toolbar, click the down arrow next to the ity button and
then select Ring Document;

DR

£ Layer Ctrl-+N
+  Ring Document 'L
Seguence 1
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2. The document appears in the Laser Editor's window, where the engraving layout is represented.

™ File Edit View Actions Laser Window Help
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Note that the displayed work area represents the linear development of the surface to be engraved
and the Properties window contains the default parameters that have been set for Laser Editor.
3. To create the ring engraving layout, complete the following operations:

0 Set the properties at the document level, so as to fit your engraving requirements. Refer to
sections Common documents properties, Geometry properties - Ring document, and Saving
a Materials database for a later re-use for further information.

0 Add the graphic objects, either drawing or importing them (see About graphic objects)

4. When you are finished, you might save the document in the following ways:
0 Choose File > Save or click the L..J button to save the document on your PC, as a graphic
layout (.x1p file).

0 Choose File > Save as to save a copy of the document.

0 Choose File > Save to Device or press the ,b button to save the layout remotely, directly
to the laser device for marking. You can select the device and enter a name for the
document.

The document(s) will be actually sent to the laser engraver through an automated procedure
written with Project Editor.

(For further information, see Saving a layout to a device).

Note:

The Project Editor is a programs editor that is used to automate marking procedures or to update
the layout contents at runtime. It has its own context-sensitive Help and it is integrated into Laser
Editor. To access it, choose File > Project Editor.

¥

5. To close a document, click the £ button at the top right of the work area.

Note: You can work on more documents simultaneously. Each document will be displayed in a tab in the
Laser Editor's window.
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Geometry properties - Ring document

When creating a new document, the default parameters that have been set in the Default configuration
parameters window for Laser Editor are used. For further information, see Setting documents parameters
(Geometry page).

You can use the document's Property browser to set parameters other than the default ones.

Group

Ring

Margin

Grid

Origin

42

All measurement units that are used in this page depend upon the units that you have selected at
the application level. See Setting language, measurement unit and graphical effects (General page).

Property  |Description
Diameter | The size of the external or internal diameter.
Height The height of the ring or cylinder.
Mark Sets engraving inside or outside the ring.
Sets the width of the vertical margins.
If it is set to True (default), the grid is displayed and the following properties are available:
Step Sets the dimension of the cells on the grid.

If it is set to True, enables the snap to the objects in the grid, that is, when you
move objects on the grid, they will be aligned to the closest grid line. (Default:
False).

Snap to
grid

The default origin for the Cartesian coordinates (x y) that are used as the reference point.
Their origin is set by default to 0.0 (Center). The position of the objects refers to this point.
The dropdown list allows you to select an origin other than Center, such as Left Top or Right
Bottom. Furthermore, you can set a Custom origin: in this case, you should enter new values
for the X,Y coordinates.

Sets the X coordinate (horizontal) of the new origin, in relation to the default

X Position | osition, that is the Center of the document.

Sets the Y coordinate (vertical) of the new origin, in relation to the default

¥ Position position, that is the Center of the document.

Invert X |If it is set to True, inverts the X axis so as to change the field orientation.
AXis (Default: False)

Invert Y |If it is set to True, inverts the Y axis, so as to change the field orientation.
AXis (Default: False)
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Defines the width of the sector. The sector represents a portion of the working
area to be engraved within a single movement of the rotating axis.

The 0 value (default) provides the highest level of quality: to each polygon is
associated a movement of the rotating axis, so that the portion being marked is
always placed on the center of the marking area. Greater value results in a
shorter total marking time, but might impact quality.

Note that the sector size can't exceed the portion of the area which is in focus;
this is based on the laser's depth of focus. If you set a greater value, the
application ignores it and uses the maximum allowed value instead, based on the
depth of focus of your laser.

It is used in association with the Sector Size property and the Tilable property for
vectorial objects. It allows fine tuning the marking results.
When you apply the Tillable property to an object, the following occur:

Advanced |Sector Size

e The object is separated into its constituting polygons.

e If a polygon is larger than the sector and it is closed (algorithm won't work
Sector Gap if the figure is open), Laser Engine will try to "slice" it in portions whose
dimension is equal to the ring's sector to be marked.

If it is set to 0, only one cut line is used between the two sectors (left and right
borders), while if it is < 0, two cut lines are used, allowing you to overlap or
separate the borders, as needed.

For a detailed description of how the Tillable property works, see Using the tiling
function.

The slant angle of the rotating axis, expressed in degrees. (Possible values: 0 to

Angle 60).

Reset axis at
the end of |Ifitis setto True, it brings the rotor to its initial position at the end of engraving.

execution
If it is set to True, allows setting the focus as ring radius-independent. This
means that (being the rings separator fixed), if the ring radius changes, the Z axis
must change accordingly in order to focus the area to be engraved. Enabling this
function, you only need to focus the revolution center; then, the system will
automatically control the Z axis so as to set the focus accordingly to the ring
dimensions.

—— Mechanical Zero (proxy zero)

Use ring

radius as Z

axis position

Logic Zero ¢

L2

Rotor

For correct operation, set the logic zero of axis Z in the revolution center. Logic
zero is the focus position on the item to be engraved. he logical zero also
depends on the ‘Ring Offset’ parameter in Laser Configuration settings,
see Setting the X, Y, Z, and Rotor Axes parameters
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Opening existing layouts
You can open layouts (that is, .x1p Laser documents) that you have previously saved for further editing, or
for sending them to the engraver.

You can open a layout that was saved locally, or a layout that was saved to a device.

For further information, see:

e Opening a layout on your PC

e Opening a layout from a device

Opening a layout on your PC
1. Do one of the following:
o From the Laser Editor menu bar, choose File > Open.

o From the Laser Editor standard toolbar, click the = Open button.

2. In the Choose a document to open window that is displayed, browse to locate the .x1p Laser
document you want to open.

3. Click on Open. The selected document is displayed in the work area of Laser Editor.

Opening a layout from a device

This function allows you to open a laser document that you have previously saved to the laser device for
further editing.

1. Do one of the following:

o0 From the Laser Editor toolbar, click the \:') Open from device button.
o0 From the Laser Editor menu bar, choose File > Open from device.

2. In the Choose a document to open window that is displayed, select from the Devices dropdown
list the device to which the document was saved. (Here are listed all the available devices on the
network).

3. The File area shows the layouts that have been saved to the selected device. Choose the file you
want.

4. Click OK. The selected document is displayed in the work area of Laser Editor.
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Saving layouts

When you are finished creating a laser layout, you can save it either locally, or to a device so that it is then
sent to the engraver through an automated procedure.

Saving a layout on your PC
The following procedure allows saving a layout as a .x1 £ file on your disk, for later use or editing.

To save the layout:
1. To save a new, unnamed layout:

0 Choose File > Save (or click the J button on the toolbar).

o In the Save document as window that is displayed, go to any location available from your
computer (or create a new folder).

o In the File name box, type a name for the document and click Save. The document will be
saved with the .x1p extension.

2. To save a copy of an existing document:
0 Choose File > Save as.

o In the Save document as window that is displayed, go to any location available from your
computer (or create a new folder).

0 Inthe File name box, type a new name for the document and click Save.

Saving a layout to a device

The following procedure allows saving a layout to a specific device with a specific name, into a folder that the
Laser Engine manages.

You can then use Project Editor to write a program for documents uploading, so that the saved documents
are sent to the engraver in an automated way.

Note:

The Project Editor is a programs editor that is used to automate marking procedures or to update
@ the layout contents at runtime. It has its own context-sensitive Help and it is integrated into Laser

Editor. To access it, choose File > Project Editor. Default programs and easy-to-use examples

are provided with the tool.

To save the layout to a device:
1. Do one of the following:
o From the Laser Editor toolbar, click the =®" Save to device button
o From the Laser Editor menu bar, choose File > Save to device.

2. In the Save document as window that is displayed, select from the Devices dropdown list the
device you are sending the layout to. (All the available devices on the network are listed).

The File area shows the layouts that have been saved to the selected device.

3. Enter a name for the document and click OK. This is the name that will be used in the Project
Editor's program.
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About sequences

A sequence is a program containing actions that Laser Engine will automatically execute.

It allows automating marking operations in simple scenarios and provides a user with an easy-to-use
interface for programs design using Laser Editor.

A typical scenario where this feature can be used, is a production line with a PLC (Programmable Logic
Controller) that manages automations and that is connected to the 1/0O PCI card: The sequence feature
allows interacting with the PLC in order to execute a specific order of marking operations.

Using a sequence you can:
o define a specific order of marking operations that will be automatically executed,;
e create or import plane or ring documents to be marked;
e interacting with the PLC by setting outputs or reading inputs;

e moving axis, if enabled.

Tip:

In addition to creating sequences, in order to automate marking procedures, you might also
@ use Project Editor, which is a programs editor integrated into Laser Editor. To access it,

choose File > Project Editor. Default programs and easy-to-use examples are provided with the

tool, as well as a context-sensitive Help.

Creating and executing a sequence
To create a sequence.

1. Do one of the following:

o From the Laser Editor menu bar, choose File > New > Sequence.

.'|?||:II r
o From the Laser Editor standard toolbar, click the down arrow next to the Ak} button and
then select Sequence:

AfH o 68

LN Layer Ctrl+h
Ring Document L
Sequence 3
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2. The following appears in the Laser Editor's work area:

™ Fle Edt View Acions Laser Window Help -~ 7 X
TR i i e Dol |
i £ Plane Cocumert cuten § v v ’.’ /'_‘
o Ring Document

T — 8 X | Documertl Document2 Sequencel 8 x

mﬂﬁf".
— Sequence : L
| TS| Sequenceitems
B Wait Start 9

Cibgects marking order 8§ X

Properties pane

Cresbe & now sequUence

Note that the Sequence items toolbar is displayed next to the Standard toolbar of Laser Editor and
a sequence with the default item is displayed in the work area.

Click the buttons on the toolbar to add items to your sequence, using the following as a reference
(see also the Example below).

Description

Label - It is a placeholder. It is required in order to use the Get and Go item. The Label tells the
Get and Go item where it must jump after verifying the specified condition.

Properties: The Label property is an editable field where you can enter a text for the label. The
typed text will then be displayed in brackets next to the Label item.

Move Axis - This item is only enabled if at least one axis is enabled on the laser. Execution of
this item result in one or more axes being moved; execution is completed when all axes target
positions have been reached. (See also Setting the X, Y, Z, and Rotor Axes parameters).
Properties: Set to True to enable one or more axis. The Position parameter is then displayed
for you to specify the axis position. The Home Search parameter is used to move the axis in
home position

Document - It allows creating or importing a plane or ring document into the sequence. Do one
of the following:

o0 To create a new document, double-click the Document item that you have add to the
sequence. If ring documents management is enabled, a window is displayed prompting
you to specify which type of document you want to create. (See About documents for
information on how to work with documents).

0 To import an existing document, click the Import property in the Properties pane and

then use the :I browse button to select the document.

Properties: The Import property allows importing an existing document. The Name property is
an editable field for you to enter the document's name.
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Set Out - It allows setting outputs on the I/O PCI card, which can be connected to a PLC (16
output bits are available). This allows you to interact with the PLC that manages operations and
tell it how to behave when executing the program.

Properties: Bit 0 to Bit 15 are the output bits that you can set. Possible options are:

@
S o] Don't care - Ignores the bit, that is, leaves the bit how it was
o] Set - It sets the bit to True.
o] Reset - It sets the bit to False.
E Delay - It allows setting a delay that you might need to complete a pending operation.
i Properties: The Delay [ms] property allows you to specify the delay in milliseconds.
0i Wait Start - It is the default item that is displayed when creating a sequence. In order to execute
o or to continue processing a sequence, Laser Engine waits for the user pressing Start.

Get and Go - To enable this item, you must first select at least one Label. A Get and Go item is
associated to a specific Label to which it might jump or not, depending on the condition to be
verified (if any). To do this, the Get and Go item verifies the input bits as they are set by the PLC
and then uses this information to proceed (jump to label or continue).
If the If Set option is selected, it verifies that the input bit is activated before jumping to the
associated label. Otherwise, ignores the jump and executes the next operation that follows. (See
the example below).
Properties: The Jump to property is an editable field for you to enter the associated label's
L name, which will then be displayed in brackets next to the Get and Go item. Bit 0 to Bit
15 properties allows setting the conditions that the Get and Go item must verify before
proceeding into the execution. Possible options are:

o] Don't care - Ignores the bit. It indicates an unconditional jump, that is, the jump
will be executed in any case.

o] If Set - Verifies that the bit has been activated (True).

o] If Reset - Verifies that the bit has been disactivated (False).

Clone document - It allows cloning a document that is already into the sequence, that is, adding
one or more copies of an existing document.
Properties: The Name property allows you entering a new name for the cloned document.

Delete sequence item - It allows deleting from the sequence an item that you have previously
added. To delete an item, select it and then press this button.

ol

Tip:
@ You can drag and drop items in order to move them to a new location into the sequence.

The example here below shows a sequence where Get and Go is used to repeatedly mark two documents.
The figure also shows how properties was set for the Get and Goes items:

Example
_Sequence

e —
B Wait Start

Property I\fahe
[ Getand Goto [P2] ]|————————> E cetando
-4 Document [Planel] v

[ Get and Go to [Start] ]
-:, Label [P2] \ Praperty 1\ealua
-5 Document [Plane2] 2 fet and G0

= Jump to Start
[z Get and Go to [Start] ] __— Bito
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The following diagram shows how the program will be executed based on this sequence:

* Label[Start]|—> Starts the process

Wait Start » Waits for user's confirmation

|

et and Go

—\Verifies the status ofthe YO bit O

to[P2]
R = . Tea .
} IfBit 0 is activated ! fBit 0 is disactivated :
Jumps to Label[P2] Ignores junp
and marks Plane2 and marks Plane 1

et and Go Jumps unconditionally
to[Start] »to Label[Start]

To execute a sequence:

Sequences are executed as projects, that is, after you save a sequence to the device, it will be executed at
the Laser Engine level by activating the Auto Mode (see Auto/Manual working mode).

For further information on saving a sequence, follow the instructions as described in section Saving layouts.
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About graphic objects

Once you have created a document, you can compose the layout for laser engraving by:
e adding shapes (circles, rectangles, or polygons);
e importing the following raster or vectorial graphics:
o vectorial: .PLT, .HPGL, .DXF, .DWG
o raster: .BMP, .JPEG, .GIF, .PNG, .TIF

e creating text strings, matrix codes, bar codes, or arrays.

For further information:
The following sections describe how to work with objects in Laser Editor:

e Common objects properties

¢ Working with simple vectorial objects

e Using Text strings

e Using Codes

e Using Arrays
e |mporting graphic objects

e Using the tiling function

e Understanding objects colour in the work area

e Common operations on objects

Common objects properties

Tip:
The Properties window supports context-sensitive Help: During layout editing, selecting a
properties title (for example, Geometry), and then pressing F1, opens the context Help for those

@ properties.

For further information on how to operate on objects using properties, see Common operations

on objects.
Properties that are specific to each object or to documents, are described in the relevant section.

The tables that follow describe the Geometry, Laser, Filling and Clone properties which are common
among graphic objects.

Geometry properties for Objects

The following table describes the Geometry properties that allow enabling/disabling objects, resizing,
rotating, and skewing them, as well as changing the objects position. These properties are displayed when
an object is selected in the work area.

Notes:

m For a quick, rough sizing, rotating, and positioning of an object, you might use your mouse
(See Using the mouse to select and manipulate objects).The Property browser allows more
precise operations.
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Geomet'ry Description

properties

D To each object loaded in the graphic area can be assigned an unique alphanumeric ID that
identifies the object in the layout.
If it set to True (default), it enables engraving of the selected object. If the object is not

Enable enabled (False), it will not be engraved and the object's color in the work area changes to
gray.

Locked If it set to True, it locks the object preventing any editing. The selection handles around the
object disappear and the @ handle appears: Click it to unlock the object. (Default; False.)

Keep Aspect If it set to True (default), keeps the proportions between width and height. It does not apply

to the Code object.

It only applies to vectorial objects on ring documents, that is, on cylindrical surfaces. It is

suitable for high precision markings, typically in jewellery.

It allows cutting the object's polygons having dimensions that exceed the sector size, into
Tillable tiles whose dimension is equal to the ring's sectors. For a detailed description, see Using the

tiling function

This property is used in association with the ring document's Sector Gap and Sector

Size properties that define the sector's dimensions.

If it set to True, it allows merging the vectors that compose an object. In the case of a string,
this property is particularly useful when working with languages whose alphabets have
ligatures, such as the Arabian language. (See Working with ligatures). (Default: False.)

It does not apply to the Array, Imported Bitmap objects and 2D codes.

Contour

It allows fine-tuning the object's dimensions by adjusting the contour.

Pocketing It does not apply to Array, Bitmap objects and 2D codes.

This is the point of origin of the object. The origin is identified by the cross symbol which, by
default, is placed in the center. If you select a value other than Center (default), this symbol
moves accordingly. The following example shows an object whose origin has been set
to Center Top in a document whose point of origin is set to Center:

Origin ofthe object
(Center Top)

=
_ E iy antes Dop
) ) Position {000, 10U0D)

Origin / ‘ . 3 0.00
¥ 10,00
[ )

| \ \
\
\ s Origin ofthe

engraving area: Center
—— | (document's origin)

You can specify the object's position in relation to the document's origin by setting
the X and Y coordinates.

Sets the horizontal position of the object in relation to the origin that has been set for the
Position (X) document. You may increase X value to move the object to the right, decrease it to move the
object to the left.

Sets the vertical position of the object in relation to the origin that has been set for the
Position (Y) document. You may increase Y value to move the object to the top, decrease it to move the
object to the bottom.
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Dimensions (W)
Dimensions (H)

Angle
Scale (X)

Scale (Y)

Skew

Sets the width of the object.
Sets the height of the object.

Sets the rotation angle (in degrees) of the object on the engraving area. It does not apply
to the Array object.

By default, is set to 1,00. Increasing/decreasing this value results in the object's width
changing. It does not apply to the Array object.

By default, is set to 1,00. Increasing/decreasing this value results in the object's height
changing. It does not apply to the Array object.

Sets a skewing for the object: if you set a positive value, the object is skewed to the right,
while, with a negative value is skewed to the left. (Default: 0). It does not apply to the
Array or Code objects.

Custom Laser parameters for Objects

The following properties are displayed when you select an object in the work area, and then set
to True the Custom Laser parameter in the Properties window.

By default, this parameter is set to False because, when you add a graphic object to a document, the object
inherits the laser parameters that have been set for that document. You can still set different laser
parameters for each object; in this case, the object's color changes to blue.

Group Property Description

Passages

Power

It allows setting the number of runs of the laser light on the object to engrave.
You might set up to 3 passages, each with different laser parameters (see
Passage properties group). This option may be particularly useful to make
several light engraving runs to clean the workpiece after a more incisive
engraving process. (See Using more engraving runs)

This indicates the laser output power. The value is expressed as a percentage
of to the maximum power of the laser source.

Light emitted by the laser is pulsed. Use this parameter to adjust the frequency
of the emitted light. All other parameters being equal, a lower frequency causes

Frequency |a longer pulse. Not all combinations of power and frequency are allowed.

Depending on the laser source type, low frequencies require correspondingly
low powers.

This indicates the engraving speed. The value is expressed in millimeters per
second. (Note: A slower speed implies engraving a deeper engraving. Set a

Passage (#) Scan Speed very slow speed (50-100 mm/sec.) for special processes, such as burnishing or

Dot Delay

Shot Time

deep engraving.

Sets the engraving time for each dot, that is, the length of time for the laser
emission on the dot.

Sets the duration of the laser shot pulse i.e. the time the Q-switch is open (or,
better, transparent).

Sets the number of runs required by the laser for engraving the imported

Repetitions |objects. Increasing the number of passes will increase depth of engraving,

consequently affecting the cycle time.
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If it is set to True, this property allows engraving thicker lines through a spiral movement
instead of a linear movement. (See Using the Wobble function to engrave with thicker lines)

Wobble

Radius Represents the diameter of the spiral curve
Speed Represents the frequency of spiral repetition
7 Axis If it is set to True, it allows setting the Height, that is, the distance between the

mechanical zero and the logic zero for the Z Axis (the focus position).

You can set the parameters for a specific object, based on a specific material (e.g. plastic) and its reactions
to the marking operation. For further information on how to save and recover a materials database, see
Saving a Materials database for a later re-use.

Filling properties for Objects

The following properties are displayed when you select an object in the work area, and then set a value other
than None (default) for the Filling property.

Notes:
The Filling properties do not apply to the Array object or the imported bitmaps.
See also Specifying the filling patterns to see examples of filling.

Filling

. Description
properties
This property is used to set the filling for the object. The engraving is mostly done with exact
parallel lines. In particular, filling can be done with:

e Single line

e Cross lines

e Triple lines - Inclination of the lines will be 0, 60, and 120 degrees.

e Islands - It allows deep engraving by executing a series of concentric markings,
starting from the object's outline, so as to obtain countersunk shapes. The Islands
allows to avoid crossed path, so each etched surface is exposed to the laser only
once, which is particularly useful when engraving on delicate materials.

Filling e Spiral - It only applies to Codes. It is used to fill rectangles with a continuous laser
beam emission. This setting is not compatible (cannot be applied together) with
Pocketing offset and Contour geometry setting.

e Dot - It only applies to 2D Codes. It allows treating a square as a dot. This filling type
is tailored for marking microelements, such as, for example, objects whose size is as
big as the laser spot on the surface. In this case, the Dot filling allows marking
directly a dot rather than filling a square.

e Raster - It allows marking a vectorial object as if it were a raster object, that is, using
the raster engraving technique (for more information, see Raster vs. Vectorial
marking). This setting is particularly suitable for plastic cards because constant
scanning speed allows for better quality.

Interline Sets the distance between filling lines.
The angle (0-360°) that defines the direction of the engraving parallel lines. Setting an angle
Angle results in the engraving lines changing direction (0 = horizontal, left to right (default) - 90 =

vertical, bottom to top - 180 = horizontal, right to left).
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Advanced

Direction

Outline
option

Tolerance

Fill by

This property is used to specify how the laser performs the filling operation:

e Bidirectional - The laser marks parallel lines, first lines from left to right, then right to
left (or vice versa, according to the value that has been set for the Angle), and so
forth. This allows reducing the markingtime. (Default).

e Unidirectional - The engraving is done only in one direction, increasing the marking
time.

This property is used to specify how the outline is to be marked relative to the filling:
e No outline - The outline of the object will not be marked.
e Filling first - The filling of the object will be marked first. (Default).
e Outline first - The outline of the object will be marked first.

Sets the distance between object’s outline and filling lines

This property is used to specify how the laser marks the filling of objects that are composed by
more polygons (such as strings):

e Object - The laser marks horizontally, using parallel lines across all the vectorial data
that compose the object (for example, a string will be marked from bottom to top,
scanning all letters with a single run). This filling option results in longer marking
times, but it is recommended when marking on plastic cards because it ensures a
uniform result.

e Polygon - The laser marks polygon by polygon (for example, letter by letter in a string,
or bar by bar in a code). This filling option results in faster marking times and it is
recommended in industrial environments.

Clone properties for Objects

The following properties are displayed when you select an object in the work area.

Notes:
The Clone properties do not apply to the Array object or the imported graphics.

Cloneproperties Description

This property is used to repeat graphic object to a different position. Inparticular,
the clone can be done with:

Clones e Number of clones

o Offset
Clonesnumber Sets the number of clone objects in X and Y coordinates.
Offset Sets the distance between objects in X and Y position.
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Working with simple vectorial objects

Actions | Laser ‘Window Help
b
- Align bl Code
i] Fip b 5L Dmported |
":_] Spacing P oW Array
7 Hze "I| ¥ Elipse
*1 Rectange
0 Paky
B4 Lines

The Circle, Rectangle, Poly, and Lines toolbar buttons (as well as the Actions menu), allow inserting in
your layout simple vectorial shapes that can be easily manipulated by editing the vectors. (See Starting
nodes editing.)

A vectorial object like this uses lines and curves, called vectors, to describe the image. In laser engraving a
vectorial graphic is faster in engraving and more defined in terms of outline lines and filling.

Furthermore, you can use the Properties window, the toolbars, or the mouse to resize, adjust, group, space,
shear, tile, fill the shapes, and so forth.

Tips:

For information on mouse operations, see Using the mouse to select and manipulate objects.
@ For information on how to operate on graphics, please refer to Common operations on objects.

Clicking a properties title in the Properties browser and then pressing F1, opens a table with a

description of those properties.

The following sections describe how to work with vectorial shapes:
e Adding a shape
e Starting nodes editing
e Using the tiling function
e Geometry properties for Objects
e Custom Laser parameters for Objects
e Filling properties for Objects

Adding a shape

To add a shape:

First, create or open a document to enable the insertion of objects (see Creating graphic
layouts and Opening existing layouts).

To add a circle or arectangle, do one of the following:

)
1. On the vertical toolbar click on the < Insert objects button and then, in the horizontal toolbar that
# ™ 4'_
is displayed, click on <= Circle or _] Rectangle.
2. From the Laser Editor menu bar, choose Actions > Insert > Circle or Rectangle.

The shape (a circle or a square) appears in the work area, surrounded by the selection handles:
Drag to make the shape the size you want (see Using the mouse to select and manipulate objects).
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To add a poly, do one of the following:

1.

Noo

&y
On the vertical toolbar click on the “« Insert objects button and then, in the horizontal toolbar that

is displayed, click on {U Poly.

From the Laser Editor menu bar, choose Actions > Insert > Poly.

Position the mouse pointer at the required start point for the polygon and left click.
To create a curve: Left-click and hold down while dragging to the desired position:

(For further information on nodes, see Starting nodes editing)

Once the pointer is in the desired location, left-click to draw a green-colored line.

Repeat the previous step as many times as required to add subsequent corners of the polygon.

To close the polygon click on the first click point. The selection handles appear around the object. To
exit the Poly creation mode, press Esc.

(For further information, see Using the mouse to select and manipulate objects).

To add a Line, do one of the following:

1.

)
On the vertical toolbar click on the “= Insert objects button and then, in the horizontal toolbar that

&
is displayed, click on e Lines.
From the Laser Editor menu bar, choose Actions > Insert > Lines.
Click and drag to draw the desired line.
To close the line click on the first click point. The selection handles appear around the object. To exit
the Lines creation mode, press Esc.

(For further information, see Using the mouse to select and manipulate objects).

To operate on shapes:
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Use the Properties window, the toolbars or the mouse to customize the look of the shape, in terms
of size, position, rotation, filling, and so forth, as well as for setting custom laser parameters.

Select the shape, then double-click it: This will result in the shape's segments changing to the green
color and in the Edit nodes function being enabled. See Starting nodes editing.
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Using Text strings

Wil | ACEOrs | Liglr Window Halp

FErmo 00 jeCiis ) Lig ¥ m]._u‘f
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By using the toolbar button or the Actions menu, Laser Editor allows you to insert text strings in a layout.

You can then use the Properties browser, the toolbars tools, or the mouse to set dimensions, printing
character, font style, spacing, shear and filling. (Click a properties title, then press F1 to open a table with a
description of the properties.)
Laser Editor allows you to:

e dynamically display updated texts;

e use special character s to create variable texts (date, time, auto-incremental counter);

e place the text inside or outside of a circumference arc;

e import any kind of font;

e set the font, dimensions, style, printing characters, spacing, and filling;

e edit strings as pure vectorial objects;

e rotate, shear, or resize strings using the mouse (see Using the mouse to select and manipulate
objects);
e set custom laser parameters that differ from those that have been set for the document.
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The following sections describe how to work with Text Strings:

Adding a Text string

Changing the characters style (see Style properties)

Aligning the text to a circle (see Circle properties)

Importing fonts
Using special character sequences

Making a text string to include an incremental counter

Editing a string as a pure vectorial object

Dynamically managing strings that share contents

Working with ligatures

Using the tiling function

Text String properties

Common operations on objects

Adding a Text string
To add a string:

1.
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Create or open a document to enable the insertion of objects (see Creating graphic
layouts and Opening existing layouts).

Do one of the following:

&
0 On the vertical toolbar click on the ‘< Insert objects button and then, in the horizontal

toolbar that is displayed, click on JP Text string.
0 From the Laser Editor menu bar, choose Actions > Insert > Text string.

The String object is displayed in the work area, surrounded by the selection handles: for quick, rough
sizing, rotating, or positioning, use your mouse (see Using the mouse to select and manipulate

objects).

Use the Properties window and the toolbars buttons for formatting and customizing the string. (See
below).

Tip:

For a quick-reference on using toolbars in Laser Editor, see Using toolbars tools.

Clicking a properties title in the Properties window and then pressing F1, opens a table with a
description of those properties.
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Importing fonts

Attention:
A In order to enable this function, all documents have to be closed.

By default, Laser Editor uses standard fonts but you can use this function to import any kind of fonts. You will
then be able to select the fonts from the Font property list under the Style property group.

Furthermore, two non-standard, single line fonts are provided (namely, Roman-s and Standard) that allow
optimizing the marking time.

To import fonts:
1. Choose File > Import fonts from the menu bar. The Font import dialog box is displayed.

The System font area on the left lists all the fonts that are currently installed on your system; by
selecting a font, a preview is displayed on the left pane.

2. Select the font(s) you want to import in Laser Editor, and then click j to enter the font in the Laser
fonts list on the right.

3. Click ﬂ to import all existing fonts.

Using special character sequences

You can use the Text string tool to create variable texts that include dates and/or times. To do so, you will
use special character sequences.

To create dates and times by using special character sequences:
1. Add a text string to the document (see Adding a Text string).

2. In the Properties browser, under String select the Text box, and then enter the desired special
character sequence, depending on the date and/or time format you want to use. Use the following
table as a reference:

Table 1 Special character sequences for dates and times

Special

character Result

sequence

%a, %A Day of the week, abbreviated (a) or full (A)
%b, %B Month of the year abbreviated (b) or full (B)
%c Date and time according to current location
%d Day of the month, decimal number (01 -31)
%H Time 24 hour clock format (00 - 23)

%l Time 12 hour clock format (01 - 12)

%] Day of the year, decimal number (001 - 366)
%m Month of the year, decimal number (01 - 12)
%M Minutes, decimal number (00 - 59)

%p A.M. / P.M. indicator

%S Seconds, decimal number (00-59)
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%U
%w
%W
%X

%X

%y

%Y

%z, %Z
%%

%[ID]

%fttc
O0#X

%Vv[], %V[]

%f

%TI(]

Week of the year, decimal number (00 - 51, Sunday is the first day of the week)
Day of the week, decimal number (1 - 7, Sunday = 1)

Week of the year, decimal number (01 - 52, Monday is the first day of the week)
Date according to current location

Time according to current location

Year, two digit decimal number (00 - 99)

Year, four digit decimal number

Time zone, name (Z) or abbreviation (z)

Percentage sign%

Percentage sign followed by an ID string that allows copying the content of a string into
another string for dynamic update. (See Dynamically managing strings that share
contents, for further information).

Long date and time representation, appropriate for current locale. (For example:
Tuesday, April 1, 2008, 12:41:29)

Long date representation, appropriate for current locale. (For example: Tuesday, April 1,
2008).

These sequences allow using global variables. V forces the capitalization. (For further
information, seeUsing global variables).

It allows encoding the FNC1 character for symbologies supporting the GS1 standard.
(For further information, see section Using Codes, GS1-128 standard, and GS1 Site).
Example: providing a text value %f00350123451234567894 to a 128 code, encodes a
GS1-128 having Al 00 and code 350123451234567894.

Inserts the ASCII character corresponding to the number between square brackets. It is
useful for adding string ASCII char that do not have a graphical representation. (For
example: %T[21] will encode the NAK ASCII code.

3. After entering the selected sequence, press Enter. The string changes to the selected date and/or
time format. Set the required parameters for the string by setting the Text String properties, or using
the toolbars buttons.

Example:

e Entering the sequence %d/%m/%Y in the text box will result in a text string with the following
format: 01/04/2008.

e Entering the sequence %d/%m/%y in the text box will result in a text string with the following
format: 01/04/08.

¥

To enter the character % into the string, type it twice %% into the Text box.

60



CREATING GRAPHIC LAYOUTS

Making a text string to include an incremental counter

You can use the Text string tool to create a variable text that includes an incremental counter. To do so, you
can:

e Use special character sequences to associate a counter to a specific string.

Note:

Use of this type of counter is maintained for legacy software support only. You should avoid using

A it in new projects. This counter is deprecated in favour of global variables. Using such counters
from the Editor may result in a value presentation not aligned with the one in use from the
Engine.

e Create a global variable so as to save the counter at the device level, and then use proper special
character sequences to associate it to more strings and/or documents. (See section Using global
variables).

To use special character sequences to create a counter:

This procedure describes how to use special character sequences to associate a counter to a specific string,
into a specific document. (To create a variable that you can share between more strings and/or document, as
well save at a device level, please refer to section "Using global variables" on page 133.)

1. Add a text string to the document (see Adding a Text string).

2. In the Properties window, under String select the Text box, and then enter the desired special
character sequence, depending on the type of counter you want to create. Use the following table as
a reference:

Table 2 Special character sequences for counters
Special character

Result
sequence
%n Counter, decimal format. It can be associated to a specific string.
%0 Counter, octave format. It can be associated to a specific string.
%e. U Counter, hexadecimal format, lower case (e) or upper case (E). It can be associated to
' a specific string.
%v, %V It allows using a global variable (see Using global variables).
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3. Press Enter. The string changes to the specified counter format. Set the required Counter properties.

4.

Counter property

Properties 8 x|
Property alue I:
= Skring
Tent String
- Style
Font Times Neaw Foman
T Ttake
Huight 10,00
Shear 0,00
Angle 0.00
= Displacem...
Spacing 0.00
Campres..| 160,00
Circle Falsm
- Counter
Skart il
i Skop oog
- Current a
Fep 1
Cycles 1
Digk 3
Filling None

Use the following table as a reference:

Description

Start The minimum value for the counter.

Stop The maximum value for the counter.

Current The current value of the counter as it appears in the string.

Step Increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented by one
step.

Digits The minimum number of digits to be displayed.

Example

62

Entering %n in the text box and then setting the parameters as follows
Current =1 - Start =1 - Stop = 10 - Steps = 2 - Cycles = 2 - Digits = 3

would result in the format 001 to become 003 ... 005 ... 007 ... 009 ... 002 ... 004 ... 006 ... 008 ... 010
... 001.

An increment would occur every two engraving jobs.
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Editing a string as a pure vectorial object

This procedure involves making the string a pure vectorial object.

This way, the string looses its specific properties and changes to a vectorial object that you can edit by using
the Edit nodes function of Laser Editor. (See Editing objects vectors).

To edit the vectors:

1.
2.

5.

Select the string you want to make vectorial.
Do one of the following:

1. From the Laser Editor menu bar, choose Actions > Make vectorial.

a

2. On the vertical toolbar, click o/ and then click WA Make vectorial in the horizontal toolbar.

%Y

To enable the edit nodes function, click the . Edit nodes button. This will result in the Edit
nodes horizontal toolbar being displayed and in the color of the outline changing to green.

Click the string to display nodes and control points that you can use to edit the characters:

I.‘[ 3

For detailed information on how to edit nodes, please refer to section Editing objects vectors.

D
To exit the Edit nodes operating mode, click the < Insert objects button.

Dynamically managing strings that share contents
Laser Editor allows for dynamically managing strings contents.

Suppose that you have two strings that share the same content and that you want to keep their content
aligned if a change occurs. To do this, you can connect the strings content to each other by means of their
ID, which is a unigue alphanumeric string that identifies the object into the layout.

=

Note:
Circular references are not allowed. If a circular reference is being introduced, an error message

will be displayed.
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To use IDs to connect and dynamically update text strings:
1. Select the string whose content you want to enter in another string.

2. Associate an ID to the string: In the Properties window, under Geometry, click the text box
beside ID and then enter the desired alphanumeric string. Note that the ID appears below the string:

T e = A
H ) {r’“‘:‘u@‘[

ARSI\
— 3 St

3. Add to the document the string that must share the same content as the above string. (See Adding a

Text string).

4. In the Properties window, under String, click the text box beside Text and enter %[St1] followed by
the text of the new string, as it is illustrated below:

In this way, when the string IDTest changes, the second string will be also dynamically updated.

Working with ligatures
What is a ligature?

A ligature occurs where two or more letter-forms are joined as a single glyph. Ligatures usually replace
consecutive characters sharing common components.

For example, in the Arabic alphabet, historically a cursive, most letters take a variant shape depending on
which they are followed (word-initial), preceded (word-final) or both (medial) by other letters.

From the point of view of an engraving layout, the ligatures would appear as letters (that is, vectorial data)
overlapping each other; as a result, the overlapped areas would not be filled as expected.

To fix the problem, the Contour property is used, which allows merging the letters, while keeping the string
from becoming a vectorial object.
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Using the Contour property to merge the letters:

1. Select the text with ligatures (letters that overlap each other).

2. From the Properties window, select Filling and then, from the dropdown list, choose the desired
filling value. (For further information, see Filling properties for Objects). The overlapped areas will

appear as follows:

N — |
| Interine 0.10
| dgie 0.00
" 4 Ure-drechonal Faisn
| Cutine Trae
Jutine First Faisn
| eoumetry
4]
| Eriatsde Tiise
Locked Falss
| Kt Aspact Fui
i I_ I ok Faksa

3. Under Geometry, select the Contour checkbox to set the True value. As a result, the overlapped

areas will be filled and the object will be kept as a String:

Text String properties

Angle 0.00
Lry-drestong Fabe
[T Trig
Dl Frst Fahe
= Gercsmetry
14}
Enalsle Tae
ludcbd Fae
ch Faks
-l pertour

The Properties window supports context-sensitive Help: During layout editing, selecting a properties title (for

example, Geometry), and then pressing F1, opens the context Help for those properties.

The following properties appear when a Text string object is selected in the work area (see Using Text

strings).

Tips:

For a quick, rough sizing, rotating, and positioning of a string, you might use your mouse
@ (See Using the mouse to select and manipulate objects).The Property browser allows more

precise operations.

Refer to section Common operations on objects for further information on how to use properties

to perform specific operations on the object.

Property |Subproperty |Description

The text string to be engraved. Select the Text box, enter the string or the value

Text

of the variable which represents it and press Enter. (For information on how to

use special characters sequences, refer to Special character sequences for

dates and times and Special character sequences for counters).
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The converted font that the text must use. The dropdown list contains the

Font available fonts. You might also import new fonts (See Importing fonts)

Style The font style to be applied to the string. The dropdown list contains the
y available options.

Height The height of characters.

Shear Represents the shear of the selected string on the X axis.

Style Represents the angle of rotation that a single letter uses in relation to its
origin. The example below shows a string with a character angle of 15
degrees:

Angle Times New B
i Faguilar
@‘ - 11 L
U e 0.0
S{rIng e
Represents the distance between the string's characters (default value is
Spacing 0). Negative values decrease the default spacing, whereas positive values

Disp|acement Increase It.

. |Represents the compression of each character of the string (default value is
Compression 100)

If enabled (True), the Circle property enables placing the text on a circumference arc
(default value is False). Setting the value to True, will result in making the following
properties visible for you to specify the appropriate parameters:

Represents the diameter of the circumference arc to align the string on. Set
a value other than O to create a circle. The figure shows a circle with a
radius value of 8:

L= Argle Q.00
-(:T:' T1 - Displacement
. INR\RP ) Spacing 0.00
Radius Ny Compression 100,00
?’ ) a1 a8 = Drcle True
“'iﬁ?f—- * (' ™ : —l Racdiue .00 _]
Counrter doclwise  Palse
I Fatse
Buito start argle True
-1 Cownlér
Counter Sets the direction of text on the circumference arc. By default, is set to
Circle clockwise clockwise.
Inside If enabled (True), it allows placing the string within the circle.

If enabled (True), it allows setting the start point of the string on the arc.
You can then set the start point in degrees in the Start Angle field below.
The figure shows an Automatic start angle (when this option is set to

False):
P -
?}W}m 5% Compression 100,00
Autostart = Circle True
ang]e Radies B.00

&

Start angle |Represents in degrees the start point of the string on the arc.
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The Counter group enables creating a variable text that includes an incremental counter
(see Making a text string to include an incremental counter).

Start The minimum value for the counter.
Stop The maximum value for the counter.
Counter Current The current value of the counter as it appears in the string.
Step Increment value (positive or negative).
Cycles The number of times the counter will be marked before it is incremented by one
step.
Digit The minimum number of digits to be displayed.

Formatters are source files that are supplied with Project Editor. These files can be used as

functions libraries. Their purpose is to make it easier for developers to create custom

applications. For example, as an integrator, you might need specific functions that these

libraries provide. Formatters have a .qs extension and are stored in the folder
Custom ...\Data\Formatters.

Formatters True or
False Enable or Disable the use of a Custom Formatter file
. Visible only if Custom Formatters is set to True. Use to select the Custom
Script . . .
Formatters from a list of available files.
See also:

. Geometry properties for Objects

. Custom Laser parameters for Objects

. Filling properties for Objects
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Using Codes

[ 11 B
biidd

Codes are representations of text data that is formatted and displayed especially for automatic acquisition by
dedicated optical devices (code scanners or readers).

There are several codes symbologies, which are provided in Laser Editor:
e Linear

Postal

Stacked

e Two-dimensional (2D)

By using the Code toolbar button or the Actions menu, you can insert codes in a layout.

You might then use the Properties browser or the toolbars tools to set dimensions, the type of standard, the
size, the error levels, a checksum, the filling and so forth. (Clicking a properties title in the Properties window
and then pressing F1, opens a table with a description of those properties).

The code is treated by Laser Editor in the same way as a text string, therefore it is possible to associate the
functions of special character sequences as described for the string object. (See Special character
sequences for dates and times and Special character sequences for counters.)

Furthermore, you can:
e set dimensions, black and white ratio, and filling;
e rotate or resize the code;
e set custom laser parameters that differ from those that have been set for the document.

The following sections describe how to work with Codes

e Usual Codes terminology

e About linear bar codes

e About stacked bar codes

e About two-dimensional (2D) codes

e Adding a code
e Setting the data restoring capability

e Balancing the black and white ratio

e Codes properties

e Using the tiling function

e Common operations on objects
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Usual Codes terminology

Bar code symbol

A complete bar code, made of a blank area before the code, a start character, one or more characters
containing the information, a stop character and a final blank area (quiet zone).

Black/White ratio

The ratio between white and black modules. You can fine-tune this ratio when marking very small elements.

Codewords

Group of bars and spaces representing one or more numbers, letters, or other symbols.

Element

Name of a space or a bar.

GS1-128 standard

The GS1-128 standard is an application standard (visit the GSI Site for further information) within the Code
128 barcode. It allows using a series of Application Identifiers to include additional data such as best before
dates, batch numbers, quantities, weights and many other attributes that a user might need. It's supported in
our software by Using special character sequences.

Inter-character space

A space which separates two adjacent characters, in some codes (code 39, bar code) the spaces inside a
character contain information, inter-character spaces do not.

Linear bar code

A linear bar code symbol (also known as 1D barcode) is made up of a series of bars and spaces which
contain information and check elements.

Module

The smallest thickness in a code element. In the case of linear bar codes, it constitutes the measurement
unit of the thickness of wide elements. In the case of 2d codes, it is a single cell, which represents a bit in the
code representation. It is represented by a square.

Quiet Zone

The blank spaces immediately preceding the start character and following the stop character.

Print ratio
In two thickness codes, it is the ratio between the thickness of the wide element and that of the narrow one.

Stacked code

A symbol that is broken into sections and "stacked" one upon another similar to sentences in a paragraph.
Extremely compact codes.

Two-dimensional codes (2D codes)

A two-dimensional code (also known as matrix code) is built on a true 2-D matrix. It is a two-dimensional way
of representing information and contains information in both the vertical and horizontal directions.
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About linear bar codes

A linear bar code symbol (also known as 1D barcode) is made up of a series of bars and spaces which
contain information and check elements. Bars can be all same lenght or have some of them longer
protruding the bottom part as in EAN codes.

In Linear symbologies there are also the Postal Codes can be distingueshed by bars disposed always the
same interval, same width but different bar heights (up to 4) like the Royal Mail code shown here below.

The following shows the EAN 8 linear bar code and the Royal Mail code:

|| ni |||||| I |||| b gy g oy 1
0123%4565" 12345678

The following represents the structure of a bar code symbol:

Where:
e Y: Thickness of the wide element

e X: Thickness of the narrow element
e Q: Thickness of the blank overflow zones at the end of the label (quiet zones)

Available linear bar codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired code from the dropdown list:

Note:
@ For further information on properties, and for a description of the available codes, select
the Encoding properties title and press F1 to display the relevant Help topic.

Bar codes with two thickness

Bars and spaces of code 20f5 or 39 can just assume two thicknesses, in a print ratio between 2 and 3, which
is the standard-compliant ratio. To set this parameter use the Advanced > Print ratio property in the
code's Property. (See Codes properties).

There are other codes in this category (Codabar, code 32, etc.), but their print ratio is fixed.

Bar codes with multiple thickness

There are many code symbologies whose bars and spaces can assume more than two different thickness.
Some examples of them are EAN, UPC, code 128, code 93, DPD code, etc..

Postal codes

This kind of symbologies is built with same bars having same width but varying height. Bars are regularly
interspersed since also the the distance of consecutive bars equals the bar width.

Where bars have two different heights (short and long bar), they share the same base line, growing bottom
up. Examples are US Postal, CEPNet, Planet.

Where codes uses three different heights consist of long bars and short bars either growing bottom up or to
down, and short bars. One example is the Pharmacode 2-Track.

Barcodes with four different heights consist of long bars, medium sized bars either growing bottom up or to
down, and short bars, drawn vertically centered. Examples are Australian Postal, Royal Mail 4 State, KIX,
Intelligent Mail® Barcode, DAFT, Japanese Postal.
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Related topics:

e Usual Codes terminology

e About stacked bar codes

e About two-dimensional (2D) codes

e Adding a code
e Setting the data restoring capability

e Balancing the black and white ratio

e Codes properties

About stacked bar codes

Stacked bar codes are a compromise between true 2D barcodes and linear codes and are constructed like a
layer cake of barcodes stacked on top of the other. These are extremely compact codes.

Codablock-F and PDF 417 are examples of stacked bar code, where a long symbol is broken into sections
and "stacked" one upon another similar to sentences in a paragraph. See picture below:

e (G |

12345678

In particular, PDF 417 has error correction capability that allows restoring data if the code is dirty or
damaged. For further information, see Setting the error correction level.

Available stacked bar codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired 2D Code from the dropdown list:

Note:
@ For further information on properties, and for a description of the available codes, select
the Encoding properties title and press F1 to display the relevant Help topic.

PDF417

MicroPDF417
Codablock F

GS1 Databar Omni
GS1 Databar Stacked
GS1 Databar Expanded
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About two-dimensional (2D) codes

A two-dimensional (2D) code (also known as matrix code) is built on a true 2-D matrix. It is a two-
dimensional way of representing information whose primary advantage is the ability to encode a lot of
information in a small space.

A 2D code contains information in both the vertical and horizontal directions, whereas a bar code contains
data in one direction only.

Information encoded in a 2D matrix code symbol, can be recovered even if the mark is damaged and missing
a portion. This capability depends on how much redundant information your code contains and on the error
correction level (see Setting the data restoring capability).

Matrix codes are made up of a pattern of cells that can be dot, square (as in the Datamatrix 2D code here
below), hexagonal or circular in shape, like the MaxiCode code shown here below:

| N %{5,
:rari,\;..;& .,

2P (]

Y A

SeLdsrrrdIrd
B g

123456abc0

Available 2D codes in Laser Editor
The Encoding Type property of the Code allows selecting the desired 2D Code from the dropdown list:

Note:
@ For further information on properties, and for a description of the available codes, select
the Encoding properties title and press F1 to display the relevant Help topic.

e Datamatrix
e QRcode
e MicroQRcode

Adding a code
To add a code:

1. Create or open a document to enable the insertion of objects (see Creating graphic
layouts or Opening existing layouts).

2. Do one of the following:

o On the vertical toolbar click on the & Insert objects button and then, in the horizontal
I
toolbar that is displayed, click on & Code.

o From the Laser Editor menu bar, choose Actions > Insert > Code.

3. The Code is displayed in the work area. By default, the last code type is used but at first installation
the linear bar code type 128 is displayed. To change the symbol, in the Property browser:
under Code symbol, select Encoding > Type, then choose from the dropdown list the option that
best fit your requirements. (See Codes properties for more information on the available codes).

4. Use the Properties window to set other code parameters, and the mouse and toolbars buttons to
operate on it.

Tip:
or a quick-reference on using toolbars in Laser Editor, see Using toolbars tools.
@ Clicking a properties title in the Properties window and then pressing F1, opens a table with a
description of those properties.
For further information on how to operate on objects, see Common operations on objects.
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Setting the data restoring capability
Information encoded on 2D codes can be recovered, even if the mark is damaged and missing a portion.

This capability depends on how much redundant information your code contains and on the error correction
level that you set. Greater redundancy and higher error correction level result in a greater recovering ability,
but impact code dimensions and, consequently, the marking time.

Note that PDF 417, which is a stacked codebar, has error correction capabilities.

For further information:
e Setting the level of redundancy for 2D Codes
e Setting the error correction level

Setting the level of redundancy for 2D Codes

Note:
@ Please consult the "Barcode Reference.pdf" for specific information about each simbology
supporting this feature.

In the case of 2D Codes you can set different codes dimensions, that is, you can specify how much
redundant data your code can contain.

2D Codes range from smaller to larger versions. Each version has a different number of modules. Note that,
as the amount of data increases, more modules are required to comprise the code, resulting in larger code
symbols.

You can use the Size property in the code's Property browser to determine the dimensions of the symbol so
as to suit your redundancy needs. (See Codes properties).

To set codes dimensions:
1. Select the code in the document. The Property browser is displayed for the code.

2. Under Encoding, in the Code properties group, select from the Size dropdown list the desired value.
Note that the Best Fit options correspond to the minimum size for the information to be encoded.

The following figure shows a range of sizes in the case of a QRCode:

Verson 12

Version 3 :_._,_, :?DW,I;W o7

QRCode

Best Fit (Version 1)
00
1)

i

21 % 21 modules 29 ¥ 29 modules 65 x 65 modules
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Setting the error correction level

Note:
m This option applies to Two-dimensional (2D) codes and some others. Please consult the
"Barcode Reference.pdf" for specific information about each simbology supporting this feature.

The error correction capability allows restoring data if the code is dirty, damaged or partially unavailable.
Many codes allow setting different error correction levels.

Different error correction levels are available for users to choose according to the operating environment (the
amount of data that needs to be encoded, the size and the amount of symbol damage that could occur),
each corresponding to a different data restoration rate for total codewords. Raising this level improves error
correction capability but also increases the amount of data and QR Code size.

You can use the Error Level properties in the Property browser to set the error correction. (See Codes

properties).

To set the error correction level:
1. Select the code in the document. The Property browser is displayed for the code.

2. Under Encoding, in the Code properties group, select from the Error Level dropdown list the
desired value.

Balancing the black and white ratio

This capability allows adjusting the ratio between white and black elements when marking very small
elements.
This feature is also referred as "Bar Width Reduction” (BWR), "Bar Width Correction" (BWC), "Pixel
Shaving".

In this case, the dimensions of the spot might have an effect on the black and white dimensional ratio and
you might need to balance the ratio. The engraving elements (black) must be identical to the empty ones.

To balance the ratio:
1. Select the code in the document. The Property browser is displayed for the code.

2. Under Encoding, in the Code > Advanced properties group, set the Black/White ratio value to the
desired percentage. The default is 100%, meaning that black and white elements are identical.

3. Set a lower percentage to compensate the dimension of the spot laser.

Codes properties

The Properties window supports context-sensitive Help: During layout editing, selecting a properties title (for
example, Geometry), and then pressing F1, opens the context Help for those properties.

The following properties appear when a Code is selected in the work area.

Tips:

@ Refer to section Common operations on objects for further information on how to use properties
to perform specific operations on the object.
Refer to Usual Codes terminology for a description of the technical terms.
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|Group ||Property ||Va|ues ||Description |

The string to be engraved in the TEXT field of the code, or
the value which represents it. (See Special character

Text sequences for dates and times and Special character
sequences for counters).
|Encoding ||Type || ||Represents the encoding type. |

Linear bar code with multiple thickness. It is used for
alphanumeric or numeric-only barcodes, variable length. It is
the default value. It can host GS1-128 standard. It is a
modern high-density symbology and was invented 1981 by
Computer ldentics. The software analyzes input data and
chooses the best suitable barcode representation with the
highest data density. This is done by so-called “subset
switching”. 3 different internal characters (=subsets) sets are

used:
128 e Codel28A = Upper Case + Non-Printable Characters
(ASCII 0-31)
e Codel28B = Upper / Lower Case + All Printable
Characters

e Codel28C = Numeric with doubled density

Codel28 uses a built-in check digit (Modulo 103). This check
digit is part of the code and cannot be omitted. It is never
printed in the human readable text. Scanners are checking it
when reading a code but do not deliver the check digit to
connected systems.

Linear bar code with two thickness. It is a numeric-only

25 barcode.

This is a self-checking code. It is used for industrial
applications, article numbering, photo development, ticketing.

Industrial ||As above, but with a different Start/Stop character encoding |

Standard

Code 2 of 5 Interleaved is in wide-spread use (article-
numbering, industrial applications). This self-checking code
offers high data capacity due to encoding pairs of numbers
Interleaved (the first digit is encoded in the bars, the second in the
spaces). Thus, this symbology can encode only an even
Subtype number of digits. If the number of digits is odd a leading zero
will be inserted automatically

This is a self-checking code. Start/stop-characters are
identical to Code 2 of 5 Industry. It supports distance reading
IATA (> 1m) and can be printed with very simple printing
techniques. It is used for baggage handling in air-transport
applications (International Air Transport Agency = IATA).

This symbology is proprietary variant of Code 2 of 5

Datalogic Standard.
Checksum ITrue or False \I/]:I()I:’dlss set to True, enables a terminating checksum code-
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3/9

Code 39 is in heavy use in industry, organizations and
commerce. It was developed 1974 by INTERMEC and got
standardized by ANSI MH 10.8 M-1983 and MIL-STD-1189.
Linear bar code with two thickness. It is a self checking,
medium density, alpha-numeric bar code, variable length.

Subtype

|Standard

||Encodes 43 characters: A-Z, 0-9, space, and -.$/+%. |

Full

This version is rarely used because Code 128 offers much
better compression. It uses the same symbology as Code 39
but encodes also lower-case letters and special characters
,+A" results in a lower case ,a“ when scanned). Scanner
must be configured correctly for decoding Code39
Full/Extended.

LogMars

This is a special variant of Code 39 used by the U.S.
Department of Defense. This standard defines acceptable
ranges for a number of variables, include density, ratio, bar
height, and size of the human-readable interpretation line.
The modulo-43 check digit, which is optional for Code 39, is
defined and recommended in the specification.

Checksum

True or False

If it is set to True, enables a terminating checksum
codewords.

93

Code 93 was invented 1982 by INTERMEC to achieve better
information densities (compared to Code 39). Code
concatenation is possible (if the first encoded character is a
space subsequent barcodes are concatenated by the
scanner).

Subtype

Standard

||Encodes 43 characters: A-Z, 0-9, space, and -.$/+%. |

Extended

Based upon Code 93 but encodes the complete ASCII
character set. One of the four available control characters is
used to shift into the ASCII-character table.

Australian Post

This barcode is used by the Australian Post for marking
shipments. Special code variants are available for
redirections, replies and so on.

Subtype

Customer

The barcode height is between 4.2mm and 5.8mm. The
module width should be adjusted to 0.47 mms. Usual no
readable text is displayed. The length will depend on the use
of additional bars (code variants Customer 2 and Customer
3).

Customer 2

This is the same barcode as the Australian Post Standard
Customer, but with additional 5 characters for customer
specific data. The first 8 characters must be digits. This
symbology is also calledAustralia Post 52-CUST (Due to its
52 bars).

Customer 3

This is the same barcode as the Australian Post Standard
Customer, but with additional 10 characters for customer
specific data. The first 8 characters must be digits. This
symbology is also calledAustralia Post 67-CUST (Due to its
67 bars).

|Redirect

|If selected, the code can contain up to 8 digit |

|Rep|y Paid

||If selected, the code can contain up to 8 digit |

|Routing

|If selected, the code can contain up to 8 digit |
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Aztec Code can encode from small to large amounts of data
with user-selected percentages of error correction. The
symbol size adjusts automatically depending on the amount
Aztec Code of input data.The input data is always analyzed and the
appropriate encoding mode is chosen automatically. Mode
switching is done as required to produce the most efficient
encoding.

This code is used by the Brazilian Postal Services. An 8 digit
ZIP-code is encoded.The check digit is -calculated
Brazilian CEPNet / Brazilian |automatically. It cannot be specified in the input data.The
Postal Code barcode height should be adjusted to 3.2 mms; the module
width to 0.423 mms; usually no plain text is displayed. The
encoding is based on US Postal codes.

The characters “A”, “B”, “C”, and “D” are useable as start or
stop characters only. The barcode uses 2 element-widths and
4 different start/stop-characters (A, B, C, and D). These
Codabar start/stop characters can be utilized for additional information
— e.g. "B1234B". The print ratio should be in the following
range: 1:2 -1:3 (Pr >= 2.25:1). Since the symbology is “self-
checking” there is no established check sum method.

Is de facto a “stacked” Code128 symbology. It is based upon
Code 128 - each row is a single Code 128 symbol extended
with row indicator information and additional check digits. The
UCC/EAN/GSL1 format indicator is supported.

This symbology is mainly used in telecommunications for
marking equipment and components. It was invented in 1977
by INTERMEC. It is similar to Code 2 of 5 Matrix. The
Code 11 symbology is not self-checking therefore 2 check digits are
recommended. Code 11 is a high-density code, but requires
also a high-density output device (mainly because of the print
ratio utilized).

It is used by the Italian Pharma Industry. The code is also
called Italian Pharmacode. The Code 32 number, consisting
Code 32 of 9 digits, is converted to an equivalent Code 39 Barcode of
6 characters. The letter the human readable text is
prepended by “A” which is not encoded.

DAFT Code is no symbology. It is a technique to generate

Codablock F

DAFT code arbitrary postal codes (like for instance the Australian Postal
Codes or the Royal Mail 4 State code).
|Deutsche Post ||This symbology is used by Deutsche Post. |
The code is basically a Code 2 of 5 Interleaved enhanced
Leitcode with a special check digit calculation. It is used for encoding
Subtype the ZIP-Code, Street and number of the shipment.

The code is basically a Code 2 of 5 interleaved enhanced
with a special check digit calculation.

DotCode is 2D dot code symbology designed to be reliably
readable when printed by high-speed inkjet or laser dot
technologies. The encoding modes of DotCode are based on
the Code128 data encoding (with modes A, B, and C)
Dotcode extended by a so called Binary Mode. The default
interpretation for DotCode data is ECI 000003 representing
the Latin-1 character set. The DotCode symbology does not
have absolute capacity limits, but a maximum symbol size of
124x124 dots is recommended

Identcode
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Subtype

Auto Discriminate

If the data starts with 2 digits, barcode has GS1 format,
otherwise generic format is used

Generic Format

Barcode data does not fulfill any special format, if it starts
with 2 digits, FNC1 is inserted

UCC/EAN/GS1

The internal data must start with 2 digits and has to apply to
a format of an so-called application identifier

|Industry

||A peculiar industry format, which adds FNC1 at 2nd position |

Macro 05

The data is prefixed with “)>" + RS + “05” + GS and suffixed
with RS + EOT

Macro 06

The data is prefixed with “[)>" + RS + “06” + GS and suffixed
with RS + EOT

Macro 12

The data is prefixed with “[)>" + RS + “12” + GS and suffixed
with RS + EOT

Custom Macro

The data is prefixed with “[)>" + RS and suffixed with RS +
EOT,; the rest of the format specifier has to be encoded by
the user

Reader
Programming

The barcode data is used to program the barcode reader

DPD

DPD Code is used byDeutscher Paket Dienst. It is based on
Code 128 and is limited to 28 encoded characters. The
encoded data and the human readable text differ slightly

EAN

Linear bar code with multiple thickness. It is a self checking,
numeric code.

This symbology is reserved for the European Article
Numbering (EAN).

The number is maintained by EAN and encodes
manufacturer and product.

The check digit is calculated automatically if not specified in
the input data (that is when only 7 digits are used for creating
the code)

Subtype

If selected, the code can contain up to 8 digit numeric.
It's used for marking small articles with restricted space.

8+2

This symbology extends EAN-8 with 2 add-on digits which
are mainly used for encoding the price or the weight.
This symbology is also used for bar-coding paperbacks or
newspapers. In this case a 2(3) digits country code and a
4(5) article code are encoded.

8+5

This symbology extends EAN-8 with 5 add-on digits which
are mainly used for encoding the price or the weight.

13

|If selected, the code can contain up to 13 digit numeric. |

[13+2

||This symbology extends EAN-13 with 2 add-on digits. |

[13+5

| This symbology extends EAN-13 with 5 add-on digits. |

128

The EAN-128 code is based upon Code-128. It has an FNC1
character at the 1st position (after the start code). This allows
scanners and data processing software to differentiate EAN-
128 from other symbologies.

The EAN-128 code is in wide spread use (retail, logistics,
food and beverage, etc.). It is used for marking transport-
units in supply chains. Besides the article-number it encodes
guantities, weights, prices, dates, and other information in a
structured way. This is supported by the use of so-called
Application Identifiers (Als) — see chapter 5.
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If it is set to True, displays and marks the human readable
string

This is a special “barcode” used for recognizing the correct
sequence of pages in print-shops.

GS1 DataBar is used to encode the GTIN (Global Trade Item
Number) with Application identifier (Al) “01“. The GTIN
consists of a packaging indicator (0..9) followed by a 12 digit
number (taken from the EAN-13 article number system)
followed by a check digit. The check digit on the 14" position
is computed automatically if not provided in the input data

The height of the symbol should be at least 33X in order to
support omnidirectional scanning (X = module width). TEC-IT

Text String || True or False

Flattermarken

GS1 DataBar (RSS-14)

Standard software prefixes the barcode data with the Al “01”
automatically - do not provide the Al 01 with your input data.
This symbology is similar to GS1 DataBar but the height
Truncated should be at least 13X. Omni-directional scanning may not be
Subtype possible.

This symbology is similar to the GS1 DataBar Stacked and
supports omnidirec tional scanning.

This symbology is similar to GS1 DataBar, but it is split into 2
rows to make the symbol smaller. It is used for
pharmaceutical packaging. Omni-directional scanning is not
possible.

This symbology is similar to GS1 DataBar, but it is smaller in
size and limited to a packaging indicator (first digit) O or 1.

This is a variable length symbology. It encodes up to 74
numeric or 41 alphabetic characters. Data should be encoded
with Application Identifiers (Als). Omni-directional scanning is
possible.

Han Xin Code is a 2D matrix symbology which is used for
encoding large amounts of data and provides a special
support for encoding Chinese characters (character set
GB18030)

HIBC bar codes are commonly used by the health industry.
HIBC standards do not really describe unique symbologies,
but a family of data structures. These data structures may be
represented by several symbologies.
There are two categories of HIBC:

e Label Identification Code (LIC) — specified by the

Supplier Labeling Standard
o Provider Applications Standard (PAS

ISBN is the abbreviation of International Standard Book
Number. It uses the symbology EAN-13 and can be optionally
ISBN extended with 5 Add-On Digits. The add-on is used for
additional pricing information. For more information, please
refer tohttp://www.isbn.org

Omni Directional

Stacked

GS1 DataBar Limited

GS1 DataBar Expanded

Han Xin Code

HIBC

ISMN stands for International Standard Music Number. The
ISMN is a standardized international code, which identifies
printed music.

ISMN The ISMN is preceded by the digits 9790. The ISMN (=EAN-
13) check digit is calculated and appended automatically!
For more information, please referhttp://www.ismn-
international.org/.
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ISSN

ISSN stands for International Standard Serial Number.
The ISSN is a standardized international code, which
identifies any serial publication inde pendently of its
country of origin, its language or alphabet, or its
frequency, medium, etc.

The ISSN is preceded by the digits 977. The check digit
of an 8-digit ISSN code (the last of the 8 digits) must be
omitted! A two digit price code, almost always "00", is
added to the end. Finally the EAN-13 check digit is
added.

Optionally the issue number can be appended as 2-digit
add-on.For more information, please refer
tohttp://www.issn.org

Italian Postal

Italian Postal Code 2 of 5 is based upon Code 2 of 5
Interleaved, but it is limited to 12 digits (11 usable digits +
1 modulo 10 check digit).

Japanese Postal

This code is used by the Japanese Postal system. You
can encode 7 digits followed by block and street number
(uppercase alphanumeric). The special compaction mode
of Japanese characters can be enabled on demand
(Format parameter “J”). This barcode symbology
supports two methods to provide the barcode data (with
and without data—extraction from the Japanese Address
B Field)

|[KIX

|This code is used by the Dutch Postal system |

Korean Postal Authority

This code is used by the Korean Postal system. Encoded
are a 6-digit ZIP and 1 check digit

MaxiCode is in use (and was invented) by UPS®.

MaxiCode represents data by drawing hexagonal items,
which are arranged around a circular center (a so called
"Bull's Eye"). Different encoding modes for including

postal information (SCM) can be adjusted: UPS Modes

MaxiCode are Mode 2 (US Carrier) and Mode 3 (International
Carrier).
The printing size is usually set to a fixed value. If you
want to change the size of the symbol, adjust a custom
module width (default is 0.870 mm)
Mode 4 - SEC/
Standar_d Error The internal data structure is regulated by different
Correction "modes". For standard purposes, data can be encoded
Mode 5 - EEC = with two different error correction levels
Subtype Enhanced E.C.
Mode 2 - SCM .
numeric The modes for "Structured Carrier Message" (SCM) were
defined by the parcel transport service UPS®. If you want
Mode 3 - SCM to use MaxiCode for UPS, please use these SCM modes
alphanumeric
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This stacked 2D symbology is used to encode large quantities of
data. The input data is always analyzed and the appropriate
encoding mode is chosen automatically. Mode switching is done
as required to produce the most efficient encoding.

The MSI-Code is a variant of the Plessey-Code. MSI uses
MSI various check digit calculation methods - Lighter implemented
the 2 most common used.

NVE stands for “Nummer der Versandeinheit” (a German term for
tracking number). This code uses an EAN-128 symbology with a
NVE-18 prefixed Application Identifier (Al) 00. The Al “00” is inserted
automatically and must not be included in the input data. It is
similar to SSCC-18

This code was invented by Laetus®. It is used in pharmaceutical

MicroPDF417

Pharmacode
areas
The data for the bars/spaces is encoded directly in the property
Text:
e “0"is used for a narrow bar (the width of these bars are
enlarged after a color change, according to ratio 1C)
One-Track e “1”is used for a wide bar (the width of these bars are
Subtype enlarged after a color change, according to ratio 2C)

e “b"is used for a narrow bar

e “c”is used for a wide bar

Pharmacode assigns numeric values to the bars. It is used for
Two-Track |medicine packing in pharmaceutically area; for small labels.
Usually Pharmacode is printed without a human readable text.

|Placet ||This code was developed for the United States Postal Services |
Subt |12 ||It is a 3-of-5 variant of the Postnet barcode. |

ubtype
P |14 ||It is a 3-of-5 variant of the Postnet barcode. |

Plessey code is in use primarily in libraries. It is a pulse-width
modulated code and was developed by Plessey Company
Limited in UK. The basic encoding principle in Plessey Code was
used by MSE Data Corporation to construct its MSI barcode. The
check digit is calculated with a polynomial CRC algorithm and is
always part of the symbology

Plessey

PZN uses Code 39 as the base symbology. It uses a special
PZN Germany check digit and the human readable text always contains the
prefix “PZN-* (which is not encoded in the barcode data)

This code is a height modulated code using 4 different vertical
bars. Itis used in mass-mailing applications (Cleanmail, Mailsort)
of the Royal Mail, United Kingdom and Singapore (also called
SinPost barcode). Encoded are ZIPs

Royal Mail

SSCC-18 is used for encoding the Serial Shipping Container
Code. It is used for the unique identification of trade items world-
SSCC wide. SSCC-18 is based on the GS1-128 symbology with
Application Identifier (Al) 00. The check digit is encoded
automatically if 17 digits are used for the input data

Telepen can encode pairs of characters only. A pair must consist
of 2 digits or of one digit and the letter ‘X’

Telepen
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lusPs

||United States Postal Services |

Subtype

Intelligent
Mail®

This symbology is also known as
e OneCode 4CB
e USPS4CB
e 4-CB
e 4-State Customer Barcode
e USPS OneCode Solution Barcode.

Intelligent
Mail®
Package

The barcode data consists of Routing Information and Tracking
Information. The Routing Information is optional. It is not printed
in the human visible text and consists of:

e Postal Code Application Identifier (Al): always 420
e Destination ZIP Code (5 or 9 digits)

Postnet 5

Encoded are a 5 digit ZIP-code. The check digit is calculated
automatically. It cannot be specified in the input data.

The barcode height should be adjusted to 3.2 mms; the module
width to 0.423 mms; usually no plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM® Barcode (4-
State Customer Barcode) additionally includes a 20 digits
tracking code.

Postnet 6

Same as Postnet 5, but the check digit can be specified freely
(the 6" digit). To be used only if the check digit is already part of
the input data.

Postnet 9

Encoded are a 5 digit ZIP-code and 4 additional digits.The check
digit is computed automatically, it cannot be specified in the input
data.

The barcode height should be adjusted to 3.2 mms; the module
width to 0.423 mms; usually no plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM® Barcode (4-
State Customer Barcode) additionally includes a 20 digits
tracking code.

Postnet 10

Encoded are a 5 digit ZIP-code and 4 additional digits.The check
digit is computed automatically, it cannot be specified in the input
data.

The barcode height should be adjusted to 3.2 mms; the module
width to 0.423 mms; usually no plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM® Barcode (4-
State Customer Barcode) additionally includes a 20 digits
tracking code.

Postnet 11

Encoded are a 5 digit ZIP-code and 4 to 9 additional digits. The
check digit is calculated automatically. It cannot be specified in
the input data.

The barcode height should be adjusted to 3.2 mms; the module
width to 0.423 mms; usually no plain text is displayed.

The newer USPS Intelligent Mail®Barcode or IM® Barcode (4-
State Customer Barcode) additionally includes a 20 digits
tracking code.

Postnet 12

Same as Postnet 11, but the check digit can be specified freely
(the 12" digit). To be used only if the check digit is already part of
the input data.
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VIN/FIN

VIN/FIN Code is used for vehicle identification. It is based on Code 39,
but does not contain start and stop characters. The set of valid
characters consists of digits and upper case letters. The letters “I”, “O”,
and “Q” are not allowed because they could be easily mixed up with the
digits “0”, and “1".

VIN/FIN Code is implemented differently in Europe and North
America. Both kinds are compatible but the North American version is
defined more strictly. So the check digit calculation method is only valid
for the North American implementation of the code.

UPC

Linear bar code with multiple thickness. It is a self checking, numeric
code. Checksum required.

Subtype

A

|[if selected, the code can contain up to 10 digit numeric |

[E

||If selected, the code can contain up to 6 digit numeric |

|Text String

||True or False

||If it is set to True, displays and marks the human readable string. |

Datamatrix

Two-dimensional matrix code consisting of black and white square
modules arranged in either a square or rectangular pattern.It can
encode up to 3,116 characters from the entire ASCII character set (with
extensions).

Subtype

|t mode

||The standard format of Data Matrix without a special header. |

UCC/EAN/GS1
mode

Special format defined by UCC and EAN/GSL1 for encoding Application
Identifiers. This format adds the function character FNC1 at 1st position
in the symbol.

|Industry mode

||supports peculiar industry formats (adds FNC1 at 2nd position) |

Macro 05
mode

[)>Rs05Gs is encoded at the beginning of the code, RS + EQOT is added
as trailer

Macro 06
mode

[)>Rs06Gs is encoded at the beginning of the code, RS + EQOT is added
as trailer

Reader
Programming

Activate the Reader Programming Mode.

DP Postmatrix

||Specia| format defined by "Deutsche Post".

Size

This property allows setting the Datamatrix size to fix the code
dimension. (For further information, see Setting the data restoring

capability).

Square Best Fit

Sets the smaller squared dimension according the information to be
encoded.

Rectangular
Best Fit

Sets the smaller rectangular dimension according the information to be
encoded.

10x10 to 48x16

Allows specifying a dimension that ranges from 10x10 to 48x48
modules for the squared size, and from 18x8 to 48x16 modules for the
rectangular size.

QRcode

Quick-Response (QR) code is a two-dimensional matrix code. Large
capacity, small printout size, high speed scan

Size

This property allows setting the QRCode size for redundancy purposes.
Each version has a different number of modules. (For further
information, see Setting the data restoring capability).

Best Fit

||Sets the smaller dimension (21x21) for the information to be encoded. |

Version 1 to 40

Allows specifying a dimension that ranges from 21x21 to 177x177
modules.

Error level

This property allows setting the error correction level for the code,
which allows restoring data if the code is dirty or damaged. To each
level corresponds a higher data redundancy and a different restoration
rate. (Default: M)

|LeveIL

||7% of codewords can be restored

|Leve| M

|Leve| Q

||25% of codewords can be restored

|Leve| H

|
||15% of codewords can be restored |
|
|

||30% of codewords can be restored
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PDF 417

Portable Data File 417 (PDF417) is a multirow, variable
length, stacked linear bar code. It has high data capacity
and high density and is widely used in the automotive
industry.

A data density of up to 900 characters per square inch is
possible.

The input data is always analyzed and the appropriate
encoding mode is chosen automatically.

Mode switching is done as required to produce the most
efficient encoding.

Subtype

|Standard

||It has control bars on both left and right sides.

|Truncated

||It omits the right-hand portion in order to save space.

ISize |

|1 to 30 columns

||Sets the number of data columns for the symbol.

Error level

This property allows setting the error correction level for the
code, which allows restoring data if the code is dirty or
damaged. To each level corresponds a higher data
redundancy and a different restoration rate. PDF 417 uses
Red Solomon error correction. (Default: Recommended).
For further information, see Setting the error correction
level.

Recommended

This value varies depending both on the specification and
the code size.

Oto 8

Allows specifying a level that ranges from 0 to 8. The
recommended minimum level is 2.

IRSS 14(GS1

DataBar)

|Stacked linear barcode. RSS 14 (Reduce Space

Subtype

Standard

Symbology) is a linear symbology that facilitates
omnidirectional scanning. It encodes 14 digits of numerical
data

Omnidirectional

It allows the full height RSS-14 (see above) to be printed in
two rows.

|Truncated

||The height is reduced to a 13X minimum.

|Stacked

||his is a RSS-14 Truncated two-row format.

RSS Limited

(GS1 DataBar)

Stacked linear barcode. It encodes a 14-digit EAN.UCC item
identification with Indicator digits of 0 or 1 in a small symbol

RSS Expanded(GS1 DataBar)

Stacked linear barcode. Can carry up to 74 numeric or 41
alphanumeric data characters in a single row

|Size |

|1 to 11 lines

||Sets the number of lines for the symbol.

MicroQRcode

Two-dimensional barcode. This is a smaller version of the
QR Code standard that fits applications that require a
smaller space and use smaller amounts of data.

Size

This property allows setting the MicroQRCode size for

redundancy purposes. Each version has a different number
of modules and a higher data redundancy. (Default: M2) For
further information, see Setting the data restoring capability.

Best Fit

Sets the smaller dimension (11x11) for the information to be
encoded.

Version M1 to M4

Allows specifying a dimension that ranges from 11x11 to
17x17 modules.
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This property allows setting the error correction level for the
Error level code, which allows restoring data if the code is dirty or
damaged. To each level corresponds a higher data
redundancy and a different restoration rate. (Default: M).
|O ||On|y for M1. Only error detection. |
L |15% of codewords can be restored |
|M ||25% of codewords can be restored. |
|Q ||30% of codewords can be restored |
) Sets the width of the module (in a linear bar code this is the smallest thickness;
Width ; .
Modul in a 2D code, is the smallest square).
odule
Heiaht Sets the height of the module for linear bar codes. (Not available for Datamatrix,
9 QRcode and MicroQRcode).
It allows adjusting the ratio between white and black elements when marking
Black/White |lvery small elements. In this case, the spot laser might affect the dimensional
ratio ratio. The default value is 100%. For further information, see Balancing the
black and white ratio.
Only available for 2/5 and 3/9 Codes. In two thickness codes, it is the ratio
Print ratio between the thickness of the wide element and that of the narrow one. The
higher the ratio, the bigger the symbol, which impacts on the scanner's reading
capabilities. Default: 200.
If it is set to True, enables the bar code engraving in
Advanced .
reverse. Reverse bar code engraving should only be done
Reverse True or False . .
on those materials where the laser marks white or black.
The bar code standard does not include reverse coding.
Visible only if Reverse is set to True. Immediately preceding the start character
Quiet zone and following the stop character is an area of no markings called the quiet zone.
The quiet zone helps the scanner find the leading edge of the bar code so
reading can begin.
Bytes This option allows the interpretation of the text property as a bytes stream,
Encodation |\wherever the text is Unicode only the lower bytes are used.
The Counter group enables creating a variable text that includes an incremental counter
(see Making a text string to include an incremental counter).
|Start ||The minimum value for the counter. |
|Stop ||The maximum value for the counter. |
Counter |Current ||The current value of the counter as it appears in the string. |
|Step ||Increment value (positive or negative). |
Cveles The number of times the counter will be marked before it is incremented by one
y step.
Digit | The minimum number of digits to be displayed. |
Formatters are source files that are supplied with Project Editor. These files can be used as
functions libraries. Their purpose is to make it easier for developers to create custom
applications. For example, as an integrator, you might need specific functions that these
Custom libraries provide. Formatters have a .gs extension and are stored in the folder
Formatters |---\Pata\Formatters.
|True or False ||Enab|e or Disable the use of a Custom Formatter file |
. Visible only if Custom Formatters is set to True. Use to select the Custom
Script . . .
Formatters from a list of availlable files.
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Using Arrays

Actions | Laser Window Hebp
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The array object is used to mark repetitively an object (or a group of objects) in different positions, allowing
you to customize both the layout and the elements arrangement.

Graphic objects are included in cells that you can customize to suit your needs.
The array object is especially tailored to Integrated Circuits (IC) chips marking.
By using the Array toolbar button or the Actions menu, Laser Editor allows you to create an array.

You might use the mouse to resize and move the array, or to select/deselect cells; you can use
the Properties window to set dimensions and number of cells and to define their content, as well as misalign
or change the distance between cells.

Tips:

Clicking a properties title in the Properties window and then pressing F1, opens a table with a
@ description of those properties.

For further information on mouse operations, refer to section Using the mouse to select and

manipulate objects.

The following sections describe how to work with arrays:

e Adding an array
e Setting the number of cells

e Resizing arrays or cells

e Changing the distance between cells

e Cells misalignment

e Selecting/Deselecting one or more cells

e Creating the contents of individual cells

e Array and cells properties
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Adding an array

To add an array:

1. Create a plane document to enable the insertion of the object (see Creating a document for plane
engraving).
2. Do one of the following:

&
0 On the vertical toolbar click on the ‘< Insert objects button and then, in the horizontal
I
toolbar that is displayed, click on @& Array.
o From the Laser Editor menu bar, choose Actions > Insert > Array.

3. The Array is displayed in the work area. By default, the whole array is selected and contains 9 cells.
Use the Properties window to set the array and cells parameters; use the mouse to resize or move
the array, as well as to select individual cells. See the topics list here below to get more information.

Tip:
Clicking a properties title in the Properties window and then pressing F1, opens a table with a
description of those properties.

Setting the number of cells

The Columns and Rows properties of the Array object, allow you to set the number of row and columns that
compose the array to obtain any number of cells.

To set the number of cells that compose an array:
1. Click on the array to enable the Properties window.

2. Under Array, select the boxes beside the Columns and/or Rows properties and enter the desired
number.

3. The array changes accordingly. You might need to resize both the array and the cells to fit the new
settings. (See Resizing arrays or cells).

Resizing arrays or cells

The Dimensions and Cells size properties allow you to resize the objects as needed.

Tip:
For information on other Array's general properties, select the Geometry title and press F1 to
display the relevant Help topic.

To resize the objects:
1. Click on the array to enable the Properties window.

2. To resize the array: Under Geometry > Dimensions, set the Width and Height properties as you
want. (You can also use the mouse: with the object selected, drag the handles that surround

it 1 E R 10 the desired position.)

3. To resize the cells of the array: Under Array > Cell size, set the Width and Height properties as
you want.
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Changing the distance between cells

The Pitch and Extra Pitchs properties, allow you to increase or decrease the distance between rows,
columns, individual cells and/or group of cells.

‘ @ ‘ To enable the Properties window, click on the array object..

To change the distance between rows and/or columns:
1. Under Array > Pitch, set the following properties:
0 X - Sets the distance between columns.

0 Y - Sets the distance between rows.

To change the distance between cells or groups of cells:
You can group cells and define additional distances between them, both horizontally and vertically.

1. Under Array, select the Extra Pitchs property and enter the number of instances, that is, the
number of extra-distances you want create. The properties that allow setting the extra pitches are
displayed below.

2. Set the properties values as follows (see the example below, also):
0 Group - Enter the number of cells that you want to include in the group to be moved.
o First - Enter the number of the first column you want to apply the extra pitch to.
o Pitch - Specify the size for the additional distance.
o]

Direction - Select the desired direction: Y direction will add the distance between rows, X
direction will add the distance between columns.

The picture below shows how the array looks after setting the properties as follows:
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3. Repeat step 2 for any other extra pitch you want to add.
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Cells misalignment

The Interleave properties allow you to change the alignment of rows and/or columns.

To change the alignment of cells:

1. Click the array to enable the Properties window.

2. Under Array, select the Interleave > Offset property and enter the misalignment measurement.

3. From the Direction dropdown list select the desired direction:

0 X - Sets the misalignment between rows.

0 Y - Sets the misalignment between columns.

The picture below shows how the array looks after setting the properties as follows:
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Selecting/Deselecting one or more cells
You can operate on individual cells by unlocking the array and selecting the desired cell(s).

To select/deselect individual cells:

1. Select the array and then click the pushpin-shaped handle “C at the top left. The handle changes
to @ and the cells in the array becomes unlocked allowing you to select them:

= e (e
I s

= [N (W]

ﬁ
(3]

2. To select one or more cells, do one of the following:
o0 Click one or more cells. (You can select as many cells as you want).

o0 Right-click a cell to display a menu that allows to select/deselect all cells, or to invert the
selection between selected and deselected cells.

o Click the rows or columns blue indicator to select/deselect the whole row or column.

3. When a cell is selected and enabled, its colour changes to bright yellow. (To deselect a cell, click on
it).

4. Furthermore, in the Properties window, under Array, the new Cells group is displayed that allows
you to:

0 enable/disable one or more cells
o define custom offset settings and rotation
o0 link a document to the cell (see Creating the contents of individual cells).

‘ m ‘ When a cell is disabled, its colour changes to light yellow.

5. Clickthe ® mouse handle to lock the cells and operate on the whole array.

Tip: I

@ For further information on mouse operations, please refer to Using the mouse to select and
manipulate objects:

90



CREATING GRAPHIC LAYOUTS o

Creating the contents of individual cells

You can enter any content into individual cells to compose your layout, as well as define custom offset
settings and rotation. You can create a document with graphics or strings, and then link the document to a
cell.

To create the contents of a cell:

1. Click the array and then click the pushpin-shaped handle at the top left “&=

2. Click to select the desired cell(s). The colour of the selected cell(s) changes to bright yellow. Note
that all cells are named Plain O.

3. You might set a different Plain number: In the Properties window, under Array > Cells, select
the Linked Plain property and enter a Plain ID. The Plain number of the selected cell changes
accordingly:

5| Cells
Cffset 0.0, 0.00)
X 0.00

@m.“ Piata: 0 m-m traies e

E ot shwn
L]

.
E = =

4. Double-click the cell. A new document representing the Plain, with the same ID number, opens. (By
default, it would be 0, as the selected cell).

Do | D | ey i s gl | s
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Enter any object you need, as you would do in a plain document. (See Creating a document for
plane engraving and About graphic objects).

When your layout is done, from the Laser Editor menu bar, choose File > Save to save the plain as
an .xlp file.

Return to the array.

Select the cell(s) to which you want to link the Plain you have just created. (You might select an
entire row or an entire column by clicking on the blue indicator).

In the Linked Plain property, enter the number of the Plain that you have created. (See step 3,
above).

The cells will be dynamically filled with the contents of the linked plain when sending the array to
laser engraving. (See Performing the engraving operation).

You can set custom properties for a cell using the Cells properties. The settings appear on the cell,
as illustrated below:
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Note that, as the Rotation angle for the cell has been set to 160, the small black indicator has been
moved accordingly, to indicate the rotation. (See Array and cells properties for more information).
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Array and cells properties

The Properties window supports context-sensitive Help: During layout editing, selecting a properties title (for
example, Geometry), and then pressing F1, opens the context Help for those properties.

The following properties appear when an Array object is selected in the work area.

Tip:
@ Refer to section Using Arrays for further information on how to use properties to perform specific
operations on the object.

Array Lo
group Property Description
Columns Sets the number of columns for the array.
Rows Sets the number of rows for the array.
. Width Sets the width for all cells into the array.
Cells size : . .
Height Sets the height for all cells into the array.
. Specifies the distance between columns. You can increase or decrease
Width .
Bitch the distance.
itc
Heiaht Specifies the distance between rows. You can increase or decrease the
9 distance.
Offset Sets a misalignment between rows or columns.
Specifies the direction for the misalignment:
Interleave Direction e X - Sets the misalignment between rows.
e Y - Sets the misalignment between columns.
Group Represents the number of cells to be considered for the extra pitch.
First Indicates the first column to which the extra pitch will be applied.
Pitch Sets the additional distance.
Extra Pitchs Sets the direction for the extra pitch:
N e Y direction will add the distance between rows.
Direction
e X direction will add the distance between columns.
Determines whether the counter increase is done by rows or columns
Rows/Columns L
direction
Left to Right or|Determines whether the counter increase is done by Left to Right or Right
Increment  |Right to Left to Left direction
Counter Top to Bottom or |Determines whether the counter increase is done by Top to Bottom or

Bottom to Top Bottom to Top direction

Determines whether the counter increase is done even by Disabled Cells

On Disabled Cells
or not
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This group of properties is displayed only after selecting one or more individual cells. (See
also Creating the contents of individual cells).

Sets the marking offset for the selected cell(s):

Offset e X - Sets the horizontal offset

e Y - Sets the vertical offset

Cells Enabled Enables/disables the selected cell(s)
Rotation Applies a rotation angle to the selected cell(s).

Allows linking a document with specific contents to the selected
cell(s). Double-clicking the cell will result in a document opening with the

Linked Plain same Plain ID as the selected cell. You can treat it as a document and then
link it to as many cells of the array as you want. (For detailed instructions,
see Creating the contents of individual cells).

Importing graphic objects

ACtions | Laser Window Help
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By using the Imported toolbar buttons or the Actions menu, Laser Editor allows importing two dimensional
graphics.

Supported file formats
Laser Editor allows importing and editing the following graphic formats:

e Vectorial:

o HPGL 1/2 (.PLT and .HPGL) - Vectorial formats were originally conceived plotters treating,
so they include plotter's specific features (such as, the line width), which the laser does not
consider. Please note that there is not an automatic adjustment of the spot laser as the
plotter's pen changes.

o0 AutoCad DXF - Two dimensional vectorial graphic exchange format that was originally
developed by Autodesk, and then disclosed to the public. However, it is still maintained by
Autodesk that periodically updates it.

0 AutoDesk DWG - Vectorial graphic format licensed by Autodesk. It is a file format used for
storing two and three dimensional design data and metadata. It is the native format for
several CAD packages.

Note:

For AutoCAD .DXF and .DWG graphic formats, new filter configuration options have been added
@ that allow selecting how to process the file. For further information, see Setting the Filter Options

(.DWG and .DXF fles).

For all vectorial objects, new advanced processing options have been added that allow the

automated editing of vectors. For further information, see Using Advanced Processing options.
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¢ Image files (bitmap):

0 BMP, is the standard format for bitmap graphics. It can be generated with any graphic
application, from digital cameras or scanners.

o GIF, is a format similar to BMP. It can be generated with any graphic application, from digital
cameras or scanners.

o JPG, is one of the most common compressed bitmap formats. A BMP image converted into
JPG has a much smaller (in bytes) dimension.

0 PNG, is an extensible file format for the lossless, portable, well-compressed storage of
raster images, that is, PNG files are compressed bitmaps.

o TIF, a common format for exchanging raster graphics (bitmap) images between application
programs, including those used for scanner images.

e Laser documents (.XLP) - Engraving graphic layouts generated by Laser Editor.

You can use the Properties window, the toolbars tools, or the mouse to resize, move, rotate, and transform
the imported graphic so as to fit the object to be engraved.

Tips:

For information on mouse operations, see Using the mouse to select and manipulate objects.
@ For information on how to operate on graphics, please refer to Common operations on objects.

Clicking a properties title in the Properties window and then pressing F1, opens a table with a

description of those properties.

The following sections describe how to work with imported graphics:

Raster graphics vs. Vectorial graphics
Importing a file into Laser Editor

Setting the Filter Options (.DWG and . DXF fles)
Using Advanced Processing options

Imported graphics properties

Raster graphics vs. Vectorial graphics

Laser Editor allows editing and importing two dimensional vectorial graphics and also importing and editing
bitmap graphics created with other applications.

About raster graphics

(.bmp, .gif, .jpg, .png, .tif)

Raster graphics describe images using colored dots, called Pixels, located within a grid. The image is
described by the specific position and color of every pixel in the grid, and the creation process is very similar
to that of a mosaic.

When you edit a raster graphic, the pixels are edited rather than the lines and curves. The raster graphics
change with resolution, as the data which describes the image is fixed in a grid with specific dimensions.
Editing raster graphics can change their quality. In particular, resizing may make the edges of the image
irregular since the pixels within the grid are redistributed. In addition, displaying raster graphics on an output
device with a lower resolution in relation to the image reduces the display quality.
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About vectorial graphics
(.plt, .hpgl, .dxf, .dwg)

Vectorial graphics describe the images using lines and curves, called vectors, which all include properties
related to color and position. The image is described by points through which lines pass, creating the form of
the outline. (Note that laser engraving is monochromatic.)

Raster vs. Vectorial marking
Raster

The raster engraving technique allows marking a vectorial object as if it were a raster object. The image is
split into rows and rows are marked sequentially, as the laser brushes the image across the surface in a
back-and forth slowly-advancing linear pattern that reminds one of an inkjet or similar printer.

The laser moves at a fixed speed and the level signal modules continuously according to the "darkness" of
the pixel being drawn. This technique can be performed only on materials whose response changes deeply
with the power of the investing beam; polycarbonate and PVC can behave this way with the use of proper
additives, while metal cannot. In general, raster engraving on plastic cards produces best results.

In laser engraving, a raster graphic is slower in engraving and less defined in terms of outline lines and filling.
It can be used, with appropriate conversions, for engraving digital photographs.

Vectorial

In vectorial marking, the laser follows the lines and curve of the pattern to be engraved, much like a pen-
based plotter draws by constructing line segments from a description of the outlines of a pattern. It traces all
vectors, regardless of how the object is being scaled.

In laser engraving a vectorial graphic is faster in engraving and more defined in terms of outline lines and
filling. A vectorial graphic cannot be used for engraving digital photographs.

Importing a file into Laser Editor

To import afile:

1. Create or open a document to enable the insertion of objects (see Creating graphic
layouts and Opening existing layouts).

2. Do one of the following:

&l

)

o In the horizontal toolbar, click on = Imported. (If this button is not visible, click the
Insert Objects button on the vertical toolbar).

o From the Laser Editor menu bar, choose Actions > Insert > Imported.

3. The Choose a file to import window is displayed. From the Files of type dropdown list, choose the
file you want. (See Supported file formats for more information).

4. Select the file you want to import. The image is displayed in the work area.

Note:

@ When you select the .DWG or . DXF file formats (AutoCAD files), the Filter Configuration window
will be displayed for you to select how to process the file to import. See Setting the Filter Options
(.DWG and .DXF fles).
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5. Using the Properties window, the mouse, and the toolbars, you can do the following:

0 Move or resize the object (see Common operations on objects)

o Edit bitmaps properties (see Imported graphics properties)

o Link an imported file to the layout (see Linking the imported file)

o Fill it with filler lines (only if the lines of the imported object are closed) and perform other
operations on graphics (see Common operations on objects)

o0 Use advanced processing functions to edit nodes of vectorial graphics (see Using Advanced
Processing options)

Tip:

@ For a quick-reference on using toolbars in Laser Editor, see Using toolbars tools.
Clicking a properties title in the Properties window and then pressing F1, opens a table with a
description of those properties.

Linking the imported file

The Linked property allows specifying the full path of the imported file. This way, at any document's loading,
the program looks for the original file into the specified path and, if it does not find it, uses the internal copy
that was created. If the original file has been changed, or updated, the document is also updated.

1. Select an imported object in the work area.
2. In Properties window, under Imported, set the Linked property to True.

3. The Linked file property is displayed that shows the full path of the imported file. To change the
path, use the browse button.

Setting the Filter Options (.DWG and .DXF files)

When you import a .DWGor .DXF file into the laser editor, that is, an AutoCAD file, the Filter
Options window displays for you to select how to process the file.

Imported AutoCAD files can be strings that use specific and proprietary fonts, which might not be available in
your system. Using these options you can fix this issue, as well as process the layers of the original file as
groups of editable objects.

To set the filter options:

1. Click the rl::)J Imported icon in the toolbar and then select AutoCAD DXF/DWG files as the File

Type.
2. Select the file to import and click Open. The following window is displayed:

~, Filter Configuration E| E

AULOCAD DF Files (*.D%F)
Impart strings as vectors || False
Diefauk Fonk Arial w

Process bayers as groups [V True

oK | | Cancel |
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3. Select the proper options, taking in mind that:
a. Import string as vectors

= If it is set to False (default) strings will be imported as strings. In this case, if the
original font is not available, an error or a warning could be returned. To fix this
problem, use the Default font option and specify a default font.

= Ifitis setto True, strings will be imported as pure vectorial objects, that is, they will
not be strings objects anymore.

b. Default font - It allows selecting from the dropdown list the font that must be used if the
original one is not available.

Tip:

@ If you imported the strings as strings (Import strings as vectors = False), and set a Default
font other than the original, the resulting layout might shows differences in terms of space or
objects alignment. To fix this type of problem, do the following.

= Review the import result for problems.

= Import the object again setting Import as vectors to True.

Compare the results and change the font properly, until achieving the desired result.
If necessary, import the required font in your system (see "Importing fonts" on page
79).

c. Process layers as groups - Typically, AutoCAD files are composed by more layers each
containing different information. For example, in a mechanical drawing, the notes might be
on a layer, while technical data might reside on other layers. If this option is set
to True (default), the layers will be transformed into groups of objects, which will be grouped
layer by layer. This allows managing and operating on layers, as well as adding specific
properties.

4. When finished, click OK. The object will appear on your document.

5. To edit the vectors in an automated way, see Using Advanced Processing options.

Using Advanced Processing options

The Advanced Processing options provide vectorial processing functions that allow editing vectors in an
automated way. It is used if the original document does not satisfy your marking requirements, or if it shows
graphic problems that result in marking imperfections.

You can make vectorial the imported object so as to check its polygons and then use these functions to fix
problems such as not closed or double polygons, before sending the document to mark.

These functions are available for vectorial objects (. PLT, .HPGL, .DXF, .DWG).
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Step 1 - Make the object vectorial and check nodes:
1. Select the imported object and then do one of the following:
0 From the menu bar, choose Actions > Make vectorial.

AL

0 On the vertical toolbar, click & Object operations and either click /) Make vectorial or
= Ungroup selection in the horizontal toolbar.
2. Double-click the object to display the vectors nodes, and then check if polygons are properly closed
or if there are double lines that overlap each other. (For further information on how to open, view,
and edit nodes, see To edit the nodes:).

The following shows an example of a .DXF imported file that shows these type of imperfections. On
the left you see the object as it was imported, while on the right the same object has been made
vectorial, as above described:
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At a first sight, it does not show problems. But if you open the nodes, by dragging the small grey
squares, problems will appear:

Not closed polygons ...

i i

o i e o

N

Double polygons ...

These problems will result in marking imperfections.

Tip:
@ To exit the Edit nodes operating mode press ESC.

3. Insuch a case, you can use the Advanced Processing functions to edit polygons automatically.
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Step 2 - Automatically edit vectors to correct imperfections:
1. Select the object and then do one of the following:
o From the Actions menu, select Advanced Processing.

973
0 On the vertical toolbar, click J Object operations and then !Z] Advanced Processing.

The following will be displayed:

., Filter Options [$__<|

Sork Eljl]E'_' % Close Po || i (a

Ik ] ’ Cancel

There are three options that you can use in association:
0 Sort Edges & Close Polygons - It operates on areas: it tries to locate areas that are
enclosed into polygons and then close them eliminating any double line.

o Join Open Polylines - It operates on the distance between nodes and it tries to close them
at the maximum distance. That is, it tries to join polygons that are near enough and then
close them.

o Split in Polygons - It allows dividing a vectorial object into individual polygons. This is
particularly suitable in the case of an imported object that is made of more polygons, placed
on different layers: using this option you can see how objects are grouped on each layer,
ungroup them, and then operates on polygons separately.

Example of usage

Let's take our example of imported object above to describe how the Advanced Processing options can be
used in association to fix all problems.

1. Select the object and then from the Actions menu, select Advanced Processing (or click J

Object operations on the vertical toolbar, and then !2 Advanced Processing).

2. Apply the first option Sort Edges & Close Polygons, which, by operating on areas, should remove
any double or not closed polygons.

However, the result is still not as expected as it shown in the following picture:
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3. Click C‘\\.'IUndo, or press CTRL+Z, to cancel the operation.

4. From the Actions menu, select Advanced Processing again and then apply the second
option Join Open Polylines.

5. Apply afilling: From the Filling properties dropdown list, select Single line:

Fie 3 }- M

6. It seems working, but let's check the nodes: Click <:‘\\«Undo to cancel the filling, make the object
vectorial by double-clicking and check the nodes:
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As you can see in the example above, there are still double polygons, which would result in marking
problems if you apply, for example, the Pocketing filing, which requires perfectly closed and well
prepared polygons.

7. Try it. From the Filling properties select Pocketing and then select Mark Preview from
the Actions menu. This is how the marking would result:
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8.
9.
10.
11.

12.

Press ESC to exit the Mark preview mode and then click <:QUndo to cancel the filling.
From the Actions menu, select Advanced processing.
Apply the first option again, Sort Edges & Close Polygons to remove all double lines.

Make the object vectorial by double-clicking it and check the nodes again. All nodes will now be
closed and double lines will not exist anymore.

To check the marking results, apply the fillings again and then select Mark preview from
the Actions menu. The following pictures show the results of both fillings:

Marking result with Pocketing filling

The object will now be marked as expected, showing closed and well-oriented polygons.
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Imported graphics properties

The Properties window supports context-sensitive Help: During layout editing, selecting a properties title (for
example, Geometry), and then pressing F1, opens the context Help for those properties.

Tips:

@ Refer to section Common operations on objects for further information on how to use properties
to perform specific operations on the object.
Refer to section Importing graphic objects for more information on imported objects.

Group |Property Description
Brightness It allows adjusting the brightness of a bitmap.
Contrast It allows adjusting the contrast of a bitmap.
Resolution It allows changing the resolution of the image, expressed in dots per inch.

If it is set to True, specifies the reverse engraving for the imported bitmap:

Bibtmap
Brightriess 0
_ontrast 0
Reverse Resolution a00
Image {- Reverse Tree |
‘ideo Mode Garay bones
= Geomebry
1D
Gray tones - Converts the image in dithering to gray tones. (Default)
Half tones - Converts a grayscale image to simulated halftone dots. Halftones
Video mode |varies the size of halftone dots to simulate shading.
Error diffusion - Converts a continuous tone image into a frequency modulated
halftone.
If it is set to True, allows specifying the full path of the imported file; it is the path
Linked that the program will search whenever the document is loaded. (See Linking the
Imported imported file).

Linked file Shows the full path of the linked file. You might change the path.
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Using the tiling function

Note:
The Tilable property is only available when editing vectorial objects on ring documents. (For
further information, see Creating a document for ring engraving)

The Tilable geometry property is used when marking indivisible objects on a rings separator, that is, on a
cylindrical surface.

Typically, when marking on a ring document, the laser focuses on a ring portion (sector) to mark.

In some applications the object to mark can be longer than the sector itself. For example, in jewellery you
might need to mark the manufacturer logo, or the client's name on a wedding ring. This might result in
deformations.

By applying the tiling function:
e The object is separated into its constituting polygons.

e |If a polygon its larger than the sector and it is closed (otherwise, the function won't work). it will be
"sliced" into portions whose size is equal to the ring's sectors to be marked.

This way, the object will be marked as if it were an individual sector, thus resulting in high precision marking.

The Tilable property is used in association with the Sector size and Sector gap Advanced properties of the
ring document, how it is described in the example in the following.

Example of tiling usage

The following example describes how the software operates when using the tiling function and how the
ring's Sector size and Sector gap properties are to be set, accordingly to your specific needs.

1. Open a Ring document by selecting File > New > “* Ring document.

. |
2. Let's suppose that we must import the logo of a jeweller. So, click Ql.and import the file.

3. As the Textstring property, type the date and then set the desired Font, Style,
and Filling properties. Then, set to True the Tilable property under Geometry:

Geometry
f’: | 1] \
Errabibe [=] wue
Locked [} False
Eeep Aspect | | False
ot oasr [ Fake
Pocketin 0,00 mm
Dhrisgin -I:I o
= Position {0 . 0S)
] 0.54 mm
¥ 0,065 mm
= [mensions 19.89 x 1,80
Wicdth 19.8% mm
- T - Helght 1,80 mm
= Angle 0.00*
"""""""""" e = Ca a.u:t:!.—' i
® 0,64 %
- = \_ o i ./J
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4. Deselect the string and set the Sector Size and Sector Gap properties for the document in order to
define the sectors properties:

Gaeonsetry

+ Work Area 31.42 x 2.00

- Margins (000, OuO0)
X 0,00 mm
¥ 0,00 v

= Grid ¥ Thue
Skep N.00 rmm

Snap bo grid Falks
C
= Aadwanced
Sector Size 0,00 mm

Sector Gap 0,00 mm
Arvgle 0.00%
Reset anmi... Falgs
Use ringr... [ False
= Laser
Passages 1 passage
= Passage 1

[ERN— A

5. Set the properties according to your needs, keeping in mind that:

a. The Sector Size property defines the width of the sector, that is, the portion to be engraved
within a single movement of the rotating axis. The object will be divided into sectors whose
size is equal to the sector's maximum size, which it is based on the laser's depth of focus.

The 0 value (default) provides a high level of quality. A single movement will be made for
each polygon and the polygon will be centered in its belonging sector.

With tilable objects, you might set a value smaller than 0 for high precision needs. Note that
smaller value results in longer marking time.

b. The Sector Gap property allows to further fine tune the tiling operation.

If it is set to O (default) only one cut will be used for both the left and right objects.

If the value is lower than 0, two cuts will be used, to either overlap the polygons (left and
right borders), or to leave a space between them.

Note that this setting is based on the laser's depth of focus, as well as on the mechanical
precision of the rotor.

6. Save your layout.
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Understanding objects colour in the work area

The objects in the work area can take on different colours, depending on their status or characteristics, as
illustrated in the picture:

Laser Lditor T T ?

lé,aser Editor

Laser Editor

Colour Meaning

The graphic object is NOT correctly placed within the graphic area. A red colored object will NOT
be engraved.

The graphic object is correctly placed within the graphic area and is enabled for engraving. Its
engraving parameters are NOT the standard ones of the document; special laser engraving

Blue parameters have been set which are only relative to this object (seeCustom Laser parameters for
Objects). There can be various blue colored objects within the graphic area; their laser
parameters may differ from each other.

The graphic object is correctly placed within the graphic area but is NOT enabled for engraving
and will NOT be engraved. (The Enable property in the property browser is set to False).

The object is correctly placed within the graphic area and is enabled for engraving. Its engraving
parameters are the standard ones of the document.

Red

Grey

Black
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Using global variables

Attention:
In order to view and manage global variables, you must be connected to the laser device. For
| further information, see Connecting to the laser device.
— This function is also accessible at the Laser Engine interface level. For further information,
please see Laser Engine User Interface.

Purpose of the functionality

Global variables are strings or counters that are stored in a small database at the device level. You can then
use special character sequences to access a global string or counter variable and share its content between
more objects or documents. (See also Using special character sequences).

For example, you can use the same counter in as many strings as you need, or refer a global string variable
in any number of document(s).

To summarize, this function offers the following main advantages:

e A counter is not only strictly associated to a string, anymore. You can create a counter that is
common to more strings and that is managed at the machine level.

e You do not longer need to create a specific program for each document to be engraved in order to
increment a counter.

e A centralized database, managed by Laser Engine, is provided. You can use it to store, view, or edit
global variables either remotely, via the Laser Editor user interface, or through a project, in order to
update or edit them at runtime.

e Variable contents (for example the current number for a counter) are not yet strictly connected to a
specific document file. As an example, counters are automatically updated after each use. Users do
not need to take care of saving them anymore: You can turn off the machine, or edit the document
and, the next time the machine is turned on, the counter will be incremented accordingly to the value
that was previously reached.

For further information on global variables management, see:
e Adding, viewing, or editing a global variable
e Using special character sequences to associate global variables to a string

Adding, viewing, or editing a global variable

Follow this procedure to add, view, or edit global variables. You will then be able to associate them to objects
by using special character sequences.

1. Be sure that you are connected to the laser device (see Connecting to the laser device).

2. Do one of the following:

0 From the Laser Editor menu bar, choose Laser > Edit device global variables.

0 On the Laser Editor toolbar, cIickm Edit device global variables.

3. The Device variables is displayed for you to add or manage variables remotely.
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To add a global variable:
1. Inthe Device variables window, do the following:
0 Click on Add new counter to add a counter variable type.
o Click on Add new string to add a string variable type.

The new variable will be added in the table using the default parameters.

2. To edit the parameters, select the variable and then double-click the field you want to change. Use
the following table as a reference:
Table 3 Global Variables Parameters
Field Description
Counters

The unique identifier for the counter. This is the name that is to be used into the special

Variable
character sequence to refer the counter.

The current value of the counter. This value will be displayed when the global variable is

Value referenced into a string object through the appropriate special character sequence.
Start The minimum value for the counter.

Stop The maximum value for the counter.

Step The increment value (positive or negative).

Cycles The number of times the counter will be marked before it is incremented by one step.

It allows keeping track of the number of markings that have been executed within the required
Cycles Cycles number. This parameter is reset to 0 when the humber of engravings has been reached
Count and the Counter has been incremented.

(It only applies if the Cycles parameter has been set to a value other than 1).

Digits The minimum number of digits to be displayed.

The numeral system that the Counter will use to represents the numbers. The following values
are allowed:

o] 2 - The marked number will be converted to binary form. Binary uses only 2
digits (0 and 1) and is also called base-2. The value 10 in base 2 will be marked 1010.
o] 8 - The marked number will be converted to octal form. Octal uses 8 digits
which are 0,1,2,3,4,5,6,7 and is also called base-8. The value 10 in base 8 will be
Base marked 012.

o] 10 - The number will be marked in decimal form. Decimal has 10 digits which
are 0,1,2,3,4,5,6,7,8,9 and is also called base-10. The value 10 in base 10 will be
marked 10.

o] 16 - The number will be marked in hexadecimal form. Hexadecimal is made up

of 2 parts which are hex(6) and decimal(10) which are 0,1,2,3,4,5,6,7,8,9,A,B,C,D,E,F.
It is also called base-16. The value 10 in base 16 will be marked OA.

Strings

Variable The unique identifier for the string. This is the name that is to be used into the special character
sequence to refer the string.

Value The content of the variable, that is, the text string.

The figure below shows an example, where one counter and two strings variables have been added:

Figure Device Variables dialog
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+ Global variables

Counters e

Wariabde Wi Start Stop Step Cycles Cycle Coumt | Dipits B | | — e |
y
1 countesl 3 1 a5 1 1 0 3 10
Cancel
Avdd Mes Couritar
Rudd e String
StrgE
Dedete Courder(s)
iaruabis walys e —
1 stringl Marking Castst & SiEimgls) ]
2 siring2 Laser Editor

3. When you are finished, click Apply and then OK to close the dialog and return to Laser Editor.

The global variable will be saved to the device and stored into the Laser Engine-managed database. You will
then be able to retrieve it from Laser Editor, in order to check or edit it.

To view, edit, or delete an existing global variable:

You can use Laser Editor to display a global variable that has been saved to the device, so as to be able to
check or edit the values.

1. Be sure that you are connected to the laser device (see Connecting to the laser device).

2. Press themEdit device global variables button on the toolbar to make the Device
variables dialog appearing that lists the variables that are currently stored on the device.

3. Do one of the following:

o To edit the parameters, select the variable and then double-click the field you want to
change. Use Table Global Variables Parameters as a reference.

o0 To delete a global variable from the Laser Engine database, select the variable and then
click on Delete counter(s) or Delete string(s), depending on which variable type you are
deleting. Click Yes to confirm your choice.

4. When you are finished, click Apply and then OK to close the dialog and return to Laser Editor.
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Using special character sequences to associate global variables to a

string

Follow this procedure to associate a global variable (string or counter) to one or more strings. You can
associate the same variable to strings that belong to different documents. (See also Adding, viewing, or
editing a global variable).

To associate a global variable to a string:
1. Add a string to the document and then select it (see Adding a Text string).

2.

(0]

In the Properties window, under String, enter in the Text box the desired special character
sequence, depending on which global variable you are using. It can be a string, a counter, or both
(see the example here below):

%v[stringname] or %V[stringname] - Where stringname is the name that you have assigned
to the global variable string when you created it (that is, the Variable field of the Device
variables dialog). V forces the uppercase.

%v[countername] - Where countername is the identifier that you have assigned to the global
variable counter when you created it (that is, the Variable field of the Device
variables dialog).

Note that the variablename value is case sensitive, so be sure that you type it exactly as you

did in the Device variables dialog.

3. Press Enter. The string changes to the specified format. When the string is sent to marking, the

Example

counter increments accordingly to the parameters that were specified when creating the variable.

In the example shown below, we have associated the same counter with two different strings that are located
into different documents. After sending to marking the two documents, at the laser device level the global
counter has incremented.
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In the following figure, a string object has been associated with global variables stringl (value:
Marking) and counterl (see figure Device Variables dialog).

| Eropertes &
. sl ; 2 =1 [ropary [k
H = String
'M k L O 0 3 Teut h»{mtr\admnnﬂ!]
Marking ——
: ) Sty FPaglar

In the following figure, a second string object, which is located in a different document, has been
associated with global variable string2 (value: Laser Editor) and to the same global
variable counterl.
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e After sending the two documents to marking, the global counter has incremented, as you can see in
the Device Variables dialog box here below:

Counters I ok ]
Cancel

— [oste cowenrs)

_ Varaahis walue |

| - —

2 shring2 Laser Editor
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Common operations on objects

This section describes all the operations that you can execute on graphic objects either by using the mouse,
or the Properties window, or the toolbars buttons.

Topic More...

Using the document's grid Click here
Enabling/disabling objects Click here
Using the mouse to manipulate objects Click here
Copying, pasting, or removing objects Click here
Aligning, flipping, or spacing objects Click here
Grouping, merging, or joining objects Click here
Editing objects vectors Click here
Zooming objects Click here
Specifying the filling properties Click here
Setting the point of origin of an object Click here
Optimizing the objects engraving order Click here
Calculating the marking time Click here
Using the Mark preview capability Click here
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Using the document's grid

The document's grid is a series of traced lines which intersect. They can be used to precisely align and
position objects in the drawing window.

The distance between lines in the grid can be set by specifying the spacing in the document property
browser. (For further information on how to create documents, see About documents).

To customize the grid:

1. Deselect any object in the work area to display the Properties window for the document. By default,
under Geometry, the Grid property is set to True, meaning that the grid is enabled.

2. To set the exact distance between lines, enter the desired value as the Step. By default, this value is
set to 10,00. Enter a lower value to align and position objects with greater precision.

3. To snap to grid objects, set the Snap to grid property's value to True. This way, objects will be
moved and aligned to the closest grid line.

Enabling/disabling objects

In order to be marked, an object must be enabled in the layout. By default, each object that you add to a
document is enabled.

To disable an object:
1. Select the object in the graphic area to display its properties.
2. Inthe Properties window, under Geometry, set the Enable value to False.

3. The object is still displayed in the graphic area, but its color changes to gray to indicate that it is
disabled and it will not be marked.

Using the mouse to select and manipulate objects

v,
""\\J

You can select and operate on objects by using the mouse.

Besides selecting objects, the mouse allows for quick, rough sizing and positioning.

Tip:

@ For extremely precise resizing, positioning, or skewing, use the
objects Geometry properties in the Property browser. (See Geometry properties for
Objects).

What you can do with the mouse:
e Selecting object(s)
e Moving, resizing, or locking objects
e Skewing and rotating objects

e Editing nodes
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Selecting object(s)
To select a single object:

1. Click to select an object. When the object is selected, it appears as follows:

The ® symbol represents the center of the selection and corresponds to the origin that has been
set for the object (see Setting the origin of an object). Note that the Property brsowser lists the
properties for the selected objects.

2. You can use the handles that appear around the object to move or resize the object. (See below).
3. To deselect an object, click on a blank area of the document.

To select multiple objects:
Do one of the following:
e Drag with the mouse to select multiple objects.
e Hold down CTRL while clicking on the desired objects.

e You can use the handles that appear around the selected objects as if it were a single object. (See
below).

Moving, resizing, or locking objects

When you have selected an object, you can use the mouse to change its position in the document, as well
as to resize it. You can also lock it so as to prevent any change.

To move an object:
1. Select the object.

2. When the mouse pointer changes to a cross , left-click and move the object to the desired
position in the document. (Note that the Geometry properties of the object are affected).

To resize an object:

1. Select the object.

2. Position the pointer over a handle until the pointer changes to the same shape as the handle, then
left-click and drag to resize the object.

3. Use the following as a reference:

Object Mouse
: You can
handle pointer
e Va Drag to resize the object.

I Drag down to change the height of the object.

e +— Drag left or right to change the width of the object.
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To lock/unlock an object:
1. Select the object.

2. Click the “™ handle. The moving and resizing handles disappear and the pushpin changes to the ©
shape. This prevents the object from being changed.

3. To unlock the object, click the © handle.
Skewing and rotating objects
You can double-click an object so as to enable the skewing and rotating handles.

To rotate an object:

1. Double-click the object(s). Note that the handles look as follows:

= -
g o
b — r—\- =
i > ‘\""@ ( |
w
=

2. Position the pointer over the < handle until the pointer changes to a cross, then left-click and drag
up or down the handle to rotate the object.

To skew an object:
1. Position the pointer over a handle until the pointer changes to the same shape as the handle, then

drag to skew the object.
2. Use the following as a reference:

Object handle Mouse pointer You can

= +— Drag left-right to skew the object horizontally.

i I Drag up-down to skew the object vertically.

Editing nodes
You can use the mouse to edit the nodes of a vectorial object.

To edit nodes:
1. Double-click a vectorial object. The object's outline becomes green-colored and

w B sad 1+ I

3 |
the @ 8B @® 88 Edit nodes toolbar appears.

2. Position the pointer over a polyline until the pointer changes to a cross, then click to display the
nodes.

Please refer to section Editing objects vectors for further information.
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Copying, pasting, cutting, or removing objects

LA B ) S (N (1) Q2019 s

You can use either the standard toolbar buttons, the Edit menu, or the shortcut keys to copy, paste, or
remove objects from the graphic area.

Tip:
@ Drag with the mouse to select multiple objects if you want to copy, paste, or remove them in a
single operation.

To copy and paste an object:
1. Select the desired object(s) in the graphic area. Do one of the following:

o From the standard toolbar, click the I::| Copy button and then the dj Paste button.
o From the Laser Editor menu bar, choose Edit > Copy and then Edit > Paste.
0 Press Ctrl+C and then Ctrl+V.

2. The copy is pasted on top of the original object. Drag to move it.

To cut an object:
1. Select the desired object(s) in the graphic area. Do one of the following:

o From the standard toolbar, click the % Cut button.
o From the Laser Editor menu bar, choose Edit > Cut.
0 Press Ctrl+X.

2. You can then paste the object.

To remove an object:

1. Select the desired object(s) in the graphic area. Do one of the following:
Y
1. From the standard toolbar, click the =/ Remove button.

2. From the Laser Editor menu bar, choose Actions > Remove object(s).
2. The object is removed from the document.
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Aligning, flipping, or spacing objects

You can use the Adjust objects toolbar or the Actions menu to quickly align, flip, space, and dimension
graphic objects. Most of these functions are only enabled if more objects are selected in the graphic area. In
particular, the spacing tools are only enabled if at least three objects are selected.

To adjust graphic objects:

e On the vertical toolbar, click B o display the Adjust objects horizontal toolbar. (All commands are
also available from the Actions menu).

e Use the following table as a reference:

Button

= Align left

J = Align top
-

= Align right

Wi Align bottom

o

“= Align center X

U= Align center Y

i,

L Flip horizontally

" Flip vertically

e &
J=l Space
horizontally
=]

‘<= Space vertically
<% Make same size
-+ Make same width

<% Make
same height
*Jr]

Restore
transformations

Action

Select at least two objects, then click this button to align all objects to the leftmost
one.

Select at least two objects, then click this button to align all objects to the top-level
one.

Select at least two objects, then click this button to align all objects to the rightmost
one.

Select at least two objects, then click this button to align all objects to the lowest
one.

Select at least two objects, then click this button to align all objects along the X axis.

Select at least two objects, then click this button to align all objects along the Y axis.

Select one or more objects, then click this button to flip the object(s) horizontally. If
you select more objects, they will be flipped both individually and in relation to each
other.

Select one or more objects, then click this button to flip the object(s) vertically. If you
select more objects, they will be flipped both individually and in relation to each
other.

Select at least three objects, then click this button to space objects the same
distance apart horizontally.

Select at least three objects, then click this button to space objects the same
distance apart vertically.

Select at least two objects, then click this button to make them the same size.

Select at least two objects, than click this button to make them same width.

Select at least two objects, than click this button to make them same height.

Reverses any change you have made, that is, restores the selected object(s) to its
original size or orientation.
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Grouping, merging, or joining objects

You can use the Objects operations toolbar or the Actions menu to assemble objects in the graphic area
so as to form a single object, as well as to edit object nodes, either manually or using the advanced
processing functions (see Editing objects vectors).

The assembling functions are only enabled if more than one object is selected in the graphic area.
These tools can be used on all objects. However it is not possible to merge or intersect bitmap pictures.

In particular:

1. The Group and Merge tools allow assembling objects, either if they overlap or not, into a single
object so they can be moved or transformed as a group. Single objects keep their properties.
The Ungroup tool can be used to reverse the grouped object back to individual objects.

2. The Union, Intersection, Difference, and Exclusion tools allow assembling vectorial objects so
that their constituting polygons are merged into a new vectorial object. You can edit vectors.
The Undo button can be used to reverse the operation. The filling properties of the resulting object is
taken from the first selected one. If this filling can't be applied to all the objects in the selection, it is
taken from the next one. If none of these fillings is possible, it will be the first one from the common
filling list. Other options are disabled by the user interface.

To use the grouping tools:
e Select more objects in the graphic area.
e On the vertical toolbar, click 1o display the Objects operations horizontal toolbar.

e Select the desired toolbar button. (All commands are also available from the Actions menu). The
following table shows examples of how tools are used:

Grouping tool Result

In this example, we have two overlapping objects. The black
star is the first selected object.
We drag the mouse to select both objects.

& 4 Group selection

As a result, the two stars are assembled in a single object so
that they can be moved or transformed as a group. The
single objects keep their individual properties, as well as their
custom laser and filling properties.

The outline of the overlapping area will be marked twice.

Use the = Ungroup selection button to disassemble the
grouped object into individual objects so each can be moved
or changed individually.
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- Merge selection

As a result, the two stars are assembled in a single object so
that they can be moved or transformed as a group. The
single objects keep their individual properties, with the
exception of the laser and filling properties.

This button can be disabled if the selection contains a raster
object, an array or if the fillings of the objects have no
common acceptable values.The merged object takes the
filing and outline attributes according to these rules in this
order:

o] The filling and the outline of the first selected
object (the black star) if all the selected objects allow
such parameters.

o] The filling and the outline of the first object in
the list whose parameters are in the intersection
parameter list of all objects.

o] If none of the filling or the outline already set
for the objects are in the intersection parameter list
and this list is not empty, the first filling in the list is
applied.

Vectorial data that compose the objects are merged into a
single object. In this case, the common area will not be
considered when engraving.

Use the o Ungroup selection button to disassemble the
grouped object into individual objects so each can be moved
or changed individually.

L Union

As a result, the two vectorial objects are assembled into a
single object, that is, their constituting polygons are merged
into the new vectorial object. Individual objects loose their
custom properties.

The new object is vectorial: double-click it to display the
nodes and the Edit nodes toolbar that allows editing the
vectors (see Starting nodes editing for further information).

To disassemble the group, you must either use the Q
Undo Union toolbar button or the Undo/Redo
command list.

As a result, the objects are assembled into a new single
vectorial object whose vectors are different from those that
compose the original objects.

Note that only the area that is common to the overlapping
objects will be considered for the engraving.

The new object is vectorial: double-click it to display the
nodes and the Edit nodes toolbar that allows editing the
vectors (see Starting nodes editing for further information).

To disassemble the group, you must either use the Q
Undo Union toolbar button or the Undo/Redo
command list.

Merge

Intersection
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P
. 1

.+’ Difference

As a result, the objects are assembled into a new single
vectorial object whose vectors are different from those that
compose the original objects.

Note that only the outline of the first selected object, minus
the area that was shared with the second object, will be

marked.
The new object is vectorial: double-click it to display the
nodes and the Edit nodes toolbar that allows editing the Q

vectors (see Starting nodes editing for further information).

Difference
To disassemble the group, you must either use the CQ Undo
Union toolbar button or the Undo/Redo command list

D s
Exclusion

As a result, the objects are assembled into a new single
vectorial object, that is, their constituting polygons have been
merged into the new vectorial object.

Note that the common area has been removed. The outlines

AWA
, \
of the two objects will be marked, minus the common area.

From the engraving point of view, the result is the same as \

the Merge tool, but this object is vectorial: double-click it to

display the nodes and the Edit nodes toolbar that allows
editing the vectors (see Starting nodes editing for further
information).

Exclusion

To disassemble the group, you must either use the CQ Undo
Union toolbar button or the Undo/Redo command list.

Editing objects vectors

Q@ |ICCe

In vectorial graphics the image is described by points through which lines pass, creating the form of the
outline.

Besides resizing a vectorial shape using the handles (see Using the mouse to select and manipulate
objects), you can enter the node editing mode and move control points or nodes around so as to make
changes to the shapes. (See About nodes and control points).

Laser Editor allows adding simple vectorial objects to your layout (see Working with simple vectorial objects),
and provides the Make vectorial function for you to make any string or code a pure vectorial object. This
way, you can edit their shape by manipulating control points and nodes, either using the mouse or the Edit
Nodestoolbar.

In laser engraving a vectorial graphic is faster in engraving and more defined in terms of outline lines and
filling. A vectorial graphic cannot be used for engraving digital photographs.

See the sections that follow:

1. About nodes and control points

2. Making an object vectorial

3. Starting nodes editing
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Note:
If you are working with elaborate objects (for example, imported drawings), consider using

@ the Advanced Processing function (J;—| button), also available from the Actions menu,
which provides an automated way to edit vectors. See Using Advanced Processing options.

About nodes and control points

When you double-click a vectorial object, nodes appear, as small boxes connected by green lines. You can
then drag the node, or edit the type of node using the Edit Nodes toolbar: for example, you can make a
node symmetric or asymmetric (see Starting nodes editing). When you do this, a line with two small circles at
the ends will appear over the node. These are called control points.

The figure below shows an example:

Asymmetric control point

ye
Node

f g :
_ | : .

| =,

| _—7 ™~
Symmetric control ' | Node

points

The type of node determines the behavior of polylines before and after the node.

Note that the control point defines two points through which the polyline passes. The position of the control
points in relation to the node defines which type of node you are working with (symmetric, asymmetric, or
angular). You can drag the small circles to change the shape.

Making an object vectorial

This function allows making vectorial a string or a code, so that you can enter the editing nodes mode and
change or deform their shape as you need. Note that, when a string is made vectorial, it looses its specific
string's properties to become a pure vectorial object.

To make an object vectorial:

Select the object you want to make vectorial. (You can also operate on grouped objects.)

Do one of the following:
o From the Laser Editor menu bar, choose Actions > Make vectorial.

u'.

o On the vertical toolbar, click &/ and then click W Make vectorial in the horizontal toolbar.

-

e To enable the edit nodes function, click the > . Edit nodes button (or double-click the vectorial
object). This will result in the Edit nodes horizontal toolbar being displayed and in the color of the
lines changing to green.

e Click the object to display a small square vertex handle at each vertex of the shape's boundary.
These are the nodes that you can use to edit the shape:

o Sad 1 | i i
b & 90 o9 a0

cumentl®
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Starting nodes editing

To edit vector shapes, you must go into node editing mode. This is done in two ways:
1. by double-clicking a vectorial object
2. by selecting the vectorial object and then clicking the . Edit nodes button

You can use the mouse to drag the nodes or you can use the Edit nodes toolbar, as it is described below.
For further information on how to make a string or a code vectorial, see section Making an object vectorial.

To edit the nodes:

1. Click a node(s) to select it F‘E

Select multiple nodes by holding down the Ctrl key while clicking the nodes you want to select.

@ If you select multiple nodes, you can move them simultaneously.

2. The following table provides several examples using the Edit nodes toolbar:

Action Result

Click b, | Angular nodes to create an angular node so that you can
manage separately the two control points.

Click ™ Asymmetric nodes to make a node that allows you to
manage an individual control point. To change the shape, drag the
control point. [

Click ®a% Symmetric nodes to make a node that allows you to move
simultaneously and symmetrically the two control points. To change the
shape, move a control point.
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: . i :
Select multiple nodes and click 5= Join nodes to manage them as a
single node. Click away from the shape to return to the original situation.

I,
1o
Click ﬂLD Break path to take the selected node and break it in two at that
point. Where one node was, there are now two unconnected nodes. The
nodes can now be moved independently of one another.
[ = \
Select two nodes and click {ILD Delete path to delete the polyline
between them.
Use the Join segment button to draw a polyline connecting two
separated nodes.
= J

3. To add a node to a segment, point to the border of the segment until the pointer changes to a cross
and then double-click-it:

i

4. Toremove a node, click the node and press the Delete key.

)
5. Click on the = Insert objects button to close the Edit nodes operating mode.
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Zooming
Wiew | Actions La
@

; 1@ Ou
Q QAQ@Q B .
Q) Page

E]
;:I @ wWindow

By changing the zoom, it is possible to display the whole graphic area on the screen or a greatly enlarged
detail of a particular part. The maximum zoom depends on the screen resolution and the dimensions of the
graphic area.

To zoom objects, you can use the Zoom dynamic toolbar or the View menu of Laser Editor.

To zoom or reduce objects in the graphic area:

1. On the vertical toolbar, click the Q Zoom button. The horizontal zoom toolbar is displayed.
2. Use the toolbar buttons to change the zoom as required:

1. To gradually zoom the work area, use the @ Zoom in button as many times as you want.

Use the a Zoom out button to gradually reduce the zoom.

2. To zoom a certain element, select the element and then click the Selection button.
This button is unavailable if no object is selected in the graphic area.

3. Torevert to the standard view, click @\ Page.
4. To zoom a specific area in the drawing, click the Window button and then trace a

rectangular window around the perimeter. Laser Editor sets the zoom level so that the
specific rectangle fills the window.
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Specifying the filling patterns
You can specify different filling patterns for objects, that is, filling the object with filler lines. To this purpose,
the Filling properties in the objects Properties window are used. (See Filling properties for Objects).

The figure below shows some examples:

Filling patterns

Strings and ve ctorial objects Single line
Angla Singe ine
U deckend | L0l
Duthe
Cuthine first

Dot

Notes:
B The Filling properties do not apply to Arrays or Imported Raster images.

To set the filling properties:

1. Select the object in the graphic area. The properties for the object are displayed in
the Properties window.

2. Select from the Filling property dropdown list the desired pattern. (By default, this value is set
to None, meaning that no filling is set for the object).

3. More properties are displayed below that allow customizing the filling pattern. Refer to section Filling
properties for Objects for a complete description of each property.
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Setting the origin of an object

The origin is a point that defines the position of the object into the engraving area. This origin relates to the
point of origin of the document's engraving area (see Geometry properties - Document

plane, Origin property).

@

The origin is represented by the cross symbol . By default, this symbol is placed in the center of the
object.

Laser Editor allows changing this property for any object to better fit your special engraving requirements.

To set the origin of an object:
1. Select the object in the work area for which you want to set a point of origin other than Center.
2. Inthe Properties window, under Geometry, select the desired value from the Origin dropdown list.

3. Note that the cross symbol moves accordingly. The following example shows an object whose origin
has been set to Center Top in a document whose point of origin is set to Center:

Origin ofthe ohject

(Center Top)
=3
& iy Cantes bop
o~ T - Position (.00, 10.00)
rd . % .00

N,
L 10,00

( \

ll'. \
\ -
! / Origin of the

M P engraving area: Center
 u . (document's origin)

4. You can specify the object's position by setting the X and Y coordinates. (Refer to Geometry
properties for Objects for a description of each property).
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Optimizing the objects marking order

Laser Editor has a function that sets automatically the marking order of the objects that compose your layout
for optimal performance.

In other words, the system orders the objects to be engraved so as to minimize the path of the spot laser
between objects, resulting in a shorter marking time.

To optimize the objects engraving order:

1. When your layout is composed and ready for engraving (see Creating graphic layouts), do one of the
following.

o From the Laser Editor menu bar, choose Actions > Marking order.

»
0 On the vertical toolbar, click '@ Adjust buttons and then click = Marking order in the
horizontal toolbar.

2. The Optimizing marker order window is displayed, showing the operation progress.

3. When finished, note that the objects order in the Objects engraving order pane, has changed. See
picture below:

[
o ﬂiﬂuing qb Q %J

W = —Marking order]|
[“. Lighter I
Cpitieriziveg maarking ordisr
nm

fecnae cmesl | |

7] | o

"ii.'n-del
! -
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Calculating the marking time

Laser Editor allows you to calculate the marking time of your graphic layout, that is, how long the engraving
operation will take.

The marking time is determined by the level of detail that you add to the objects that compose the layout. If
you can't exceed a specific marking time, consider removing some details.

Attention:

Keep in mind that this is an approximate value that is just intended to help you in calculating
T the time. The actual marking time depends also on the specific device you are using, as well
| o) as on its settings.

To view the final results of your marking, besides calculating the marking time, see Marking

preview.

To calculate the marking time:

1. Create your engraving layout (see Creating graphic layouts).

2. There are two possible scenarios:

o If the marking time for the layout is less then 30 seconds, the Marking time button on the
toolbar shows the expected time automatically. For example:

e D0:14 |

I:m.n'-u"tl‘l:
R '

Marking time: 00[m) 14[s) OL3[me]{
(2% mark ngs/h |

o If the marking time for the layout exceeds 30 seconds, in order to calculate the estimated

time, you must click the = 90200 b ton.

Marking preview

The Mark preview function allows you to check the final result of the marking process of your layouts directly
in Laser Editor.

When selecting this option, the Mark preview window shows both the lines that the laser will actually mark,
according to the filling you specified, and the marking time. This way, you can precisely verify the time that
the process will take and the result that you will obtain, such as, for example, if lines are placed equidistantly
apart.

The drag and drop function allows you to move layout's objects around the work area.

Note:

An object: with functionality for mark preview is available at scripting level also. Programmers
m can create their own user interface including a preview of the document to be engraved. For

further information, see the Project Editor online documentation, chapter "Language

Reference".
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To mark a preview:

e Create your layout. (See Creating graphic layouts).

The following shows an example of string object:

Ryt E 7 ;

Note that the Cross lines Filling property is applied.
e Do one of the following:
0 From the File menu, select Mark preview.

o From the Laser Editor standard toolbar, click the "'CE* Mark Preview button that is made
available after opening or creating a document.

The following window is displayed:

%
Laser editor!
[ orgamaarn |

The Mark preview windows shows exactly how the lines will be marked.

o Use the zooming bar the right side to further check the results, and the drag and drop function to
move items.

e If needed, edit your layout so as to achieve the desired result.

129



LASER EDITOR

5- PERFORMING THE ENGRAVING OPERATION

This chapter is divided into the following sections:

Topic
Setting custom laser parameters

e Using more engraving runs
e Using the wobble function to engrave with thicker lines

Displaying the trace limits
Simulating the marking operation
Connecting to the laser device
Sending a layout for marking

1. Auto Mode vs. Manual Mode

More

Click here

Click here
Click here
Click here

Click here
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Setting custom laser parameters

The engraving parameters must be set before engraving the graphic layout. Correct engraving parameters
are essential to ensure engraving quality. When setting laser parameters you should consider the laser
source you are using, the material to mark, and the required process.

Engraving parameters can be the same for all graphic objects: by default, each graphic object uses the laser
parameters properties of the document. However, you can set different laser parameters for each object; this
will result in the object's colour changing to blue.

To set laser properties for all objects:

1. Create or open a document (see About documents). Be sure that no object is selected in the work
area.

2. In the Properties window, under Geometry, set the Laser properties as required. Please refer to
section Laser properties for documents for information on how to set the parameters.

To set laser properties for individual objects:
1. Select the object(s) in the document. (See About graphic objects).

2. Inthe Properties window, set to True the Custom Laser property.

3. Set the properties that appear as required. Please refer to section Custom Laser parameters for
Objects for information on how to set the parameters.

Note that, after editing, the object's colour changes to blue.

For further information, see:

e Using more engraving runs

e Using the Wobble function to engrave with thicker lines

Using more engraving runs

The Laser properties allow you to set the number of runs of the laser light on the object to engrave. You
might set up to 3 passages, each with different laser parameters.

This option may be particularly useful to make several light engraving runs to clean the workpiece after a
more incisive engraving process.

Warning:

Be sure to select the best parameters according to the material used and the required
A processing type. To carry out a good cleaning run, it is important that the speed is the same as

an engraving run.

To set more passages:

1. Click a blank area on a document (to set the parameters for all objects), or select an individual object
(see To set laser properties for individual objects:).

2. In the Properties window, under Laser (or Custom Laser for an object), select the number
of Passages, that is, the number of runs of the laser light (1 to 3). The parameters for each passage
will be displayed allowing you to set different parameters.

3. Set the other parameters as required. Please refer to section Custom Laser parameters for
Objects for information on how to set the parameters.
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Using the Wobble function to engrave with thicker lines

Wobble is a function integrated in Laser Editor that allows engraving the single lines of vectorial graphics,
either True Type characters or imported figures, with thicker lines.

Normally, the line thickness corresponds to the dimension of the laser spot. If you need to increase this
thickness, you can use the wobble function.

The two figures below represent the functioning principle of the wobble:

The figure on the left shows the result of a vector engraving with the wobble disabled, while the figure on the
right shows the same vector but with the wobble enabled:

The conversion of the vector into a dense spiral provides greater thickness of the engraved line.

To enable the wobble function:

Attention:
[] The wobble function configuration parameters must be tested and checked in order
(1= to obtain the desired effect. Engraving times with the Wobble function are longer,
only use the Wobble function when absolutely necessary.

You can enable the wobble function either at a document or at object level. To do so, you can use
the Laser (or Custom Laser) > Wobble property.

1. To enable the wobble function, do one of the following:

o Create or open a document (see About documents), then, in the Properties window,
under Laser, set to True the Wobble property. This will be the default setting for all objects
that you add to the document.

0 Select the object (see About graphic objects), then, in the Properties window, set
to True the Custom Laser property and then the Wobble property.

Specify a value for the Radius property, that is, the radius of the spiral curve to be used.
Specify a value for the Speed property, that is, the frequency of spiral repetition.

Use the Simulator tool to verify the result of the Wobble function: from the Laser Editor menu bar,
choose Laser > Simulator:
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Note that the single line character has a much thicker outline. The same result would be obtained
with real engraving.
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Displaying the limits
This function refers to displaying the margins of the drawing on the work plain. Margins are displayed using a
red laser pointer.

Limits function displays the bounding box of the object(s) that will be engraved: this result is obtained by
driving head scanners to move along the box path at a fast speed.

In order to use this function you must be connected to the device and the Manual Mode must be activated. In
Auto Mode this function is not available (see Auto mode vs. Manual mode).

Note:
For further information on the laser pointing parameters that are used to display engraving limits,

see Setting the aiming parameters.

m These functions are also accessible at the Laser Engine interface level through the £l start
ol

limits and | Limits previous/next sector menu buttons.
For further information, see Laser Engine User Interface.

To display the limits:

1. Be sure that you are connected to a device (see Connecting to the laser device) and that you have
activated the Manual Mode (otherwise, the Limits buttons are unavailable). To activate it do one of
the following:

w
o Select %! Switch to Manual Mode on the toolbar.

o From the Laser Editor menu bar, choose Laser > Switch to Manual Mode.

Note: This is a toggle button: if the Manual Mode is activated, the tooltip says Switch to Auto
Mode, and vice versa.

2. Do one of the following:

0 To see the engraving limits for one ore more specific objects, select the object(s) and click

x

on 7% Limits on selection on the toolbar. (Alternatively, choose Laser > Limits on
selection from the menu bar).

0 To see the engraving limits for the whole graphic area, click on filJ Limits all on the
toolbar. (Alternatively, choose Laser > Limits all from the menu bar).

0 To see the engraving limits for the sectors that compose the object when engraving on a ring

document, click on Limits previous sector and Limits next sector buttons on the
toolbar. The buttons become available (green colored) after pressing either the Limits on
selection or Limits all button. (Alternatively, choose Laser > Limits next sector and Limits
previous sector from the menu bar)
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The example below shows how the limits for a sheared word (Editor) would appear.

Editor

Related topics:

e Setting custom laser parameters

e Simulating the marking operations

e Connecting to the laser device

e Send marking
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Simulating the marking operations

Laser Editor can be used to simulate the engraving results, that is, when you are finished creating the layout,
you can test the engraving via a video graphic simulator before sending it to the device for marking.

Tip:
@ To verify the final result of your layout, as well as its marking time, you can use the Mark
preview function (menu File > Mark preview). For further information, see Marking preview.

If you are not connected to a device, pressing F5 or Send Marking (which would otherwise start the laser
engraving), results in a graphic window being displayed, which simulates the engraving operation. The
simulation maintains all the speed, filling, wobble or other parameters set in the document.

Attention:

The simulation can only be done in Manual Mode. In Auto Mode the feature is not available and
l the laser engraving is managed automatically through the Laser Engine (see Auto mode vs.
= Manual mode). Note that, when in Auto Mode, the Simulator button is pressed meaning that the

device is working in simulation.

To simulate the engraving:

1. Be sure that you have activated the Manual Mode. To activate it do one of the following:
w
o Select 5+l Switch to Manual Mode from the toolbar of Laser Editor.
o From the Laser Editor menu bar, choose Laser > Switch to Manual Mode.

Note: This is a toggle button: if the Manual Mode is activated, the tooltip says Switch to Auto
Mode, and vice versa.

2. There are two possible scenarios:

o If you are not connected to a device, pressing F5 (or clicking “I> send Marking) will
automatically activate the simulator.

W
o If you are connected to a device, the m Simulator button is enabled and you must press
it (or choose Laser > Simulator from the menu bar) to activate the graphic simulator.

The following picture shows an example:

M Dsp Simulator
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3. To interrupt the marking simulation, use the ‘e Stop marking toolbar button (or choose Laser >
Stop Marking form the menu bar).

Related topics:

e Setting custom laser parameters

Displaying the limits

Connecting to the laser device

Marking preview

Send marking
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Connecting to the laser device

Attention:

The following connection procedure only applies to users who have a Supervisor installation
of Laser Editor. (For further information, see section Installation types and connection
modes).

In Laser Editor, the laser device that is used for marking graphic layouts is managed by the Laser Engine
interface and can be either local, in the case of a stand-alone marking solution, or remote, in the case of an
unattended marking solution, typically on a production line.

In particular, the connection mode (local or remote) depend upon your type of installation:

e If you have an unattended Supervisor installation of Laser Editor, you can use the procedure that is
described here below to remotely connect to a Laser Engine, provided that the remote control has
been enabled. (See Local/Remote control).

e |If you have a Stand-alone installation (without remote control), you can only access the Laser
Engine interface that controls your local device. The Connect to device buttons of Laser Editor that
are described in the following procedure, are not available for this installation type.

For further information about using the Laser Engine interface, see chapter Laser Engine User
Interface.

To set your Windows Firewall so as to enable remote connection:

This operation is required in order to enable remote communication between Laser Editor and Laser Engine.
It involves setting your Windows Firewall properly:

1. Click Start, click Control Panel, and then double-click Windows Firewall.

2. Select the Exceptions tab, and then click Add Port.

3. Inthe Port number box, type 4659 and then click OK.

4. Repeat step 3, but type 4657 in order to open the port for files and binary data transfer.

To connect to the device:

1. Do one of the following:
o From the Laser Editor menu bar, choose Laser > Connect to device.

b
0 On the toolbar, click 4 Connect to device.
2. Inthe Connect to device window that is displayed, select the device you want to connect to.

Ny

Note that all the available devices are listed, both local and remote devices. In the case of a remote
device, the IP Address is also displayed.

3. Click OK. Note that the status bar of Laser Editor shows both the status of the connection and
information on the connected device.

Related topics:
e Simulating the marking operations

e Send marking
e Laser Engine User Interface
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Send marking

Laser Editor allows two ways for sending a graphic layout to marking:

e In Manual Mode - By pressing F5 (or choosing Laser > Send Marking) to send a layout. By

pressing F9 or click on (or choosing Laser > Send Marking on selection) to send a selected
objec. If you are operating on a stand-alone marking unit, and are interacting directly to the laser
device, you can either use the simulator to test the layout, or send it to marking. (See Simulating the
marking operations).

e |n Auto Mode - By saving the graphic layouts to the device. The layouts will then be sent to marking
based on the programs that have been created via Project Editor.

Note:
@ The functions described in this section are also accessible via the Laser Engine interface. For
further information, see chapter Laser Engine User Interface.

Auto mode vs. Manual mode
By default, the Auto Mode is selected, but you can switch between working modes.

The main difference between these working modes is that in Auto mode the command for sending
documents to marking can be external, that is, can be executed from the PLC; whereas, in Manual mode, the
operator has full control and no external signals are considered.

Here below, a short description of how each mode works is provided.
Auto mode
The Auto mode is the default operating mode.

When the application starts in Auto mode, the document or project that is saved to the device and is set as
the default is automatically sent to marking. External signals from the PLC are also executed.

In the case of a project, documents that will be sent to marking depend on how the program was written.
(See Project Editor's Help for further information). For example, a program can be used to automate
operations such as updating a counter.

Note that, in order to use Laser Editor for interactions with the laser device, that is, setting the laser
configuration parameters or sending documents directly to marking, you must switch to the Manual mode.

The Auto mode is particularly useful in work environments where the operator assigned to engraving is not
authorized to edit the engraving layout or where complex projects are to be executed.

Manual mode

In this mode, the operator has full control, that is, he/she selects the document to be marked and no external
signals are considered.
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Note that, you must activate the Manual mode in order to create and test a layout before saving it, or if you
want to change the laser configuration parameters. Engraving simulation and testing operations are only
available in Manual mode.

Behavior

Typically, in this mode, you can do the following:

w
e Select the project or document to be marked and then press B

o |f needed, perform any editing or testing operation prior to mark.
e In work environments such as a production line, after selecting the document, you can activate
the Auto mode so as to enable external starts from the PLC.

To switch to Auto Mode if Manual mode has been activated:
e Choose the Laser > Switch to Auto Mode from the menu bar.

or

w
e Click on “%*! switch to Auto Mode on the toolbar.

Sending the layout to marking
To send a layout directly to marking:

1. Be sure that you are in Manual Mode. To switch to this mode, do one of the following:
0 Choose Laser > Switch to Manual Mode from the Laser Editor menu bar.

o Click & Switch to Manual Mode on the toolbar.

2. PressF5or click on” ™ Send Marking on the toolbar. (Alternatively, choose Laser > Send
Marking from the menu bar).

Important note:
l!.! If you are not connected to a laser device, the graphic simulator will automatically be activated
— instead. (See Simulating the marking operations).

w
3. To interrupt the laser marking or the simulation, use the ‘@ Stop marking button on the toolbar
(or choose Laser > Stop Marking form the menu bar).

To save a layout to the device for next marking:

1. From the Laser Editor menu bar, choose File > Save to Device or press ,b on the toolbar.

2. In the Save document as window that is displayed, select from the Devices dropdown list the
device you are sending the layout to.

3. Enter a name for the document and click OK. This is the name that will be used in the Project
Editor to write a program to upload the document send it to the engraver in an automated way.

Note:

The Project Editor is a tool integrated into Laser Editor that allows creating customized
@ programs. To access it, choose File > Project Editor. The tool has its own context-sensitive

Help and it is used to automate marking procedures, or to update the layout contents at

runtime. Default programs and easy-to-use examples are provided with the tool.
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6- LASER ENGINE USER INTERFACE

This chapter describes how to use Laser Engine, which is an application that is provided with Laser Editor
and allows operating on the laser device.

The interface allows previewing how a document or project that was saved to the device will be marked, as
well as performing many other fine-tuning operations before marking.

Laser Engine can be installed with Laser Editor or independently, and available buttons or functions may
differ depending on the installation type that you have chosen when installing Laser Editor. For further
information, refer to Installation types and connection modes.

For further information:

Topic See
Launching Laser Engine Click here
Laser Engine's user interface overview:

e Main window elements

e Menu buttons Click here

e Shortcut menu commands
Managing users and access rights Click here
Using the global variables function Click here
Switching between working modes (Local/Remote or Auto/Manual) Click here
Configuring the laser device parameters Click here
Using the "Marking on the Fly" function to mark objects in movement Click here
Displaying the marking limits Click here
Managing axis and executing the focusing test Click here
Correcting lens distortions Click here
Sending documents to marking Click here
Viewing the device status Click here
Using the log file to fix problems that might arise Click here
Testing the system's connections Click here

Note:

Laser Engine can now be integrated into customers' applications as an ActiveX server.

Developers can now write their ActiveX clients and build highly customized user interface for
@ their clients, using Laser Engine to control the laser.

To this purpose, a new object has been created as entry point in the ActiveX server. (For

further information, see the Project Editor online documentation, "Language Reference"

chapter).

This feature must be licensed.

141



LASER EDITOR

Launching Laser Engine

To launch Laser Engine:

1. After you install Laser Editor, the Laser Engine icon appears on the applications toolbar, as it is
shown below:

Laser Engineicon

v
TPE 14.25]

2. Todisplay the Laser Engine user interface, do one of the following:

-

o Double-click the Laser Engine icon to display the application window.
0 Right-click the Laser Engine icon, and then click Show.

3. To close the Laser Engine window, do one of the following:
0 Click the Close button at the top right of the window.

0 Right-click the Laser Engine icon, and then click Minimize.

Note:
@ Starting from the release 5.3, you can also launch both Laser Engine and Laser Configuration

. Lo

-
from Laser Editor, by using the ad hoc toolbar buttons * & ! or the Laser menu commands.

For further information on the elements that appear on the window, please refer to section User interface
overview.
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User interface overview

This section provides a quick reference to the graphical user interface of Laser Engine, both for the functions
available in the main window and for the shortcut menu that you access by right-clicking the Laser Engine
icon in the applications toolbar.

For further information:
e Main window elements
e Menu buttons
e Shortcut menu commands

Main window elements
The picture below shows the main window of Laser Engine when you access it.
In this example, a document is selected whose contents are displayed in the Preview area:

L.

3

[Documenu [ Device Skatus |

it Counter

[_ é[[lif[lil—l_l@
(D3

“TBEW 16.25

The numbered elements are described below:

| Area |Description

accessing the main functions. All buttons are toggle: move the pointer over a button to see the

® Menu buttons - The left side of the Laser Engine window contains the buttons that allow
current selection. For more information on each button, see Menu buttons.
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©

® Q0 ®

Documents and projects saved to the laser - The Documents tab that is shown at the startup,
lists all the project or documents that have been saved to the device and that you can send to
marking (see Sending documents to marking):

e the “ icon indicates a document (.xIp) created with Laser Editor

o the ™ icon indicates a project created with Project Editor

e the === jcon indicates a sequence (.xse) created with Laser Editor
When you select an item, the Preview area displays the contents. If a sequence if selected, the
first document in it is displayed.
Note that right-clicking a document or a project, results in a shortcut menu opening that allows
you to delete the element or to set it as the default, that is, as the document or project that will be
selected at Laser Engine startup:

Docurnents Z hxis Roktor fxis

File name Ent

o FdRS-232 %05

Set &5 default
Deleke

Tabs - In this area, the following tabs can be displayed:

e Documents, that lists the project and documents, as it is explained here above. For
further information, see Sending documents to marking.

e Device Status, that shows information relating to the status of the laser device. It is a
read-only tab. For further information, see Viewing the Device Status.

The availability of the following tabs depends upon the laser source you are using and how it is
configured, that is, if axis are enabled. For further information, see Managing axis and executing
the laser test.

e X-Y Axis, that allows managing the horizontal and vertical axis prior to marking a plane
document.

e Z AXis, that allows managing the Z axis prior to marking, as well as executing the laser
test for focusing.

e Rotor Axis, that allows managing the R Axis prior to marking a ring document.

Document's or project's preview - If you select a document (as in the example), this area
shows how the graphic objects will be actually marked. If you select a project, it gives you
information on the project.

Marking time - It previews the required marking time, based on the objects to be marked,
showing also the progress.

Zoom function - In the case of a document, it allows zooming the objects to be marked.

Device status icon - It tells you the current status of the device: for example a yellow icon
means Device ready, while a red icon means Device busy. For further information on device
statuses, see Viewing the Device Status

Laser Engine icon on the applications toolbar - Right-click this icon to open a shortcut
menu that lists a number of commands. See Shortcut menu commands for further information.

144



LASER ENGINE USER INTERFACE

Menu buttons

Information:
| If users access control has been enabled and you do not have proper rights to use the buttons,
L. you will be prompted for a password with rights. (For further information, see Managing users

and access rights).

The following table provides a short description of all available menu buttons. A link to the relevant section in
this chapter is provided.

Buttons Description

to Local/to Remote - It allows specifying the Laser Engine supervision level: it can be Local

(Laser Editor and Laser Engine are on the same machine) or Remote (Laser Editor and

Laser Engine are on different machines.) After setting the Remote control, operators who

have a Supervisor installation type might control remotely the laser.

This button is only available if you have an Interactive installation with remote control
/ allowed.

By setting the Remote control, all other buttons become unavailable.

For further information, see Local/Remote control.

to Auto/to Manual mode - It allows switching between working modes. This button is only
available if the Local control has been activated.

When the Auto mode is activated, the engraving operations are executed automatically.
The Manual mode is used for editing and testing graphic layouts.

You can set the default working mode via the shortcut menu. For further information,
see Auto/Manual working mode.

Start - It allows sending a document to marking, or stopping the marking operation,
w

/ ; respectively. When pressed, this button changes to ‘a

[} This button is only available if the Local control has been activated. For further information,

s see Sending documents to marking.

Start Limits - It allows displaying the margins of the graphic objects to be marked.
For further information, see Displaying the limits.

Limits previous sector / Limits next sector - These buttons allow displaying the margins of
| the sectors that compose the objects to mark, when engraving on ring documents. The
I buttons become active after clicking on Start Limits.
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Shortcut menu commands

Right-clicking the Laser Engine icon on the Windows application toolbar, results in a shortcut menu opening:

Minimize

Show

R R

| Always on kop

dser management

Global variables

R

Wiew log

Swskem test

Laser configuration

Lens correction

Start in auto mode

Start in remate mode

it

1707

Right-click the Laser
Engine icon to display
the shortcut menu

The commands available on the shortcut menu are shortly described below. A link to the relevant section in
this chapter is provided.

'Menu command

Description

|Minimize/Show

|Allows minimizing or displaying the Laser Engine user interface.

/Always on top

|AIIows keeping always visible the Laser Engine window.

User management

Allows accessing the user management function. You must have the appropriate
privleges to manage users. See Managing users and access rights for further
information.

Global variables

Allows accessing and managing the global variables; these are strings or counters that
are stored in a small database at the device level. If users management has been
enabled and access to this function has been limited, you will be prompted for a
password with proper rights. See Using global variables for further information.

View log

Log, that allows checking what happened during the work session. For further
information, see "Understanding the log file" on page 179.

System test

Displays the dialog that allows checking your hardware and cables connections.
See Testing the system for further information.

Laser configuration

Allows accessing the parameters for configuring the laser. See Configuring the laser
parameters for further information.

Lens correction

Allows opening the wizard that you can use to correct lens distortions. See Correcting
lens distortion for further information.

Start in auto mode

Allows specifying the working mode that must be activated at startup. See Auto/Manual

Start in - remote working mode for further information.
mode
|Quit |Exits the Laser Engine interface. Use this command if you need to restart Laser Engine.
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Managing users and access rights

Minimize

Abaays on bop

Lises managenment

Ghobal vanables

View log

Syshbem test

Laser configuration

Lens correction
Statinaomods

Start in remoke mode

Quit

The User management function allows you to set and mange the users' rights on the system.

By default, Laser Editor does not request any login and any user can access and manage all system's
functions.

To change this setting, you must first enable the Users management function by entering a unique

password that gives you administrator privileges; then, you can specify the rights on the system's functions
for specific classes of users.

Note:

m This function is also accessible and usable at the Laser Editor level by clicking the >
Manage device users button on the toolbar or by choosing Manage device users from
the Laser menu.

To enable the users management and to set the access rights:
1. Right-click the Laser Engine icon on the Windows applications bar.
2. Onthe shortcut menu that appears, click User management.
3. The dialog box for typing the password is displayed:

i Please enter password x|

Please enter password to confirm operation:

Passward: |

(¥ Do nat rermember

i~ Remember For | Irinukes
i~ Remember until program is closed

o | cancel |

147



LASER EDITOR

4. Type a unique password of your choice.

Note: If

5. Specify
specific

the password you specify is not unique in the system, an error message will be displayed.

whether and how long the system must remember your password: You can specify either a
time interval in minutes, or the entire program's session. Once the specified time is elapsed,

the password will be requested to enter the function.

Note: To change the administrator password, or to disable the users access control, see Disabling
users' access control.

6. Click OK. The User management window will be displayed.

. User management e 2
Manage users| Auto/manual | Manage layouts | Programiming | Laser configuration | Global variablesl

administrator | 4] = ¥ M
Everyone 3]
Operator (*
Designer (*)
Developer (*)

(*) Disabled users because no password is sst Set passwords I

Ok I Cancel I

The left
can limi

side of the grid lists the available types of users, while in the upper part the functions you
t the access to are listed. An asterisk (*) indicates that the access control is currently

disabled for those users because no password has been set, and a selected checkbox indicates that

the user

has rights to the function.

Available users are:

(0]

(0]

Function name
Manage users

Auto/Manual

Manage layouts

Programming

Laser
configuration

Global variables

The Administrator has full rights on the system's functions and can manage the users'
rights; you cannot edit this user.

The Everyone user is the default user, who has all rights except the users management
function; it is editable and you can use it as a basis for setting the other users' rights.

Three additional types of users are provided: Operator, Designer, and Developer. These
represent the typical operators of a laser system for whom you might limit the access rights
to the functions.

The functions you can limit the access to are:

Allowed operations
This function allows managing users' access rights to the system.

This function allows switching between manual and auto working mode. See Auto mode
vs. Manual mode.

This functions allows creating a layout and sending it to marking. See Creating graphic
layouts.
This function allows implementing a project with Project Editor and then sending it to
marking. (See the Project Editor's online help that is integrated into the Laser Editor help
system.)

This function allows accessing and configuring the laser configuration parameters.
See Configuring the laser parameters.

This function allows creating global variables that you can access both from Laser Editor
or from the Laser Engine interface. See Using global variables.
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7. To enable the access control for the Operator, Designer, or Developer user, in the User
management window click Set passwords. The Change passwords window is displayed.

¢ Change Passwords

Mew password: I

Repeat password: |

ik Cancel Apply

8. Click the User arrow to display the list of users and then select the desired user, for
example Designer.

Note:
m Select Administrator to change the current password, or to disable the users access control by

entering an empty password.

9. Type a unique password of your choice, and then confirm it.
10. Do one of the following:
0 Click OK to return to the User management window.
o Click Apply to clear the fields if you want to disable access control for the user, or if you
want to change the password.
11. Note that the Designer user inherited all Everyone's rights, that is, has access to all functions, but
the checkboxes are still unavailable and you cannot clear them.
12. To limit the access rights to a specific function for the Designer user:
o0 Clear the corresponding checkbox for the Everyone user.
o0 The checkbox becomes available for the Designer user also; clear it to limit the access to
the function for this type of user, as shown in the example below:

Manage users | Autofmanual | Manaoge layouts | Programming |Laser configur
Administrator | [ & bl
Evaryone ] |
Operator () | |
Designer O +] B ]
Devaloper {*) . | . h-:

13. Click OK to save your settings. The next time users try to access the Laser configuration function,
the system will prompt them to enter a password with the appropriate privileges.

Note:
Some functions are dependent to each other. For example, a user who has access rights to

@ Programming must also have access rights to Manage layouts and Auto/Manual, so the system
will prevent you from disabling them.
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Disabling users' access control

To disable the access control for a type of user or for all users:

1.
2.
3.

Access the user management function using the Administrator password.
In the User management window click Set passwords.
Click the User arrow to display the list of users and then do one of the following:

0 Select Administrator to disable access control for all users. This way, all users will have
access rights to all functions.

0 Select the type of user you want to disable from the User list.

Leave the Passwords fields empty and then click OKif you want to close the Change
password window, or click Apply to keep it open.

In the message window that is displayed, click Yes.

To re-assign the access to a function for a type of user:

1.
2.
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Access the user management function using the Administrator password.

In the User management window, select the checkbox corresponding to the function you want re-
assign.

Click OK.
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Switching between working modes
In this section:

e Local/Remote control

e Auto/Manual working mode

Local/Remote control

Notes:

The Remote/Local button is only available if your installation is Interactive with remote control
@ allowed (For further information, see Installation types and connection modes).

By default, at the startup, the local control is enabled. This way, only authorized operators can

activate the remote control so allowing remote connections from other operators in the network.

The Remote/to Local button of the Laser Engine left menu, allows specifying who is supervising the Laser
Engine, that is, who is controlling and can actually send commands to Laser Engine.

The button is toggle: Move the pointer over it to see the current selection. In the figure below, the Local
control is activated:

Dacui

() —y [toRemote

Local control

The Local control is used when Laser Editor and Laser Engine are both installed on your PC, that is, if you
are locally connected and directly controlling the laser source.

In this case, Laser Engine will accept commands from you, but not from other operators on the network.
Behaviour when resuming Local control from Remote control

If the Remote control has been activated and you need to make changes at runtime, such as displaying limits
or testing a layout, do the following:

e Click the to Local button in the left Menu of Laser Engine to resume the Local control.

e You will be notified if other operators are remotely connected and remote connections will be
terminated.
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Remote control

The Remote control is used when Laser Editor and Laser Engine are installed on different machines, that is,
when operating in a network.

This allows different operators to establish a remote connection so as to send commands to Laser Engine,
which will accept commands from the first operator who connects.

Only operators in the network who have a Supervisor installation of Laser Editor can remotely connect to
Laser Engine. (For further information see Installation types and connection modes).

Behaviour:
e Click the to Remote button in the left Menu of Laser Engine to set the Remote control.

e The laser source connected to Laser Engine will appear on the list of available laser sources for
remote connection.

e From Laser Editor, an authorized operator (with a Supervision installation) clicks the Connect to
device button and then selects the laser source from the list that is displayed. (See Connecting to
the laser device).

Auto/Manual working mode

Notes:
@ This button is only available if the Local control has been activated (see Local/Remote control).

The Auto/Manual button of the Laser Engine left Menu, allows switching between working modes. The
button is toggle: Move the pointer over it to see the current selection. In the figure below, the Manual mode is
activated:

To Auko Mode
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For further information, please see chapter "Performing the engraving operations”, section Auto mode vs.
Manual mode.

You can set the Auto mode as the default working mode, that is, as the mode that will be used at Laser
Engine startup.

To set the Auto mode as the default working mode:
1. Right-click the Laser Engine icon on the Windows applications bar.

2. On the shortcut menu that appears, click Start in auto mode to set it as the default mode. Note that
the menu command is now checked:

Wiew log

Swsbam bask

Laser configuration

Lens correckan

I v ISI:art im auko mode

3. To deselect the default mode, click it.
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Configuring the laser parameters

i rrilze

Akways on kop
User management
Global variables
View log

System best

ILarser configuration

Lens correckion

v | Start n auko mode

Start i remote mode

This chapter describes the laser configuration parameters that you can set to configure the laser devices for
optimal engraving performance.

To access the Laser configuration window:

1.

Right-click the Laser Engine icon on the Windows applications bar.

2. Onthe shortcut menu that appears, click Laser configuration.

P

Attention:
If users management has been enabled and access to this function has been limited
(see Managing users and access rights), you will be prompted for a password with proper rights.

3. The Laser configuration window is displayed, allowing you to set all the properties for the laser

devices you are connected to.

4. To set parameters, use the following tables as a reference:
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Setting the laser parameters

Setting the correction parameters

Setting the aiming parameters

Setting Input/Qutput parameters

Setting the X, Y, Z, and Rotor Axes parameters
Configuring the Marking on the Fly function
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Setting the head scanner parameters

The Scanner page of the Laser configuration window, is used to set the scanner speed and the waiting
times for adjusting the engraving quality with respect to running times.

Properties .
Group Property Description
E];F;f/s?peed Speed the scanners use when moving between polygons (that is, when not marking).
Passive g-switched laser sources “oscillate' at start up, resulting in first line(s) being
progressively thicker. The Scan Ramp parameter sets a time (expressed in
Scan Ramp| .- ; on
millisecond), for the scanner to accelerate from zero to maximum speed: this allows to
[ms] - . .
reduce the flaw. This parameter needs only to be set for passive g-switched laser
sources.
Scan Acceleration needs to happen only at start up to allow emission stabilization. The Scan
Threshold  |Threshold is the amount of time that must elapse (after the laser has been switched
[ms] off) for the acceleration ramp (see Scan Ramp) to be repeated.

The position the scanner moves to when standing-by, that is, at the end of the marking
operation. If the emission cannot be completely stopped, this parameter allows moving
the scanner so as to prevent damages. Possible values are:
Scan e Center, moves the scanner to the origin. This is the mandatory setting if you
are using the Marking on the Fly function (for further information,

ﬁi?t?gz see Configuring the Marking on the Fly function).

e Corner, moves the scanner to the bottom left corner. If this option is selected,
the Corner Position fields are displayed below, indicating the exact position in
points. By default, this position is the farther from the origin.

e Dynamic, moves the scanner dynamically back to the center after elapsing a
certain amount of time.

Corner
Position Indicates the position of the corner along the X coordinate.
[pts] X
Corner
Position Indicates the position of the corner along the Y coordinate.
[pts] Y

Refers to the waiting times required for high quality engraving. K and C are two variables, where K is
the proportional coefficient for speed and C is constant. The system calculates the waiting times for
the movement of the laser according to these parameters. Waiting times are all expressed in
microseconds [us]. (For further information, see Calculating waiting times).

K first [us]
Polygon . . . . . . . . .
Delays C first [us] e First = First point of a vector. (That is, waiting time before proceeding with the
K next [us] first movement.)
C next [ps] e Next = Conjunction point between two vectors
K last [us] e Last = The last point of a vector
C last [ps]
C on [us] The time that the laser spends to mark an individual pixel.
Raster The waiting time before the laser marks the next pixel. The higher this time, more
C off [us]
Delays powerful the next pulse.
Cline [us] |The waiting time between lines, that is, before the laser marks the next line.
The time that elapses before the system actually start emitting.
C draw [us] |The laser system can have a sort of inertia, that is, a response delay between the
Laser "emission" signal and the actual emission.
Delays

The time that elapses before the system extinguish the laser emission.

C jump [ps] This phenomenon is complementary to the one originating the Cdraw delay.
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Calculating waiting times

The engraving process is achieved by means of a laser beam deflection device controlled by two retroactive
electrical drives (PID) which angular position is proportional to the control voltage provided. Due to the very
nature of the system, the reaction time (phase) of the drives is not negligible. If this reaction delay wasn't
taken into account, poor results would be obtained: the solution is that the control system waits the mirror for
correct positioning before proceeding.

The waiting times required for high quality engraving are illustrated below. Waiting times are linear functions
(linear phase) of the engraving speed; this is why they are parameterized by two variables: K, proportional
coefficient for speed and C, constant. The system computes the waiting time according to these two
parameters with the following formula:

Speed
T=C+K.

Max speed

The speeds indicated in the formula are expressed in thousands of coordinates per second and the
maximum reference speed mentioned in the formula is equal to 1000 [Kcoord/s], which corresponds to the
following speeds expressed in [mm/s] according to the lens:

e f100=1133.3 mm/s
e {160 =1822.2 mm/s
e 254 =2900.2 mm/s

Note: Waiting times are all expressed in microseconds [ps].

The following example shows how to engrave the word "LASER". Thick lines indicates actual marking, thin
ones a jump of the mirrors (that is, a movement of the mirrors between marked vectors):

The following examples will better illustrate how incorrect technical waiting time setting can affect the result.

TFirst [us]
Waiting time for the scanner to actually reach the required position before switching the laser on.

e |If the delay is lower than the optimal value, notice how
the first vector of each polygon is distorted and longer
than the correct length.

e If the delay ishigherthan the optimal value, the
engraving process will be slower but no effects will be
visible.
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TNext [us]

Waiting time for the scanner to reach the correct position before tracing the vector after the first with the
exception of the last. This waiting time is according to the engraving speed and depends on the angle
between the two consecutive vectors. If the angle is equal to 180°, the waiting time will be equal to zero,
while the waiting time will increase as the angle decreases, the time being maximum when the angle is equal
to zero degrees.

e |If the delay is lower than the optimal value notice how
the polygon vectors are rounded and not sharp

e If the delay is higher than the optimal value, notice
how the polygon vectors are more marked and deeper
than they should be.

TLast [us]

Waiting time for the scanner to reach the correct position before switching the laser off (scanning the last
vector of a polygon).

e If the delay is lower than the optimal value, notice how
the last polygon vectors are shorter and incomplete.

o If the delay is higher than the optimal value, notice
how the vector end points are more marked.

TDraw (Diode Laser) [us]

Time the system takes to actually start emitting. Even if low, the system can have a sort of inertia, that is, a
response delay between the "emission" signal and the actual emission.

This time does not depend on speed (only constant component in the formula is required).

o If the delay is lower than the optimal value, notice how
the first vector of each polygon is shorter.

o If the delay is higher than the optimal value, notice how
the initial vector points are deeper.

Note: Tdraw is usually smaller than Tfirst. Since they both deal with the starting point of the first vector, the
first is usually neglected.
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TJump (Diode Laser) [us]

Time the system takes to extinguish the laser emission. This is the complementary phenomenon to the one
originating Tdraw,

This time does not depend on speed (only constant component in the formula is required).

e |If the delay is lower than the optimal value, notice the
blurring between the polygons.

e If the delay ishigherthan the optimal value, the
engraving process will be slower but no effects will be
visible.

Setting the laser parameters
The Laser page of the Laser configuration window, contains the following parameters:

Note:

m The Laser source is set to the default parameter that has been set for Laser Editor. For further
information, see Setting the laser parameters (Laser page). You can still set a source type other
than the default one.

Properties
Group

Laser

Property

Source Type

Edit advanced
parameters
button

Description

Power Change
Type

LaserLink
diagnostic

Description

This is the currently selected laser source.

This button enables more parameters that allow configuring the laser source,
SO as to suit your needs. This function is intended for specialized technicians
who will be provided with an ad hoc password.

This parameter is displayed after activating the Edit advanced
parameter function.
It allows entering a description of the laser source.

This parameter is displayed after activating the Edit advanced
parameter function.
Some systems (especially lamp ones) have high “optical inertia’: they take
time to stabilize laser emission after power supply has changed. Diode
sources behave this way only if the level ramp starts below emission
threshold. This parameter can have two values (do not change settings in
laser.ini file):

e Once: Power Change time (see Delays parameters) is applied only

on the first engraving pen down (diode sources)

e Always: Power Change Time is applied to every level variation (lamp
sources)

It allows enabling/disabling the communication with the external device so as
to check its state before marking. If it is set to False the check is not
performed.

158



LASER ENGINE USER INTERFACE

Levels

Delays
Parameters
First Pulse
Killer

Enable
continuous
emission

If this property is set to True, you will then be able to set to 0 the Frequency
parameter. The Frequency parameter is used to adjust the laser output
frequency by directly operating on the Q-switch; it can be set at documents
or objects level (see Laser properties for documents).

The Q-switch is an electro-optical system which controls the opacity of a lens
making it possible to change the laser beam frequency. Setting to O the
Frequency parameter prevents the emission from being discontinuous

Power level signal controls the electrical current fed to the laser diode: the higher the
current, the higher the power emitted. It is expressed as a percentage of the maximum.

Min. Level [%)]
Thermal
Level [%]

Max. Level
(%]

Ramp Time
[ms]

Power
Change [ms]

Stand by [s]

Shot Time
[bs]

Shot/Base
Frequency
[HZ]

Minimum allowed power level signal. This is the value the software uses
when the user sets to 0% the laser power.

Level signal the laser moves to when standing-by.

Maximum allowed level signal. This is the value the software uses when the
user sets 100% laser power.

Time, expressed in milliseconds, for effecting the ramp used to pass from the
minimum level to maximum level.

Thermal standby, expressed in ms, it is the standby time between the end of
the level ramp and start of engraving. This standby serves for the laser to
stabilize before starting to work.

Expressed in seconds, this is the standby time between the end of engraving
and the level ramp which resets the minimum value (of standby). This
standby lets the laser remain stable between two close engraving with
consequent saving of work time.

Duration of the laser shot pulse i.e. the time the Q-switch is open (or, better,
transparent). Crystal unwinding time is always order of magnitude faster than
shot time therefore this parameter affects shot energy only indirectly as it can
be used to tune crystal re-populating time (it begins only when Q-switch is
closed).

This parameter sets default Q-switch frequency. Frequency is inversely
proportional to laser beam power, that is, if the frequency is too high, the
power may not be sufficient for the engraving process. Frequency can be
changed trough the user interface and be customized for each object but
raster engraving with LEVEL technique uses this parameter as Pixel Rate,
that is, the rate at which pixel are generated (and therefore scanner moved).
In this case the "Shot Frequency' parameter is used to control Q-Switch
modulation. Setting it to zero (O)causes Q-Switch modulation to be
synchronous with scanners movement (that is, one pulse per pixel).

FPK: When operating on a steady Q-switch frequency, the power of the pulses emitted
depends upon the frequency itself (as this is the time the crystal take to repopulate), and the
level of the optic pump (the diode). However, the very first pulse is different because crystal
population increased a lot during the stand-by time: energy of the first pulse can be times
bigger than the following pulses. The FPK is a technique to avoid the first pulse.

FPK Delay
[us]
FPK Level
[%]

Time the level or pen down signal is low to suppress First Pulse Killer (FPK).

Level of the first pulse killer.
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Power Rule

Frequency Rule

Speed Rule

Delay Rule

The following parameters are displayed after activating the Edit advanced
parameter function.

Min Power |This ruse is used to control the beam peak energy does not overtake

[%0] damage limits. Low frequencies correspond to high single shot energy.
Scanning mirrors can be damaged by single high energy shots.
Max Power ) ) -
[%] Power rule consists of a list of five parameters.
The first two parameters indicate the absolute minimum and maximum
Constant power level allowed.
Power Third and fourth parameters are used to calculate maximum power related

Correction [%] |to selected frequency according to this formula Pmax = C + K * F
Gain Power \Where Pmax is the maximum power allowed, C (Constant Power
Correction Correction) and K (Gain Power Correction) are the numbers in the rule and
[%/Hz] F is the current frequency.
Fifth parameter is used to set the Power Offset. In certain types of laser
(fiber laser) the relation between the power level and the power output is
Offset Power Such that, at a power level of zero, the laser emits already a significant
Correction [%] [@mount of output power. Offset Power Correction parameter represents the
percentage of power level that is emitted when the laser is set to the
minimum power level.

The following parameters are displayed after activating the Edit advanced
parameter function.

Min

Frequency

[Hz] Defines minimum and maximum frequencies [Hz] allowed (comma
Max separated).

Frequency
[Hz]

The following parameters are displayed after activating the Edit advanced
parameter function.

Min Speed
[Kpts/s] Defines minimum and maximum marking speed [mm/s] allowed (comma

Max Speed separated).
[Kpts/s]

The following parameters are displayed after activating the Edit advanced

parameter function.

Min Delay ) o )

[ms] Defines minimum and maximum dot delay [ms] allowed (comma
separated). Dot delay is used in vectorial marking and it is the time used to

Max Delay |mark the "dot" entity.
[ms]

160



LASER ENGINE USER INTERFACE

Setting the correction parameters

The Correction page of the Laser configuration window is used to set the optical correction required to
recover the distortion of mirrors and lens.

Properties o
Group Property Description
Focal Length |It contains a list of available optical lenses that you can install on the
[mm] scanner head of the laser device.
. This button allows duplicating a lens to be used as a template for creating
Duplicate lens !
L a new one. You can then set the Lens parameters to suit your needs.
ens
Delete lens This button allows deleting a lens created by the user.
This button allows importing a lens using another configuration file
Import lens (laser.inz). This way, you can use a configuration of a custom lens that
was executed on a different device.
Parameters in this area allow the user to orientate the optical field in whatever direction he
is comfortable in.
Reverse X axis |If itis set to True, X axis parameters are reversed. False is the default.
Reverse Y axis |If it is setto True, Y axis parameters are reversed. False is the default.
) Swap X axis and Y axis.
Field The three axis reverse parameters are used to direct the engraving field
Orientation in the four angular positions, as described below:

. e (0°rotation : None
Swap X-Y axis i
e 90° rotation : Invert X + Swap X-Y.
e 180° rotation : Invert X + Invert Y.

e 270° rotation : Invert Y + Swap X-Y

Parameters in this area allow the user to set his own optical corrections (for example, if
scan head is not properly aligned with the marking filed).

Use correction |If it is set to True, allows you to specify the path of a custom file to be

file used for Field Correction.
Offset X [pts] It allows aligning horizontally the field.
Offset Y [pts] It allows aligning vertically the field.

Scale X [%]
Scale Y [%]

Theta X [deg] ) .
Optical Theta angles used to calculate optical correction.

Correction Theta Y [deg]

Scale factors used to correct magnification.

Horizontal sides |These parameters correct an error introduced when scan head is not
ratio [top/bottom] |properly aligned with the marking field.

Vertical sides | This produces a deformation of the field from a square into a trapezium.
ratio [right/left] To fix the problem, use the Diagonals ratio parameter.

Rotates the optical field to align it to the physical field. Since this
operation introduces errors near the field borders, only values lower than
1° are accepted.

Field rotation
angle [deg]

The ratio between top and bottom sides (Horizontal sides ratio), right and
Diagonals ratio  |left sides (Vertical sides ratio) that a user can use to fix a deformation
adjusting the optical correction.
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These parameters allows configuring your own lens. They are used together with
the Duplicate - Delete and Import lens_buttons. (See above)

Description A string describing the lens.
Focus Depth Range along the Z axis the beam is focused.
Nominal  Focal
Length [mm] These parameters determine the size of the marking area and other
L Real Focal properties of the system.
ens Length [mm]
parameters

Field Width [mm] . . . . . , .
Marking field dimensions. The optical field is always a square, but

Field] Height physical can have different measures in actual application.

mm

Mechanical Field

Side [mm] Side of the marking field square.

Logical Field | This value is used to perform conversion between points and millimeters.
Side [pt]

Setting the aiming parameters

The Aiming page of the Laser configuration window, is used to correct the pointer limits in relation to
engraving so as to obtain perfect overlaying, since the power laser and the pointer laser wavelengths are
different.

Resonator can contain a red light diode. This is used to highlight marking area to the operator usually in
industrial applications. Not every laser has a red diode.

The different wavelength of the visible red diode with respect to laser light causes a different refraction inside
the objective lens. As a consequence the coordinate generated when displaying layout limits must be
corrected to match layout engraving.

This page allows some tuning on limits placement; if the result appears still wrong, please contact the
technical support team.

Properties _

Group Property Description

Scanner [Slfp?trs]/s] Speed Scanners speed used when tracking limits, expressed in Kspots/s.
Offset X [pts] Alignment offset expressed in points, applied to X coordinate when

P tracking limits.This value is limited to +1% of the coordinates range.

Offset Y [pts] Alignment offset expressed in points, applied to Y coordinate when

c i P tracking limits.This value is limited to +1% of the coordinates range.

orrection

Scale applied to X coordinate when tracking limits.This value is limited to
+5% (95+105%).

Scale applied to Y coordinate when tracking limits.This value is limited to
+5% (95+105%).

Scale X [%]

Scale Y [%]
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Setting Input/Output parameters

The Input / Output page of the Laser configuration window is used to set durations and delays of laser
Input signals in relation to engraving.

Properties o
Group Property Description
Start time [ms] |Sets the minimum duration, in ms, of the start engraving signal.
InoUts Start delay Sets the delay, in ms, between acceptance of the start engraving signal
P [ms or mm] and actual start of engraving.
Stop time [ms] |Sets the minimum duration, in ms, of the stop engraving signal.
Delay between the work in progress (Laser Busy) signal and actual laser
Busy advance 7 ; NS .
[ms] emission. Th|s.parameter may be useful if this signal is used to open an
electromechanical shutter.
Busy delay Delay between the end of actual laser emission and the end of Laser
[ms] Busy signal.
. Duration of the end engraving signal (Laser End) after Laser Busy signal
Outputs End time [ms] ends. 9 g signal ( ) y sig

If set to true the SW_Ready signal goes high when a document or a
sequence is in AUTO MODE. This setting maintains the same

Sw Ready management as Smartist.

Compatibility |If set to false the SW_Ready signal go high when a document or a
sequence is in AUTO MODE and the laser status is READY (Key=active;
Enable=active)

Setting the X, Y, Z, and Rotor Axes parameters

The pages Y Axis, X Axis, Z Axis, and Rotor Axes are used to set the parameters related to the three
mechanical axes whose movement are controlled by step motors.

In particular:
e Z axis is the mechanical axis. It allows focusing on different levels.

e X, Y, and Rotor axis are the mechanical axes used to position objects under the laser via step motor
control.

Axis management and settings depend on the board controlling their movement. These parameters are
typically used by who installs and sets the step motor for axis management. (For further information,
see Mechanical axis management).

Properties _
Group Property Description
These two parameters set the conversion between motor steps and axis movement.
The number of steps to move the motor to the distance given a the Units
Steps [steps]
value.
c . The distance to move the axis when the motor moves the specified
onversion number of steps. The units value depends on the axis you are
Units managing: if this is a rotary axis, the value is in degrees (e.g., the
[mmi,inch,deg...] |number of steps to rotate of 360°); if this is a linear axis, the value is
expressed in a linear unit of measure, which is the one you have set for
the application.
. It it is set to True (default), enables the axis management. The relevant
Parameters Enable axis

tab will appear in the Laser Engine window.
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Dedicated 1/Os

It only applies to the rotor axis (R Axis). It allows managing up to 4 axis,
totally independent of each other. To this purpose, a new outputs set
can be managed.

If set to True, check the 1/0s documentation related to your control
board and then connect the R Axis to the dedicated outputs set.

If set to False, check the 1/0Os documentation related to your control
board and then connect the R Axis to the outputs set used by the X
AXis.

The following parameters allow the user to set a speed that best fits the mechanical
characteristics of the motor in use, so as to prevent the motor from sliding. You can use
either steps or units as the unit of measure.

Start speed
[steps/s]

Start speed
[units/s]

Speed [steps/s]
Speed [units/s]

Ramp time [ms]

Reset at same
speed

Reset start speed
[steps/s]

Reset start speed
[units/s]

Reset speed
[steps/s]

Reset speed
[units/s]

Reset ramp time
[ms]

Brake release
[ms]

After move delay
[ms]

Home search
direction

Reset on Startup

The motor speed at the beginning of the acceleration ramp.

The motor speed at the end of the acceleration ramp.

The time employed by the acceleration ramp to go from minimum
speed (Start speed) to working speed (Speed).

If set to True, the same speed that you have set above will be used for
axis reset (home search).

If set to False, some properties will appear below allowing you to enter
a different speed for the home search.

The motor speed at the beginning of the acceleration ramp during reset
operation. (These parameters are displayed if the Reset at same speed
value is set to False).

The motor speed at the end of the acceleration ramp during reset
operation. (These parameters are displayed if the Reset at same speed
value is set to False).

The time employed to accelerate from minimum speed (Reset Start
Speed) to working speed (Reset Speed). Axis reset is performed at a
different speed to seek for maximum precision. (These parameters are
displayed if the Reset at same speed value is set to False).

Electromechanical brake release time. This is the time that elapses
between the brake release signal activation and the start of mechanical
movement.

Settlement time between the end of the axis movement and the
marking start. After the motor (especially rotating ones) reaches the
position, a time must elapse to stop vibrations; this time depends on
system inertia.

The direction of home search. It can be set to Auto, Decreasing motor
steps, or Increasing motor steps.

In particular, the Auto option allows to directly search the home in the
correct direction, based on the current position of the axis.

If it is set to True, the axis will be moved in Home position at Laser
Engine startup.




LASER ENGINE USER INTERFACE

The following parameters refer to the minimum and maximum limits (in steps) that the
axis can reach.

Minimum [steps] o o
— - Minimum motor position limit
Minimum [units]

Maximum [steps] . T
- - Maximum motor position limit
Maximum [units]

Zero [steps] Position of the logic zero in relation to the mechanical zero. Each

Limits movement of the axis is considered in relation to the logic zero.
Zero [units] Conversely, home search locates the mechanical zero (home sensor).
Ring Offset Logical zero offset of axis Z in the revolution center. This parameter
[steps] enable the possibility of using two zero logical reference, the logical
Ring Offset |zero for layer documents and ‘Ring Offset’ added to logical zero for
[units] Ring documents.

The True value sets the reverse of axis logic. It can be used when
Reverse axis axis orientation is reverted, so that the mechanical zero is placed
where the operator expects.

The following parameters can be used to test the settings during setup phase.

It enables the search of the home sensor (mechanical zero) at the

Home search speed that has been specified for the Reset parameters.

Move to [steps] ) o ) -
, These parameter allows moving the axis in the desired position
Move to [units]

Commands The following parameters are read-only and depend upon the three parameters above.

If checked indicates that the home position (mechanical zero) has

Home flag been reached.

Current  position

[steps] It shows the last position the axis has reached (steps or units)
Current  position [accordingly to the Move to parameters.
[units]
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Configuring the Marking on the Fly function
Attention:
A The Marking on the Fly function is only available on iMark control boards.

When this option is enabled all objects are automatically ordered so that they will be marked in the opposite
direction of the roller. In this way we take advantage of the movement to extend the marking field.

This feature is typically used on a production line where a conveyor roller is connected to the laser system,
and both are controlled by a PCI control board.

You might connect an encoder to the system for best performances or set the Continuous marking mode to
mark repeatedly the same content.

A Wizard is provided that you can access from the Marking on the Fly configuration window, which helps you
to properly configure and use this function.

When using an Encoder

When high quality or high precision is required, for example, in the case of very small laser markings, an
encoder allows for best performances.

The encoder counts the roller movements and instantly determines its speed. This allows to obtain the
correct position of the moving target and to ensure high marking precision.

When the target is detected by the sensor and the start is given, the encoder calculates the target's position
by giving a specific amount of pulse counts for a specific distance.

Time for calculation is allowed by the Start Delay property.

Tip: If you are not using an encoder (e.g., if the target moving speed is known or no high marking
@ precision is required), you can simulate it by enabling the Simulation parameter, ant then
specifying an average speed.

When using the Continuous marking mode

The Continuous marking mode allows setting the laser so that the same marking will be repeated at
predefined distances or intervals.

Typically, it is used when you need to mark repeatedly a continuous tube at a specified distance.

When you set this mode, the sensor detects the target and the start is given only once; then, the marking is
repeated every time the specified distance is reached.

If an encoder is being used, the distance value for repetitions must be set in mm, while if no encoder is being
used, the value is set in ms.

Setting the configuration parameters

Prerequisite:

In order for the Marking on the Fly function to work properly, it is mandatory that you set the
A following parameter:

Laser Configuration > Scan parameters > Standby Position = Center
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By clicking Marking on the Fly in the Laser Configuration window, the following configuration window
opens.

£ Marking on the Fly Configuration

(] Enabile Marking on the Fiy
Encoder

[[] swrwdation
Scale Factor 105,00 [courksjmen] =
[ reverse ercoder

Offset 0 [mm) -

Linit [wm] £

Start: delay 155 [mm] -

Dustaree 0 [imen] -

I | = |

Note that a Wizard is provided that guides you through the correct setup of hardware connections and
parameters that control this function. (See Parameters description for a description of all parameters).

The following describes how the Wizard is to be used.

Using the Wizard

1. In the Marking on the fly configuration window, click Wizard. The first window displays that allows
checking the hardware and cable connections.

# Markyng on [ Iy Configuration

Hardware and cables connection

Welcome 10 the Mark on Fiy configuration wazard

This wizard will drive you trough the system configuration for eplimal markang on moving
targets This page will help you check that hardware and connections are working property
Fallow the instructions in this box to complets the set up procedure

@) Power on the transport belt. If the encoder 15 properly connected, the gear image should
animate If it does not, check the connections

b) ¥your system does not have an encoder select the checkbox 1o simulate encoder signals.
c) Activate the extemal start signal and verify that the LED turns grean

Prass "Next" to continue

Shart Signal
- - - - - - - =
Tnput 0 Trgnd | Ingnt 2 gt 3 Trgai 4 Irgn 5 Trpuit & ot 7
- = - El - e - =
Treput & Trgut @ nput 10 Tpet 11 Trpue 12 Trput 13 Input 14 Trgue 15
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2. Follow the instructions as described in the Wizard to check that everything is connected and working
properly and that the photocell is correctly mounted:

a. If you have an encoder, after powering on the transport belt, ensure that the blue gear in the
window animates.

If you do not have an encoder connected to your system, select Simulate Encoder Signal.

After activating the external start signal, ensure that the Start Signal led in the window turns
green.

Input 0 tol5 turn green to indicate currently active input signals, if any; otherwise, they are
grey (if not in use or inactive).

@ Tip: If you only need to check hardware and cables connections, you might close the Wizard.

3. Click Next. The Scan Head Position window is displayed that allows defining the origin of the object
to mark relative to the marking field in order to determine the correct marking direction:

@ Markyng an Fly Configuration '? ﬁ

Scan Head Position

This page will help you st the comect onentation parameters of the laserfransport system

a) Tumn the kaser on and activate the aiming beam if it i1s off

b) Press the "Run” button. The laser will draw an amowy with the red aiming beam. Place a
white paper shaet under the scan head In case you cannot sae it

¢} The amow should point the same direchon the belt 15 moving. If not press the "Rotate”
button undll it does

d) Start the transport - the transport must be running whan you press "Nex"

Prass "Mext" to continue.

=2

s Rotate

<Back || Met> || conesl |

4. Follow the instructions and complete the test as described in the window until the arrow points
correctly.
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5. Click Next. The Speed conversion window is displayed that allows calculating the Scale
Factor that defines the speed of the transport belt. This way you do not need to use specific
instruments to calculate this value:

@ Markyng on Fly Configuration H; E|

Speed conversion

This page computes the transport speed

a) Power off the transport belt

b} Flace two or more objects at the same distance on the transport belt
) Set the distance between objects in the editbox

d) Power on the transport balt

The "speed” aditbox will display the computed transport belt speed

Prass "MNext” 10 continue

istance betwaen bao tigger [mm]: 201

Spend 20978

[ <back || Met> || cancel |

6. Follow the instructions as described in the window.

The value that is displayed in the Speed box after completing the test is the value that is to be used
to calculate the Scale Factor that must be entered in the Marking on Fly Configuration window
(counts/mm if you have an encoder, mm/sec. if you are using the simulation). The speed
corresponds to the number of pulses that elapse between the objects to mark.
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7. Click Next. The Start Delay window is displayed that allows calculating the distance between the
start sensor, which detects the object to mark, and the center of the marking field. This test does not
actually mark; rather, it allows checking that the distance is correctly set:

@ Markyng on Fly Confliguration

Start Delay

This page will help you set the comact distance betwsen start sensor and marking field

a) Power off the ransport balt

b} Flace one or more oljects on the ransport Dalt

) Measure the distance between the sensor and the center of the field marking as indicated
in the drawing and input it

d) Press the "Run” button

&) Power on the ransport belt

The laser will rack a small circle on the object{s) with the red aiming beam while they ana
moving. If you cannot see the cicle(s) either the distance or computed speed (previous page)
IS Incormect

g
;
g
g

< Back beats || conent |

|
]

8. Follow the instructions as described in the window.

After pressing Run, ensure that the small circle that the laser tracks is pointing the target when this
arrives in the marking field. If not, verify the Start delay distance, and then repeat the test. If
the Start delay is correctly set, you must recalculate the computed speed (Wizard window Speed
Conversion).

9. Click Next. The Fine Tuning window will displays that allows fine tuning the parameters and
verifying that the speed of the transport belt (Scale Factor) has been correctly calculated. The test
will actually execute a marking while the belt is moving.
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10.

11.

12.

13.

@& Markyng on [ ly Configuration

Fine tuning

This page will help you fine tune parameters in order 1o have better marking quahty. A circle
will be engraved on & targel obiect to check parameters

a) Power off the transport belt

b Flace one object on the ransport belt

¢) Press the "Run” button

d) Enable laser marking

&) Power on the transport belt

f) Check that the circle has been marked comectly, otherwise press the figure that more
closely resembles the figure marked - this changes the speed - repeal the prevous steps

Fress "Finish” to save the configuration

Larser i 4
p——
I OmRO
Frequency @ (0000 ¥
Scanspeed OO0 -
Speed: | 104,00 -
| <Bace || msn || conew |

Follow the instructions as described in the window. Note that by repeating the test and selecting the
desired circle, the speed changes until the circle is marked correctly.

You might also change the Power, Frequency, and Scan speed values to suit your specific needs,
based on the material on which you are marking.

When finished click on Finish.

Complete the parameters in the Marking on the Fly Configuration window, as needed. See the
table in the following for a description.
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Parameters description
The table here below describes the parameters that appear in the Marking on the Fly window:

Property
group

Encoder

Direction

Settings

Parameter

Enable the
Marking on
the Fly

Simulation

Scale factor

Reverse
encoder

Position

Offset [mm]

Reverse
polygon
ordering
Unit [mm] or
[ms]

Start Delay
[mm] or [ms]

Continuous
marking

Distance
[mm]

Description

Select the checkbox to enable the feature.
(For best practices in setting this feature so as to follow your needs, see When
using an Encoder and When using the Continuous marking mode.)

If this option is selected, Encoder is simulated by the iMark control board, that is,
the laser will chase the target at the given speed.

The conveyor roller (or the target moving) speed. There are two possible scenarios:

e If an encoder is being used, this value corresponds to the number or pulses
for millimeter, as measured by the encoder.

e If you are using the simulation, you must specify a value that corresponds
to the average roller speed based on the time (in mm/sec.).

Use the Speed conversion window of the Wizard to calculate this value.

It allows reverting the signal to the encoder so reverting the marking direction.

The axis along which the targets are marked on the conveyor roller, relative to the
head scanner.

Use the Scan Head Position window of the Wizard to correctly determine the
direction.

An additional offset that can be used to fine-tune the marking operation. Negative
offsets will move the layout in the direction that the target is coming from. Use this
parameter to adjust layout position and take full advantage of target movement to
extend marking field. The following picture shows how this parameter affects the
marking operation:

B

N
: °
<
[
It sets the ordering of the polygons, based on both the scan head configuration (X /

Y Axis) and the direction of the object to mark.
Use the Scan Head Position window of the Wizard to set this parameter.

Measure unit, either in [mm] or [ms], for the Start Delay parameter.

Distance in [mm] or delay in [ms] between the center of the marking field and the
Proximity sensor.
Use the Start Delay window of the Wizard to calculate this value.

Select this option if you want to mark the same layout repeatedly at a specific
distance.

If an encoder is being used, this value is in [mm]. If you are using the simulation,
this value is in [ms].

The distance in [mm] between markings when the Continuous marking mode is
enabled.

172



LASER ENGINE USER INTERFACE

Setting the network parameters

The network configuration window contains the following parameters:

Properties
Group

Network

Send
Date/Time

Local area
connection

Property

Device Network
Name

Updates
Date/Time on
the device

DHCP Settings

IP Address
Subnet Mask

Default
Gateway

Preferred DNS
Server

Alternate DNS
Server

Description

Specify the name of the device used by Lighter in a
remote mode environment. It is useful when many
laser are connected to the same network and you
need to recognize them.

If Use DHCP is set, the IP address is assigned
automatically (check if your network support this
capability).

If Specify IP address manually is set, you have to ask
your network administrator for the appropriate 1P
settings.

IP Address of device
Subnet Mask

Default Gateway
Preferred DNS Server

Alternate DNS Server
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Managing axis and executing the laser test

Note:

The X-Y Axis, Z-Axis and Rotor Axis tabs of the Laser Engine interface are only available if the
@ laser is compliant and properly configured, that is, if axis have enabled at the laser configuration

level (see Setting the X, Y, Z, and Rotor Axes parameters).

In particular, the Rotor Axis tab, is only available if a rings separator is installed on your device.

Laser Engine provides you with a graphical user interface for directly manage axes movements, which are
controlled by step motors.

You can move an axis either by setting axis parameters, or by using the arrow keys on your keyboard.

For further information:

Topic Contents
Mechanical axis management A brief technical description of how the software manages axis.

Using the X-Y or Rotor Axis tabs
for axis management

Using the Z Axis tab for axis |How to manage the mechanical axis that allows focusing on different
management and laser test levels and how to execute the laser test.

How to manage the linear or rotary mechanical axis of your device.

Mechanical axis management
Description of the settings related to axis requires a brief description of the way the software manages axis.

Axes reference

The figure below shows axis logical (blue) and mechanical (black) references. These can be different as
logical representation is built upon what the operator expects while mechanical representation depends on
design choices or needs. In the figure, Z axis shows this difference: orientation is reversed and logical zero is
placed on a totally different quote than mechanical zero (where the zero sensor is placed).

Step motors drive axis movement. Axis can be either linear or rotary. Devices that drive axis movement
obviously have Minimum and Maximum, that is, quotes than cannot be outgone; this is true for rotary axis as
well: even though rotation could continue, limits are set so that reference cannot exceed them.

v

Mechanical zero

fero i
L Logic zero

S Working plane

Max >
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Linear vs. rotary axis
The software drives axis in the same way, be they linear or rotary.

The main setting is the conversion between motor step and axis movement. In linear axis this is the number
of steps to move the motor of Imm (or any other reference: 1meter, linch, etc.); in rotary axis this is the
number of steps to rotate of 360° (or any other angle measure).

Inversion indicates rotation direction in rotary axis.

Mechanical zero

Zero

Logic zero

-

Using the X-Y or Rotor Axis tabs for axis management

Attention:

These tabs are only available if axes are enabled at the laser configuration level (see Setting the
X, Y, Z, and Rotor Axes parameters).

Fields on the tabs are only available if the Local control and the Manual mode are activated.
(See Switching between working modes).

X, Y, and Rotor axis are the linear and rotary mechanical axes used to position objects under the laser via
step motor control. (See Mechanical axis management for further information).

By using these tabs, you can control axes movements and objects position on the working plane.

To manage axes:
The example below describes how to use the X-Y Axis tab to check and manage the linear mechanical

axes. Using the Home Search command button, results in the axis motor moving so as to reach the
proximity sensor. The meaning of the fields on the Rotor Axis tab is identical.

175



LASER EDITOR

1. Selectthe X-Y or Rotor Axis tab of Laser Engine, depending on which axis you are moving.

Documents Device Stabus XA s  Axis Foatar &xis

Home Seardh >

X=0.00, ¥=0.00 X Axis
000, 00,
| Harme Flag

Minimim Position  -200
Maxirmum Postion 200

ik

Current Position | 0,00

¥ s

Hame Flag
Minimum Pogsidon  -1000
Maimum Position 1000

(1]

Current Position | 10,100

Za0d. 00 T T T T Tgnn.0o

The example above represents a working plane with two linear axes that move the object in the X
and Y directions; it shows you the position of the laser spot on the plane.

2. Click Home Search. If the Home Flag is not checked, that is, if the zero has not been reached, the
motor starts moving towards the proximity sensor, until the sensor is reached. The motors will not
move if the Home Flag is already checked.

3. The parameters underneath means the following:

o Home Flag - This checkbox is selected if the zero has been reached, that is if the 0 sensor
is activated.

0 Minimum position - The minimum motor position that the axis can reach.
o0 Maximum position - The maximum motor position that the axis can reach.
o0 Current position - It shows the last position the axis has reached.

Using the Z Axis tab for axis management and laser test

Notes:

The Z Axis tab is only available if the axis is enabled at the laser configuration level (see Setting
@ the X, Y, Z, and Rotor Axes parameters).

Fields on the tab are only available if the Local control and the Manual mode are activated.

(See Switching between working modes).

The Z Axis is used to focus the laser on different levels. (See Axes reference for further information).

By using the Z Axis tab you can also perform the laser test for focus. (See Executing the laser test for
focus).
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Managing the Z Axis
The example below describes how to use the Z Axis tab to check and manage the axis. Using the Home
Search command button, results in the axis motor moving so as to reach the proximity sensor.

1. Selectthe Z Axis tab of Laser Engine.

Documents Device Status A Rxis Z Axis Rator Axis
- Hame Search »
330,00~ 520 00 SIS . -lN—
Axis
Home Flag
Mirsmium Pastion 1]
Maimun Postion 330
Current Position 330,00 >
Laser Test
Tvpe Lire i
Size 10,00 v
Powier 0 v
Fraquency 20000 -
0.00

Prass an "Arrow Key” For continuows movement or
“CTRL+Arrom Ky For pulse mevement

2. Please, refer to the previous section To _manage axes: for further information on the Home
Search button and parameters underneath.

Executing the laser test for focus
This function allows searching the focal plane.

For optimal performance, when engraving the laser head must be at the correct focus distance from the item
to be engraved.

The laser test allows engraving a geometric shape with predefined parameters and position the axis at the
same time.

To execute the test:
1. Selectthe Z Axis tab of Laser Engine.

2. Under Laser Test, set the following parameters:

o From the Type dropdown list, select the required geometrical shape for the test (Square,
Line, Circle, or Dot).

o Specify the Size for the shape and the laser output Power (expressed in percentage),
according to your device's maximum power.

0 Specify the laser output Frequency. This parameter is used to adjust the laser output
frequency by directly operating on the Q-switch.

3. Click;[to launch the test. A greater interaction of the laser with the material under
examination indicates that the optimal focus has been obtained.

Tip:
@ The correct position can be identified as the engraving point in which the laser generated noise
and luminosity are at the maximum.
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Correcting lens distortion
In laser marking, lens and mirrors that are used to deflect the laser light, produce distortions whose
correction is critical to an accurate marking operation.

The Lens Correction function provides a way to easily correct this phenomenon.

Related topics:

e Setting the correction parameters
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Sending documents to marking

Notes:
This button is only available if the Local control is activated. (See Switching between working

@ modes).

To select a document, or to perform testing operations, as well as to make any other change, you
must activate the Manual Mode (see Auto/Manual working mode).

By using the Laser Engine interface, you can send to marking any document that has been saved to the
device. (See Saving a layout to a device).

To send a document to marking

1. Be sure that you are in Manual working mode. (To check the current working mode, move the

pointer over the button.)

2. Inthe Name area of the Documents tab, select the .x1p document you want to mark.

w
3. Click “ to send the document to marking. To stop the marking click ‘@,

Note that, as the laser marks, in the lower part of the Preview pane, the progress bar moves and the
marking time decreases.

Tip:

The Laser Editor's Mark preview function (see Marking preview), that allows previewing how

lines will be marked by the laser and verifying the marking time, has been implemented as a
@ scripting object. Programmers can add the object to their user interface to allow operators to

check the layout being engraved.

(For further information, see the Project Editor's online documentation, "Language reference"

section.)
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Viewing the Device Status

The Device Status tab of the Laser Engine interface is a read-only window that shows the device status
information. It is available only if you are using ULYXE or VLase devices.

The colored icon at the right-bottom of the window shows the device status (see table Icons representing the

device status).

In addition to provide status information, this feature helps you to diagnose or correct errors that might arise.

Docurnents Device Stabus

System Information
Diode Serial Mo,
Conkrol Unit Firrmwsare version

Resonator Firmware version

Diode Data

Ternperabure

Converter Data

Temperature

Input Yoltage

Working Time - hhhhhimm:ss

Deode

Power Board Firmware version

Cormmand Box Firrmware version

Current

Heat Sink Temperature

Systeam

5.52 & Lasar READY
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The status icon on the right-bottom of the window changes accordingly to the device status. The meaning of
each icon is described in the following table:

Icons representing the device status
Icon Device Status Meaning

U OFF The laser is OFF or disconnected.

This status means that the VLASE is connected, no error is detected, but
it cannot be used. Possible reasons are:

WARNING e key sequence is incorrect
&\ e emergency has been activated
@/ e the laser is warming-up

@ Tip: For a detailed description, as well as for troubleshooting warnings, please refer to
the manual provided by your laser source's manufacturer.

. WAIT The laser is waiting for input.
STAND-BY or o o .
READY The laser is in stand-by or it is ready, and the shutter is closed.
. READY The laser is ready to be used.
J:\r BUSY The laser is currently marking.
N

The laser device is in an error status.
ERROR When the error status is detected, neither documents nor projects can be

G sent to marking.

@ Tip: For a detailed description, as well as for troubleshooting error conditions, please
refer to the manual provided by your laser source's manufacturer.
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Understanding the log file

Minirmize

Akways on top
Liser management
Global variables
View log

System best

Laser canfiguration

Lens carreckion

w | Start in aukto mode

Start in remote mode

The View log shortcut menu command of the Laser Engine interface lists all actions that have occurred so
allowing to correct any problem that might occur.

The default size for the log file is set at Laser Editor level via the General page of the Laser
Editor Configuration window, as shown below. For information on accessing this window, see Setting
language, measurement unit and graphical effects (General page).

Default parameters configuration x|
=
Lingar: [l =
Decimals: |Z ﬂ
—
Logging
Max log space [KB]: | 1000000 =
T i _-..

In particular, the Max log space parameter defines the disk space for log files. When the system date
change, the application check if this space has been exceeded, and if true, oldest files are deleted.
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To access the Log:

1. Inyour Windows application bar, right-click the Laser Engine icon to display the shortcut menu.
2. Click View log to display the log file.

To increase the maximum log level, see To increase the log level here below.

To understand the log file

The information on the log file is colour-coded to help you understand if action is required:
e Black colour - Informational message. No action is required.
e Blue colour - Warning messages. Action might be required.
e Red colour - Error messages. Action is required.

To increase the log level

To increase the log level, that is, the level of detail for the log file, you must modify the following Windows
registry key:

1. Open the open the Registry Editor (click Start > Run and then in the Open text box, type regedit.)

2. In the Registry Editor window, navigate to the registry location
HKEY KEY LOCAL MACHINE\SOFTWARE\Laservall.
Note that the Laservall folder contains three subfolders: Laser Engine, Laser Controller,
and Laser Editor, each containing a LogLevel value that refers to that particular component.

3. Click the folder for the component whose log level you want to increase to display the values.

4. Right-click the LogLevel value and click Edit to open the edit window.

5. In the Value data field, change the value as required. Note that the default value is 4 that
corresponds to the lowest level of detail. Lower the value, higher the log level, that is, set this value
to O for the maximum level of detail.

183



LASER EDITOR

Testing the system

Minimize

Always on top

ser management
Global variables
Wiew log

Laser canfiguration

Lens correckion

v | Start n auko mode
Start in remote mode

Quit

The System test shortcut menu command of the Laser Engine interface allows accessing the dialog where
you can check your system's connections.

In particular, besides testing the Laser, you can test allInputs and Outputs, as well as the
external Start and Stop signals.
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To test the system's connections:
1. Inyour Windows application bar, right-click the Laser Engine icon to display the shortcut menu.
2. Click System test to display the dialog:

= : : <
f‘ System Test - . ﬁ

Laser Test
Type | Line -
Size 26,00 8
Power g2 =
Frequency 25000 -
> |
| Input Test

@' @ @ @ @ @ @ @ stont
-

G.—
®: ®° O 1 S S @ @ stop

Output Test
) u'| ) 1] P @ ||; 4] | @5 |G 6 G ?| [ @ Ready |
@: @ 'Q 1u ®: P @ iG 14 G 15!

Change all uutput5|

To test the Laser:
1. Under Laser Test set the following parameters:

o From the Type dropdown list, select the required geometrical shape for the test (Square,
Line, Circle, or Dot).

o Specify the Size for the shape and the laser output Power (expressed in percentage),
according to your device's maximum power.

o Specify the laser output Frequency. This parameter is used to adjust the laser output
frequency by directly operating on the Q-switch.

2. Click the button launch the test.

To test the inputs:

The inputs are activated/deactivated via the external Start and Stop commands. If the inputs do not become
green (activated) something is wrong in your connections:

e When the external Start is pressed, the Start led becomes green. Check that the Input leds become
green.

e When the external Stop is pressed, the Stop led becomes green.

185



LASER EDITOR

To test the outputs:
To test the outputs connections you must manually activate them, either one by one or all at once:

~® System Test e — - E

Laser Test

Type Line -

Size 26,00 -

Power 82 =

Frequency 25000 g

L ]
L » ]
Input Test
® & @: @: &: O & @ @ sor

E N
17 ®: @®° & ®u: @1 ®: 912 @ @ Stop

Output Test

| @ @3 o
®: ®° (@

e To check the outputs one by one, click the relevant button.

e To check all outputs at once, click Change all outputs.

If the Output button changes to green, it indicates that it is activated and that all connections are set
correctly. If the output button is still grey, something is wrong in your connections.

o When the Ready button is green and activated, it indicates that the device is ready for the marking
operation.
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